Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: rlimit_max (1024) below minimum Windows limit (16384)

  1. #11
    Join Date
    Nov 2009
    Beans
    40

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    Does anyone know why this comes up?

  2. #12
    Join Date
    Jun 2009
    Location
    Open Linux Forums
    Beans
    2,710

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    just tested this on my lucid server and works like a charm.
    I'm not antisocial. I'm just not user friendly...
    Open Linux Forums

  3. #13
    Join Date
    Dec 2009
    Beans
    6,017

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    http://lists.samba.org/archive/samba...ry/153320.html :
    On Mon, Jan 25, 2010 at 11:44:03AM +0000, Miguel Medalha wrote:
    >
    > I just installed samba on a new server, 3.4.5-42, 64 bit version from
    > Sernet, over CentOS 5.4.
    >
    > When running testparm, I get the following warning:
    >
    > rlimit_max: rlimit_max (8192) below minimum Windows limit (16384)
    >
    > I searched Google for some answer but I couldn't find a satisfactory
    > one. What should I do to solve this?
    > Can someone from the Samba team enlighten me on this?

    It's a warning, you can safely ignore it. Windows 7 clients need to
    have exactly the same number of open handles available as Windows
    servers, else it fails in some file copy situations with a "out of
    handles" message. Samba has taken care of it for you, but it's just
    letting you know your fd limit is set a bit low.

    Jeremy

  4. #14
    Join Date
    Jun 2009
    Location
    Open Linux Forums
    Beans
    2,710

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    haha, that's good to know. so both scenarios work
    I'm not antisocial. I'm just not user friendly...
    Open Linux Forums

  5. #15
    Join Date
    May 2005
    Beans
    40
    Distro
    Ubuntu Development Release

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    Quote Originally Posted by Strongman332 View Post
    i have tried this and it did not work for me
    It does not work for me either.
    It is not ubuntu specific though, you can have the error on Centos 5:

    http://lists.samba.org/archive/samba...ry/153331.html

    and solaris as well:

    http://lists.samba.org/archive/samba...ry/153949.html

  6. #16
    Join Date
    Oct 2010
    Beans
    2

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    Hi! I tried this issue but the problem is still present:

    rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)

    thank you

  7. #17
    Join Date
    Dec 2009
    Beans
    6,017

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    Please see post #13.

    It's not a problem that needs to be fixed.

  8. #18
    Join Date
    May 2008
    Beans
    13

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    This did not work for me either (new lucid install). I noticed that the * domain specification does not apply to root (according to the files). Basically, this worked for me:

    Add the lines:

    * - nofile 16384
    root - nofile 16384

    to your /etc/security/limits.conf file
    and reboot.


    I really only needed the root line but include the * to be complete in providing a true *. Hope this helps,

  9. #19
    Join Date
    Feb 2009
    Beans
    9

    Re: rlimit_max (1024) below minimum Windows limit (16384)

    The line
    root - nofile 16384
    worked for me, but I guess it's because it was a server that I never log in to as an ordinary user - just root.
    Otherwise, you may need the "* - nofile 16384" line, or more exactly, replace the "*" with the user running samba.

    I did not have to reboot though, just logout and in again, then the warning was gone.
    I have not yet tried to reboot the server, so I don't know if this setting will survive a reboot - but it would be strange if not..

  10. #20
    Join Date
    Aug 2006
    Beans
    Hidden!

    Exclamation Re: rlimit_max (1024) below minimum Windows limit (16384)

    might not want to just blindly start changing config files, in general.

    For this particular item, not sure if this has been addressed yet, but here's a security reason for that setting of 1024

    https://lists.ubuntu.com/archives/ub...er/031446.html

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •