Results 1 to 10 of 135

Thread: Canon MF4350d - Printer Scanner setup

Threaded View

  1. #1
    Join Date
    Jan 2007
    Ridgeland WI US
    Xubuntu 14.04 Trusty Tahr

    Canon MF4350d - Printer Scanner setup

    May 21, 2012 - - - Update for Ubuntu 12.04 LTS

    When I installed Ubuntu 12.04 the system found the printer and installed a driver that does not work. It's not hard to get it working though.

    First you need the drivers from Canon's site. The download zipped file has both the 32 bit and 64 bit drivers. Note the steps below are for one specific version of the download. Hopefully Canon has updated it and you will be getting a newer version and need to edit the commands.

    The Canon support site is
    The drivers for the MF4350d are at

    Download the file to a known location like /home/user/Downloads

    # # # First is a how-to for 64-bit systems ONLY # # #

    Before doing this I had already installed Adobe's Acrobat Reader (acroread) which installed libc6-i386 ia32-libs lib32z1. If you have not installed Reader then run this:
    sudo apt-get install libc6-i386 ia32-libs lib32z1
    (mjpollard post #88 and Footer post #93)
    The 64 bit files are in RPM not DEB so you need alien to convert them
    sudo apt-get install alien

    For a 64 bit install I followed the work of bjtuna (post #80). I put custom installs in /opt so I edited bjtuna's steps for my preferences. The ln command was a major breakthrough, thanks bjtuna.

    sudo -i
    cp /home/user/Downloads/Linux_UFRII_PrinterDriver_V240_us_EN.tar.gz /opt/
    cd /opt
    tar xzvf Linux_UFRII_PrinterDriver_V240_us_EN.tar.gz
    cd Linux_UFRII_PrinterDriver_V240_us_EN/64-bit_Driver/RPM
    ln -s /usr/lib /usr/lib64
    alien -k -c cndrvcups-common-2.40-2.x86_64.rpm
    alien -k -c cndrvcups-ufr2-us-2.40-2.x86_64.rpm
    dpkg -i cndrvcups-common_2.40-2_amd64.deb
    dpkg -i cndrvcups-ufr2-us_2.40-2_amd64.deb

    Now jump to the common steps – skip the 32-bit stuff

    # # # Now the 32-bit version – it's easier # # #

    I did not test this. My last install was 32-bit but Ubuntu 11.04
    Get the driver and extract as above

    sudo -i
    cp /home/user/Downloads/Linux_UFRII_PrinterDriver_V240_us_EN.tar.gz /opt/
    cd /opt
    tar xzvf Linux_UFRII_PrinterDriver_V240_us_EN.tar.gz
    cd Linux_UFRII_PrinterDriver_V240_us_EN/32-bit_Driver/Debian
    dpkg -i cndrvcups-common_2.40-2_i386.deb
    dpkg -i cndrvcups-ufr2-us_2.40-2_i386.deb

    # # # Common Steps # # #

    Ubuntu 12.04 had already found the printer and installed a non-functioning driver for it. So the first step is to delete the printer that is installed. Next add a printer. Side bar: I'm using Gnome Classic (no effects). Printer maintenance menus there are incomplete. I had to log in using Ubuntu (Unity) to have printer maintenance functions. Add the printer and you are given several options for a driver. The correct one was the fourth, the one with UFRII LT. Sharing the printer was a pain. It was so easy in 9.04, now it's CUPS.

    For scanning I didn't install anything else. I didn't test scanning until after the printer was installed and scanning worked fine. I don't use the fax function so I don't know if it works.

    The following is the original post of March 11, 2010 – Not so useful except to understand what the posts that follow are talking about.

    # # # Original Post # # #

    Out of the box the Canon MF4350d doesn't work with Linux (except as a copier). So here is how I got it to work. I don't use or care about the FAX machine feature so I am ignoring that. This is an Image Class printer. The user guide says MF4380dn MF4370dn and MF4350d

    Canon has a site to download the driver HERE
    There I downloaded:
    Linux Printer Driver (UFR II) Ver.2.00E --- 2010-02-17
    Unpack it and find a pair of Drivers. In the Documents/ReadME you will find Ubuntu 9.04 32bit has been tested. The only 64bit systems are Fedora and RedHat. I could not get Ubuntu 9.04 64 bit to work, even with the rpm's for 64 bit. Anyway I just installed a 32 bit version of Ubuntu 9.04 and that worked fine.
    Before installing the debs (32 bit versions in download) you need to verify you have libcups2-dev. Get it with Synaptics. After libcups2-dev is installed just install the two debs.
    Now connect the printer - Search for it if things don't start popping up. It will want to install two print drivers. One is fax the other is a printer. Install using the recommended driver. Send a test sheet (I don't like the test page because it consumes way to much toner). If the first one works cancel the install of the second (fax).
    Pretty straight forward for a 32 bit installation.

    The sane version from synaptics will not work. You have to get an unreleased version.
    I followed a Linux-Mint post HERE Here are my steps...
    Synaptics - get libusb-dev --- without it no error messages will be generated but the scanner will never work.
    Get the unreleased version of sane from HERE
    Download the "Master" from the first line of the list.
    My download was 4.7 MB called:
    as root extract the tar-ball in /opt
    In a terminal
    $ sudo su
    # cd /opt/sane-backends
    # ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
    # make
    # make install
    # cd /etc/udev/rules.d/
    # gedit 40-scanner-permissions.rules
    In gedit paste the following three lines:

    # usb scanner
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE:="0666"
    Save it. Check that it's in the correct folder /etc/udev/rules.d/ (I did this wrong once).

    Reboot to have the new rules take effect.

    Start XSane and it should default to it or offer it in a list.

    I bought one for my mother and one for my wife while they were on sale ($130 with trade-in).
    Last edited by ridgeland; May 21st, 2012 at 12:40 PM. Reason: Ubuntu 12.04 steps
    Gigabyte GA-MA790GPT-UD3H - AMD Phenom II x3 720 - 8 GB RAM - 2009 - My first PC from parts!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts