Hi,
I tried to install the printer drivers for the Canon PIXMA iP3600 printer, downloaded from here: http://software.canon-europe.com/software/0031336.asp
There is a dependency problem of these packages, they depend on libcupsys2. This package has been renamed libcups2 (Canon seems to be slow in updating their packages). Although I have libcups2 installed on my notebook, and libcups2 provides the virtual package libcupsys2 (to satisfy such old dependencies), the canon printer drivers cnijfilter-common_3.00-1_i386.deb and cnijfilter-ip3600series_3.00-1_i386.deb still report a dependency error, and refuse to install. Could somebody explain me, why, and how to overcome this problem?
I could install them using dpkg -i --ignore-depends=libcupsys2, and they work nicely, but my system has now broken packages, and synaptic refuses to 'Mark All Upgrades', saying that I have broken packages, and I should fix them first.
Thanks