Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Synaptic will not install any program

  1. #21
    Join Date
    Jun 2010
    Beans
    8

    Re: Synaptic will not install any program

    i got rid of the one packet that i was having problems with now when i hit sudo apt-get upgrade this happens

    Code:
    mike@Mikes-Computational:~$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages have been kept back:
      linux-generic linux-headers-generic linux-image-generic
    The following packages will be upgraded:
      cairo-dock-plug-ins cairo-dock-plug-ins-data cairo-dock-plug-ins-integration
      compiz compiz-core compiz-dbg compiz-dev compiz-gnome compiz-kde
      compiz-plugins docky eucalyptus-common eucalyptus-java-common evolution
      evolution-common evolution-data-server evolution-data-server-common
      evolution-plugins fglrx-modaliases gdm gstreamer0.10-plugins-good
      gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pulseaudio
      indicator-application kdepimlibs-data kdepimlibs5 kpackagekit krb5-multidev
      libappindicator0 libc-bin libc-dev-bin libc6 libc6-dev libc6-i686
      libcamel1.2-14 libdecoration0 libdecoration0-dev libebackend1.2-0
      libebook1.2-9 libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6
      libedataserver1.2-11 libedataserverui1.2-8 libegroupwise1.2-13
      libexchange-storage1.2-3 libgdata-google1.2-1 libgdata1.2-1
      libgnomekbd-common libgnomekbd4 libgssapi-krb5-2 libgssrpc4 libido-0.1-0
      libk5crypto3 libkadm5clnt-mit7 libkadm5srv-mit7 libkdb5-4 libkrb5-3
      libkrb5-dev libkrb5support0 libpam-modules libpam-runtime libpam0g
      libpoppler-glib4 libpoppler5 libsdl1.2debian libsdl1.2debian-pulseaudio
      libservlet2.5-java libservlet2.5-java-doc libtomcat6-java libusb-0.1-4
      libvirtodbc-dev linux-firmware linux-libc-dev nvidia-current-modaliases
      openssh-client openssh-server pm-utils-powersave-policy poppler-utils
      python-appindicator python-docky python-ubuntuone-client software-center
      ssh-askpass-gnome telepathy-butterfly tomcat6 tomcat6-admin tomcat6-common
      tomcat6-docs tomcat6-examples tomcat6-user ubuntu-system-service
      ubuntuone-client ubuntuone-client-gnome udisks update-manager
      update-manager-core update-manager-kde virtuoso-nepomuk xserver-common
      xserver-xorg-core
    101 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    Need to get 20.4kB/72.4MB of archives.
    After this operation, 3,719kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://us.archive.ubuntu.com/ubuntu/ lucid-proposed/main libusb-0.1-4 2:0.1.12-14ubuntu0.1 [20.4kB]
    Fetched 20.4kB in 2s (8,327B/s)     
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 
    dpkg: warning: files list file for package `libaprutil1-dbd-sqlite3' missing, assuming package has no files currently installed.
    (Reading database ... 289340 files and directories currently installed.)
    Preparing to replace libpam-modules 1.1.1-2ubuntu2 (using .../libpam-modules_1.1.1-2ubuntu3_i386.deb) ...
    Unpacking replacement libpam-modules ...
    dpkg-deb (subprocess): error in buffer_read(stream): failed to write to pipe in copy: Input/output error
    dpkg-deb: subprocess paste returned error exit status 2
    dpkg: error processing /var/cache/apt/archives/libpam-modules_1.1.1-2ubuntu3_i386.deb (--unpack):
     short read in buffer_copy (backend dpkg-deb during `./usr/share/doc/libpam-modules/changelog.Debian.gz')
    No apport report written because the error message indicates a dpkg I/O error
                                                                                 Errors were encountered while processing:
     /var/cache/apt/archives/libpam-modules_1.1.1-2ubuntu3_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    mike@Mikes-Computational:~$

  2. #22
    Join Date
    Jul 2009
    Beans
    Hidden!

    Re: Synaptic will not install any program

    Code:
    sudo rm /var/cache/apt/archives/libpam-modules_1.1.1-2ubuntu3_i386.deb
    might help

  3. #23
    Join Date
    Jun 2010
    Beans
    8

    Re: Synaptic will not install any program

    can you copy that file and then put it on there so i can re download it in to the file system

  4. #24
    Join Date
    Jun 2010
    Beans
    8

    Re: Synaptic will not install any program

    just need to install things but the file is still missing and now i can upgrade my last 2 upgrades this is what happens

    Code:
    mike@Mikes-Computational:~$ sudo apt-get -f upgrade
    [sudo] password for mike: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be upgraded:
      compiz-core libcamel1.2-14
    2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/604kB of archives.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    (Reading database ... 
    dpkg: warning: files list file for package `libaprutil1-dbd-sqlite3' missing, assuming package has no files currently installed.
    (Reading database ... 312022 files and directories currently installed.)
    Preparing to replace compiz-core 1:0.8.4-0ubuntu15 (using .../compiz-core_1%3a0.8.4-0ubuntu15.1_i386.deb) ...
    Unpacking replacement compiz-core ...
    dpkg-deb (subprocess): error in buffer_read(stream): failed to write to pipe in copy: Input/output error
    dpkg-deb: subprocess paste returned error exit status 2
    dpkg: error processing /var/cache/apt/archives/compiz-core_1%3a0.8.4-0ubuntu15.1_i386.deb (--unpack):
     short read in buffer_copy (backend dpkg-deb during `./usr/bin/compiz')
    No apport report written because the error message indicates a dpkg I/O error
                                                                                 Preparing to replace libcamel1.2-14 2.28.3.1-0ubuntu2 (using .../libcamel1.2-14_2.28.3.1-0ubuntu3_i386.deb) ...
    Unpacking replacement libcamel1.2-14 ...
    dpkg-deb (subprocess): error in buffer_read(stream): failed to write to pipe in copy: Input/output error
    dpkg-deb: subprocess paste returned error exit status 2
    dpkg: error processing /var/cache/apt/archives/libcamel1.2-14_2.28.3.1-0ubuntu3_i386.deb (--unpack):
     short read in buffer_copy (backend dpkg-deb during `./usr/lib/libcamel-1.2.so.14.0.1')
    No apport report written because the error message indicates a dpkg I/O error
                                                                                 Processing triggers for man-db ...
    Errors were encountered while processing:
     /var/cache/apt/archives/compiz-core_1%3a0.8.4-0ubuntu15.1_i386.deb
     /var/cache/apt/archives/libcamel1.2-14_2.28.3.1-0ubuntu3_i386.deb
    E: Sub-process /usr/bin/dpkg ret

  5. #25
    Join Date
    Sep 2008
    Beans
    22

    Re: Synaptic will not install any program

    Quote Originally Posted by plucky View Post
    It seems to be having problems reading linux-headers-2.6.31-20.list.

    You could from a terminal
    Code:
    sudo mv /var/lib/dpkg/info/linux-headers-2.6.31-20.list /var/lib/dpkg/info/linux-headers-2.6.31-20.list.old
    Then open synaptic package manager and search for linux-headers-2.6.31.20 and reinstall which will recreate the list.It will complain that the file is missing,but it will then recreate it.

    Good Luck


    Plucky, you are my hero for the day. I attempted to install updates half a dozen times, using Synaptic, Aptitude, Apt-get, and was pretty well stumped. A quick google for key words from the error message brought me here.

    root@ubuntu-guy:/var/lib/dpkg/info# mv /var/lib/dpkg/info/libgssrpc4.list /var/lib/dpkg/info/libgssrpc4.list.old

    My next attempt installed all updates, no problems at all.

    Thank you, thank you, thank you!

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •