Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

  1. #1
    Join Date
    Mar 2006

    Talking Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    Lenovo put out a Netbook S10-3t, which is a tablet with a multi touch screen. Unfortunately, as of Ubuntu 10.4 Lucid Alpha 3, the Wi-Fi device is not enabled after installation of x86 Netbook

    The Wi-Fi device is Broadcom BCM4313 with pci code [14e4:4727], specification here:

    There is an open source driver b43 that as of 2.6.32-15-generic does not support this device code as can be seen here:

    Broadcom provides a binary/proprietary driver that does work as can be seen here:

    The driver does not work due to a packaging problem. The procedure to fix it is:
    A. install bcmwl-kernel-source
    B. activate broadcom driver via restricted drivers

    here is a detailed link:

  2. #2
    Join Date
    Mar 2010

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    Honestly I was looking for it from quite long. I didn't badly need it but yeah of course I was looking for it to fulfil my needs. And I am happy that finally I got it.

  3. #3
    Join Date
    Apr 2009
    Cambridge, MA
    Ubuntu 11.04 Natty Narwhal

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    I still get "No proprietary drivers are in use on this system".

    I have a Lenovo s10-3t as well.

  4. #4
    Join Date
    Mar 2010

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    Try to do what's written in the README file from the Broadcom website, it worked for me.

  5. #5
    Join Date
    Mar 2010

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    Can u tell me how to install this driver . I read the readme. it makes me confused. Thanks so much.

  6. #6
    Join Date
    Mar 2010

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    First download the latest drivers here :

    Then launch the Terminal and do the following steps :
    - apt-get install build-essential linux-headers-generic
    - apt-get build-dep linux
    Then go to the directory where you downloaded the drivers then :
    - mkdir hybrid_wl
    - cd hybrid_wl
    - tar xzf ../hybrid-portsrc.tar
    - make
    Now you should have a file called "wl.ko".
    - rmmod wl
    - mv <path-to-prev-driver>/wl.ko <path-to-prev-driver>/wl.ko.orig
    - cp wl.ko <path-to-prev-driver>/wl.ko
    Where <path-to-prev-driver> is /lib/modules/<kernel-version>/kernel/net/wireless.
    Then add some default drivers to blacklist :
    - rmmod b43
    - rmmod ssb
    - echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
    - echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf
    Finally load drivers :
    - cd <path-to-prev-driver>
    - modprobe lib80211
    - insmod wl.ko
    - modprobe wl
    Now, your Wi-Fi should work.

  7. #7
    Join Date
    Mar 2010

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    It seems not all machines shipped with bcm 4313.

    I went throw many intructions, including ndiswrapper, bcmwl-kernel-source package and manually compile linux_sta driver from broadcomm.

    All times i was successfull with loading driver, i am able to see wlan0 interface but wifi still wont work

    in dmesg i see such errors
    [   53.433042] iwlagn 0000:07:00.0: firmware: requesting iwlwifi-6050-4.ucode
    [   53.435960] iwlagn 0000:07:00.0: iwlwifi-6050-4.ucode firmware file req failed: -2
    [   53.435976] iwlagn 0000:07:00.0: firmware: requesting iwlwifi-6050-3.ucode
    [   53.441241] iwlagn 0000:07:00.0: iwlwifi-6050-3.ucode firmware file req failed: -2
    [   53.441257] iwlagn 0000:07:00.0: firmware: requesting iwlwifi-6050-2.ucode
    [   53.446047] iwlagn 0000:07:00.0: iwlwifi-6050-2.ucode firmware file req failed: -2
    [   53.446062] iwlagn 0000:07:00.0: firmware: requesting iwlwifi-6050-1.ucode
    [   53.451146] iwlagn 0000:07:00.0: iwlwifi-6050-1.ucode firmware file req failed: -2
    [   53.451158] iwlagn 0000:07:00.0: Could not read microcode: -2
    iwlist scan sayng "network is down"
    root@void-laptop:/home/void# iwlist scan
    lo        Interface doesn't support scanning.
    eth0      Interface doesn't support scanning.
    wlan0     Interface doesn't support scanning : Network is down
    pan0      Interface doesn't support scanning.
    and ifconfig falling to bring wlan0 up
    root@void-laptop:/home/void# ifconfig wlan0
    wlan0     Link encap:Ethernet  HWaddr 00:23:15:06:b1:70  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    root@void-laptop:/home/void# ifconfig wlan0 up
    SIOCSIFFLAGS: No such file or directory
    Finally i discover that lspci give me another pcid

    07:00.0 0280: 8086:0089 (rev 35)
    It was my epic fail - i spend 3 days to track this diff and warn all who fail with broadcom wifi - some models shipped with intel card.

    and according to this bug intel still have no open driver for this card. So be patient.
    Last edited by flashvoid; March 19th, 2010 at 04:01 PM.

  8. #8
    Join Date
    Apr 2007

    Re: Wi-Fi on Lenovo s10e with Broadcom BCM4312

    Same problem following 10.4 upgrade no wifi.

    Using Lenovo S10e.
    05:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
            Subsystem: Broadcom Corporation Device 04b5
    Followed update procedure as found in broadcom README.txt file:
    Go to System->Administration->Hardware Drivers
    Choose the Broadcom STA wireless driver
    Sometimes the driver does not show up in the Hardware Drivers choices.  In
    this case, try reintalling the driver from the GUI or shell like this:
    From the GUI:
    Package Manager (System>Administration>Synaptic Package Manager). Click the 
    Reload button in the upper left corner of Synaptic to refresh your index then 
    search for and reinstall the package named bcmwl-kernel-source.
    From the shell:
    sudo apt-get update
    sudo apt-get --reinstall install bcmwl-kernel-source
    In either GUI or text case, after reinstalling, reboot your machine.
    Now go back to System->Administration->Hardware Drivers
    and you should see the driver enabled and working.
    All working well following reboot.
    Last edited by dbld; July 9th, 2010 at 11:53 AM.

  9. #9
    Join Date
    Sep 2010

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    Same BCM4313 chipset found in the new HP Mini 210 with Intel NM10 chipset (1.86GHz Atom N475).

    Same instructions to install the wifi driver. Tested working with WPA2 access point.

  10. #10
    Join Date
    Dec 2007
    Behind you!!
    Ubuntu 10.04 Lucid Lynx

    Re: Wi-Fi on Lenovo s10-3t with Broadcom BCM4313 [14e4:4727] (rev 01)

    I have a HP Mini 210 also. To get wifi working I ran
    apt-cache search bcmwl
    This returned two packages.
    After installing the kernel source, and giving it a reboot, wifi worked without any issues.

    Linux is not windows
    Fluxbox & Flux menu how to
    Programming is an art. Learn it, Live it, Love it!

Page 1 of 3 123 LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts