Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

  1. #11
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Beans
    925
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    Quote Originally Posted by cloudxrocks View Post
    so what do u suggest i do?
    read my comment #4 above.

  2. #12
    Join Date
    Jan 2010
    Location
    Norway
    Beans
    218
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    I have an ATI Radeon x300 card - and got it working 100% - even compiz works flawlessly.
    I followed this:
    https://help.ubuntu.com/community/RadeonDriver

  3. #13
    Join Date
    Jan 2010
    Location
    Norway
    Beans
    218
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    although I see your card is not listed in any of the lists on the page linked above - it may work even though... I'm no expert...

  4. #14
    Join Date
    May 2007
    Location
    Virginia, USA
    Beans
    13,316
    Distro
    Ubuntu Mate Development Release

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    If you're getting a graphical desktop, you already have the open source driver installed.

    If you download and attempt to install any other drivers, you will only hose up your display big time, have to then remove those drivers, and end up reinstalling the same open source drivers you already have.

    Sorry, but ATI dropped Linux support for your card a long time ago. There are no ATI drivers that will work with your card and any recent Ubuntu versions.
    Ubuntu 17.10 Mate, Mint 18.3 Mate; MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  5. #15
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Beans
    925
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    Quote Originally Posted by Mark Phelps View Post
    If you're getting a graphical desktop, you already have the open source driver installed.

    If you download and attempt to install any other drivers, you will only hose up your display big time, have to then remove those drivers, and end up reinstalling the same open source drivers you already have.

    Sorry, but ATI dropped Linux support for your card a long time ago. There are no ATI drivers that will work with your card and any recent Ubuntu versions.
    Clarification: X1400 card is fully supported in Ubuntu 9.10.

    "ATI driver" above refers to a proprietary AMD (formerly ATI) driver. It's not needed nor recommended for X1400 chipset. The best option is to use free open source "radeon" driver mentioned previously:
    https://help.ubuntu.com/community/RadeonDriver

    Open source driver works particularly well when KMS/DRI2 is enabled per my previous comment #4.

    This driver is packaged with all versions of Ubuntu and Kubuntu and is provided by package xorg-xserver-video-ati

  6. #16
    Join Date
    Mar 2010
    Beans
    4

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    Quote Originally Posted by michael37 View Post
    Clarification: X1400 card is fully supported in Ubuntu 9.10.

    Open source driver works particularly well when KMS/DRI2 is enabled per my previous comment #4.
    im having a problem with this. after i modify the bootoptions and run update-grub the options remain the same. am i doing something wrong?

  7. #17
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Beans
    925
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    Quote Originally Posted by cloudxrocks View Post
    im having a problem with this. after i modify the bootoptions and run update-grub the options remain the same. am i doing something wrong?
    Probably. Try reading up this page: https://help.ubuntu.com/community/Grub2

    I assume you are using Grub2, not older Grub; that's a case when you fresh-install Ubuntu 9.10.

    If this doesn't resolve, please start another thread to address Grub issue to avoid thread contamination.

  8. #18
    Join Date
    Jul 2008
    Beans
    235
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    On a related note, I'd like to know if I'll be able to run flightgear flight simulator, which requires, I believe 3d acceleration. I have an ATI Radeon X1400 card (Thinkpad T60), and just yesterday installed Ubuntu 9.10. Although glxgears shows good frame rate, I suspect flightgear needs FGLRX driver to run properly. A couple years ago when running Gutsy Gibon I used the Restricted Drivers Manager to install the proprietary ATI driver from Ubuntu repositories.

  9. #19
    Join Date
    Jul 2007
    Location
    Boston, MA, USA
    Beans
    925
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    Quote Originally Posted by rawlins02 View Post
    On a related note, I'd like to know if I'll be able to run flightgear flight simulator, which requires, I believe 3d acceleration. I have an ATI Radeon X1400 card (Thinkpad T60), and just yesterday installed Ubuntu 9.10. Although glxgears shows good frame rate, I suspect flightgear needs FGLRX driver to run properly. A couple years ago when running Gutsy Gibon I used the Restricted Drivers Manager to install the proprietary ATI driver from Ubuntu repositories.
    ATI Catalyst driver (former fglrx) discontinued support for X1400 using fglrx driver last year.

    http://en.wikipedia.org/wiki/Radeon#Linux

    ATI Mobility X1400 is powered by R500 family chip.

    Try the instructions for Kernel Mode Settings. Even though current KMS reduces the speed of glxgears, it supposedly increases speed of complex full screen 3D ops. For performance, you may also choose to go with Lucid pre-release.

  10. #20
    Join Date
    Jul 2008
    Beans
    235
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: need help installing ATI Mobility Radeon x1400 driver on ubuntu 9.10

    Thanks. The more I read about newer versions of linux, older ATI cards, and drivers, I'm probably lucky that I got a working display when I installed 9.10. Most apps like all my Firefox plugins work fine. I'll have to try your suggestions the next chance I get.

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •