Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: Help - WUSB600N and 9.10 32-bit

  1. #31
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,392
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Help - WUSB600N and 9.10 32-bit

    [ 522.149179] --> Error 2 opening /etc/Wireless/RT3070STA/RT3070STA.dat
    Do you have any files in /etc/Wireless? If you have a directory called RT2870STA and a file within it called RT2870STA.dat, you can do:
    Code:
    sudo mkdir /etc/Wireless/RT3070STA
    sudo cp /etc/Wireless/RT2870STA/RT2870STA.dat /etc/Wireless/RT3070STA
    sudo mv /etc/Wireless/RT3070STA/RT2870STA.dat /etc/Wireless/RT3070STA/RT3070STA.dat
    Now reboot and see if things improve.

    You may need to edit /etc/Wireless/RT3070STA/RT3070STA.dat to suit your needs. There are instructions in the readme in the file you used to compile the driver.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  2. #32
    Join Date
    May 2010
    Location
    Vinnitsa, Ukraine
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Help - WUSB600N and 9.10 32-bit

    Thank you for advice, Chili. Actually, I didn't compile the driver; the logs and messages were obtained with the default driver included in Ubuntu 10.04 LTS. But I found the file (RT2870STA.dat) in the sources downloaded from Ralink, edited it and put in /etc/Wireless/RT3070 directory. Of course, I renamed the file to RT3070STA.dat also. But, anyway it doesn't work. Here are the .dat file and dmesg:

    RT3070STA.dat (entire):
    Code:
    #The word of "Default" must not be removed
    Default
    CountryRegion=5
    CountryRegionABand=7
    CountryCode=
    ChannelGeography=1
    SSID=Flavia
    NetworkType=Infra
    WirelessMode=5
    Channel=0
    BeaconPeriod=100
    TxPower=100
    BGProtection=0
    TxPreamble=0
    RTSThreshold=2347
    FragThreshold=2346
    TxBurst=1
    PktAggregate=0
    WmmCapable=1
    AckPolicy=0;0;0;0
    AuthMode=WPA2PSK
    EncrypType=AES
    WPAPSK=
    DefaultKeyID=1
    Key1Type=0
    Key1Str=
    Key2Type=0
    Key2Str=
    Key3Type=0
    Key3Str=
    Key4Type=0
    Key4Str=
    PSMode=CAM
    AutoRoaming=0
    RoamThreshold=70
    APSDCapable=0
    APSDAC=0;0;0;0
    HT_RDG=1
    HT_EXTCHA=0
    HT_OpMode=0
    HT_MpduDensity=4
    HT_BW=1
    HT_BADecline=0
    HT_AutoBA=1
    HT_AMSDU=0
    HT_BAWinSize=64
    HT_GI=1
    HT_MCS=33
    HT_MIMOPSMode=3
    HT_DisallowTKIP=1
    IEEE80211H=0
    TGnWifiTest=0
    WirelessEvent=0
    CarrierDetect=0
    AntDiversity=0
    BeaconLostTime=4
    PSP_XLINK_MODE=0
    I changed here SSID to my Wireless network's name. In Windows 7 the network's Authentication type is WPA2 and encryption type is AES, so I turned AuthMode to WPA2PSK and EncrypType to AES. This is it.

    $: dmesg
    Code:
    [  229.367961] usb 1-1.2: new high speed USB device using ehci_hcd and address 6
    [  229.476289] usb 1-1.2: configuration #1 chosen from 1 choice
    [  229.477897] 
    [  229.477899] 
    [  229.477900] === pAd = feb32000, size = 566748 ===
    [  229.477901] 
    [  229.477904] <-- RTMPAllocAdapterBlock, Status=0
    [  229.761964] <-- RTMPAllocTxRxRingMemory, Status=0
    [  229.763582] -->RTUSBVenderReset
    [  229.763703] <--RTUSBVenderReset
    [  230.041847] RTMPReadParametersHook::(WPAPSK key-string required 8 ~ 64 characters!)
    [  230.041938] I/F(wlan0) Key1Str is Invalid key length! KeyLen = 0!
    [  230.041984] I/F(wlan0) Key2Str is Invalid key length! KeyLen = 0!
    [  230.042031] I/F(wlan0) Key3Str is Invalid key length! KeyLen = 0!
    [  230.042079] I/F(wlan0) Key4Str is Invalid key length! KeyLen = 0!
    [  230.043361] 1. Phy Mode = 5
    [  230.043363] 2. Phy Mode = 5
    [  230.079148] RTMPSetPhyMode: channel is out of range, use first channel=1 
    [  230.097090] 3. Phy Mode = 5
    [  230.108357] MCS Set = ff ff 00 00 01
    [  230.121195] <==== RTMPInitialize, Status=0
    [  230.123843] 0x1300 = 00064300
    [  235.165027] ===>rt_ioctl_giwscan. 1(1) BSS returned, data->length = 136
    [  240.351045] wlan0: no IPv6 routers present
    Of course, I restarted the system everytime I changed the system. IPv6 is still turned to "Ignore" in the network configuration...

  3. #33
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,392
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Help - WUSB600N and 9.10 32-bit

    Your dmesg says:
    WPAPSK key-string required 8 ~ 64 characters!
    And your dat file says:
    WPAPSK=
    Please fill in the blank and then reboot. You might also add your country code and channel in the required spaces; US? 6? Does it work as expected?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  4. #34
    Join Date
    May 2010
    Location
    Vinnitsa, Ukraine
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Help - WUSB600N and 9.10 32-bit

    Quote Originally Posted by chili555 View Post
    Please fill in the blank and then reboot. You might also add your country code and channel in the required spaces; US? 6? Does it work as expected?
    What exactly should I put in the WPAPSK string? My password to the wireless network? My country is Ukraine and I don't know which code fits Ukraine. I suppose, it's not a phone code Channel is the same. I have never adjusted these parameters in Windows, so I need an advice. Thank you in advance!

  5. #35
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,392
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Help - WUSB600N and 9.10 32-bit

    What exactly should I put in the WPAPSK string? My password to the wireless network?
    Yes, exactly. Your country code is UA. It may negotiate the channel by itself. Try these settings and reboot.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #36
    Join Date
    May 2010
    Location
    Vinnitsa, Ukraine
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Help - WUSB600N and 9.10 32-bit

    I entered CountryCode as you advised along with a Password in WPAPSK line, and nothing changed. Then I payed attention to the following strings in dmesg:
    Code:
    [   47.989827] I/F(wlan0) Key4Str is Invalid key length! KeyLen = 0!
    So I also typed the Password to one of the lines Key*Str. Now my RT3080STA.dat looks like:
    Code:
    #The word of "Default" must not be removed
    Default
    CountryRegion=5
    CountryRegionABand=7
    CountryCode=UA
    ChannelGeography=1
    SSID=Flavia
    NetworkType=Infra
    WirelessMode=5
    Channel=0
    BeaconPeriod=100
    TxPower=100
    BGProtection=0
    TxPreamble=0
    RTSThreshold=2347
    FragThreshold=2346
    TxBurst=1
    PktAggregate=0
    WmmCapable=1
    AckPolicy=0;0;0;0
    AuthMode=WPA2PSK
    EncrypType=AES
    WPAPSK=<my_password>
    DefaultKeyID=1
    Key1Type=0
    Key1Str=<my_passwoed>
    Key2Type=0
    Key2Str=
    Key3Type=0
    Key3Str=
    Key4Type=0
    Key4Str=
    PSMode=CAM
    AutoRoaming=0
    RoamThreshold=70
    APSDCapable=0
    APSDAC=0;0;0;0
    HT_RDG=1
    HT_EXTCHA=0
    HT_OpMode=0
    HT_MpduDensity=4
    HT_BW=1
    HT_BADecline=0
    HT_AutoBA=1
    HT_AMSDU=0
    HT_BAWinSize=64
    HT_GI=1
    HT_MCS=33
    HT_MIMOPSMode=3
    HT_DisallowTKIP=1
    IEEE80211H=0
    TGnWifiTest=0
    WirelessEvent=0
    CarrierDetect=0
    AntDiversity=0
    BeaconLostTime=4
    PSP_XLINK_MODE=0
    And after reboot dmesg returnes:
    Code:
    [   47.304834] usb 1-1.2: new high speed USB device using ehci_hcd and address 6
    [   47.413532] usb 1-1.2: configuration #1 chosen from 1 choice
    [   47.415042] 
    [   47.415043] 
    [   47.415043] === pAd = fd352000, size = 566748 ===
    [   47.415044] 
    [   47.415045] <-- RTMPAllocAdapterBlock, Status=0
    [   47.691375] <-- RTMPAllocTxRxRingMemory, Status=0
    [   47.693109] -->RTUSBVenderReset
    [   47.693215] <--RTUSBVenderReset
    [   47.989769] I/F(wlan0) Key1Str is Invalid key length! KeyLen = 23!
    [   47.989788] I/F(wlan0) Key2Str is Invalid key length! KeyLen = 0!
    [   47.989807] I/F(wlan0) Key3Str is Invalid key length! KeyLen = 0!
    [   47.989827] I/F(wlan0) Key4Str is Invalid key length! KeyLen = 0!
    [   47.990668] 1. Phy Mode = 5
    [   47.990668] 2. Phy Mode = 5
    [   48.027593] RTMPSetPhyMode: channel is out of range, use first channel=1 
    [   48.046665] 3. Phy Mode = 5
    [   48.058568] MCS Set = ff ff 00 00 01
    [   48.072402] <==== RTMPInitialize, Status=0
    [   48.074921] 0x1300 = 00064300
    [   53.104771] ===>rt_ioctl_giwscan. 1(1) BSS returned, data->length = 136

  7. #37
    Join Date
    May 2010
    Location
    Vinnitsa, Ukraine
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Help - WUSB600N and 9.10 32-bit

    Hello,

    Is there any suggestions?

  8. #38
    Join Date
    May 2010
    Location
    Vinnitsa, Ukraine
    Beans
    16
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Help - WUSB600N and 9.10 32-bit

    Hello All,

    I just want to say I gave up to make the default driver working and compiled a new one using this great toturial: http://ubuntuforums.org/showthread.p...hlight=dwa+160

    Thank you all and, espetially, chili555 for help and patience!

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •