Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Wakeup from suspend, and wireless is disabled

  1. #1
    Join Date
    Apr 2009
    Beans
    295
    Distro
    Xubuntu 20.04 Focal Fossa

    Wakeup from suspend, and wireless is disabled

    Using wireless is fine until I suspend, then upon waking up I can't reconnect with wireless and on right-clicking the network connection icon the wireless networking check box is greyed out. I can however reconnect with my wired ethernet. Is there a setting somewhere to choose a preference of autoconnect mode upon boot up and waking up from suspend, either ethernet or wireless? Driver installed via b43-fwcutter.

  2. #2
    Join Date
    Nov 2007
    Location
    Okieville, USA
    Beans
    3,178
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Wakeup from suspend, and wireless is disabled

    what version of Ubuntu?
    MCP, A+/Linux+ Certified IT Technician
    System Specs | Dress up your "Super Button" FREE
    "If sometimes you can't be good, then be VERY good at being naughty!"

  3. #3
    Join Date
    Jun 2009
    Location
    Kansas
    Beans
    13
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wakeup from suspend, and wireless is disabled

    I've got the same problem. Running Karmic 9.10 on a Vaio PCG-K13. Never had this problem until yesterday.

  4. #4
    Join Date
    Apr 2009
    Beans
    295
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Wakeup from suspend, and wireless is disabled

    Quote Originally Posted by theozzlives View Post
    what version of Ubuntu?
    9.10 Karmic

  5. #5
    Join Date
    Apr 2009
    Beans
    295
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Wakeup from suspend, and wireless is disabled

    This may be a solution:

    http://lilserenity.wordpress.com/200...ernate-resume/

    Haven't tried it yet. Will tomorrow.

  6. #6
    Join Date
    Apr 2009
    Beans
    295
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Wakeup from suspend, and wireless is disabled

    Quote Originally Posted by donsy View Post
    This may be a solution:

    http://lilserenity.wordpress.com/200...ernate-resume/

    Haven't tried it yet. Will tomorrow.

    Well I tried it and it made no difference. Is there a setting somewhere to enable wireless?

  7. #7
    Join Date
    Nov 2005
    Beans
    29

    Re: Wakeup from suspend, and wireless is disabled

    Same problem here (Ubuntu 9.10, Dell Latitude D600, Broadcom BCM4306 wireless), and the method of setting STOP_SERVICES has not worked, so I'm hoping someone knows another fix.

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,394
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wakeup from suspend, and wireless is disabled

    Please try this:
    Code:
    sudo gedit /etc/pm/config.d/config
    It will probably be a new file. Add a single line:
    Code:
    SUSPEND_MODULES="iwl3945"
    Substitute your wirless driver if it's not iwl3945. Learn with:
    Code:
    lshw -C network
    Here is mine, for example:
    *-network
    description: Wireless interface
    product: PRO/Wireless 3945ABG [Golan] Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlan0
    version: 02
    serial: 99:19:d2:c2:88:77
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwl3945 ip=192.168.1.103 latency=0 multicast=yes wireless=IEEE 802.11abg
    resources: irq:31 memory:edf00000-edf00fff
    It sounds like yours, donsy, is b43.

    As always, proofread carefully, save and close gedit. Use kate, nano, vim or, if you are an Uber-geek, emacs, if you don't have gedit.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  9. #9
    Join Date
    Nov 2008
    Beans
    42

    Re: Wakeup from suspend, and wireless is disabled

    I too sometimes have this problem. Wake up from suspend and I am unable to make my wireless connect. The connect button is greyed out. Fortunately, it always does connect, but it can take up to 5 min before it autoconnects. I tried chilli555's suggestion, but no change. Anybody have any other ideas?

    I am running 9.10 64 bit on a Lenovo T400 with an Intel WiFi 5300.

  10. #10
    Join Date
    Sep 2007
    Beans
    7
    Distro
    Kubuntu Development Release

    SOLVED hp zv5000 resume

    correct wireless resume for HP pavilion zv5000 (zv5475ea) (Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03))

    file "/etc/pm/config.d/config" now contains:

    SUSPEND_MODULES="b43"

    NB: "lshw -C network" gives "driver=b43-pci-bridge", that broke resume completely.

    thank you people.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •