Results 1 to 8 of 8

Thread: can't compile upstream kernel 2.6.33-rc8 on 9.10

Hybrid View

  1. #1
    Join Date
    Apr 2009
    Beans
    141

    Question can't compile upstream kernel 2.6.33-rc8 on 9.10

    I'm trying to build kernel 2.6.33-rc8 according to the documentation here: https://wiki.ubuntu.com/KernelTeam/GitKernelBuild , but at a late stage in the compilation, I'm encountering the following error:

    Code:
    /usr/bin/make -f ./debian/rules 	debian/stamp/binary/pre-linux-image-2.6.33-rc8-custom
    make[1]: Entering directory `/root/src/linux-2.6.33-rc8'
    ====== making target debian/stamp/install/linux-image-2.6.33-rc8-custom [new prereqs: ]======
    This is kernel package version 11.015.
    echo "The UTS Release version in include/linux/version.h"; echo "	   \"\" "; echo "does not match current version:"; echo "	   \"2.6.33-rc8-custom\" "; echo "Please correct this."; exit 2
    The UTS Release version in include/linux/version.h
    	   "" 
    does not match current version:
    	   "2.6.33-rc8-custom" 
    Please correct this.
    what am I doing wrong?

  2. #2
    Join Date
    Feb 2007
    Beans
    100

    Re: can't compile upstream kernel 2.6.33-rc8 on 9.10

    Yep, i am getting this too even on the final kernel 2.6.33

  3. #3
    Join Date
    Dec 2008
    Location
    Isolated Digital Reign
    Beans
    151
    Distro
    Kubuntu Development Release

    Re: can't compile upstream kernel 2.6.33-rc8 on 9.10

    See this bug: https://bugs.launchpad.net/ubuntu/+s...ge/+bug/498747

    ...and out of it get this patch: http://launchpadlibrarian.net/374978...e-2.6.33.patch

    And apply it on your system. Your other choice is to wait for an updated version of kernel-package in karmic.

    C]-[aoZ

  4. #4
    Join Date
    Feb 2007
    Beans
    100

    Re: can't compile upstream kernel 2.6.33-rc8 on 9.10

    i tried applying this patch or so i think and i get this...

    patch -p1 < ../kernel-package-2.6.33.patch
    can't find file to patch at input line 3
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |--- /usr/share/kernel-package/ruleset/misc/version_vars.mk 2008-11-24 18:01:32.000000000 +0100
    |+++ /usr/share/kernel-package/ruleset/misc/version_vars.mk 2010-01-06 16:16:28.662667462 +0100
    --------------------------
    File to patch:

  5. #5
    Join Date
    Dec 2008
    Location
    Isolated Digital Reign
    Beans
    151
    Distro
    Kubuntu Development Release

    Re: can't compile upstream kernel 2.6.33-rc8 on 9.10

    Well, just cd into / and use sudo.

  6. #6
    Join Date
    Jan 2010
    Beans
    25

    Re: can't compile upstream kernel 2.6.33-rc8 on 9.10

    Works for me! Thx !
    GT

  7. #7
    Join Date
    Apr 2008
    Location
    utm skudai
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: can't compile upstream kernel 2.6.33-rc8 on 9.10

    it seem make-kpkg cant find utsrelease.h in include/linux folder
    quick workaround is i make symlink
    ln -s ./include/generated/utsrelease.h ./include/linux/utsrelease.h
    and make-kpkg again

    good luck

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •