Page 13 of 13 FirstFirst ... 3111213
Results 121 to 125 of 125

Thread: Ubuntu on Lenovo ThinkPad Edge

  1. #121
    Join Date
    Jul 2009
    Caracas, Venezuela
    Lubuntu 13.04 Raring Ringtail

    Question Re: Ubuntu on Lenovo ThinkPad Edge

    I recently owned a Thinkpad Edge 13'', model 01962CS... I'm using Xubuntu 11.10 on it (along with Windows7) and so far, my only complain is that the mic problem is still there. The mic is only functional when I'm using W7, so, no hardware problem there...

  2. #122
    Join Date
    May 2006
    here & there
    Kubuntu 12.04 Precise Pangolin

    Re: Ubuntu on Lenovo ThinkPad Edge


    I need your help.
    I have a 15" Intel (i5) Edge running Kubuntu 11.10 on it. Everything seems to work except the F1-F12 keys. It's freaking me out.
    And some of the FN keys like (volume up or down or mute) don't seem to work either. I get a visual feedback that the volume is reduced, but the system doesn't react to it, it still has the same volume as before. Then i have to manually change it in kmix myself, which is not the purpose, right?!

    If I press Fn+F1 in most applications help pages should open, but it doesn't do anything.

    How can I change the key mappings of these keys, that F1-F12 will finally work.

    Do you have any ideas?
    The strange thing is, when I used Kubuntu 11.04 all these keys worked out of the box.

    please help, as it's getting a little frustrated

  3. #123
    Join Date
    Feb 2007
    The Netherlands
    Ubuntu Development Release

    Re: Ubuntu on Lenovo ThinkPad Edge

    Strange, I have an Edge 15 running Ubuntu 11.10 and everything works.
    I reckon it's a BIOS or forgotten config setting.

    In the last case, try Kubuntu from Live CD. If keys work, you need to add a new user so you DO NOT inherit your old home with bad configs.
    Windows 7 for Media Production, Ubuntu 12.04/Cinnamon for other work.
    Xubuntu 12.04 as Media Center, CentOS 5.6 as server.
    Linux Mint on my casual laptop, Maemo 5 on my Nokia N900.

  4. #124
    Join Date
    May 2006
    here & there
    Kubuntu 12.04 Precise Pangolin

    Re: Ubuntu on Lenovo ThinkPad Edge

    I've checked the BIOS, everything is looking fine there. I haven't changed it since i've got the laptop. and as said earlier in my post above, the F1-F12 keys worked fine in the previous releases e.g 11.04

    now when I press F1 i get an A
    when I press F2 i get a B
    .....and so on.

    I've checked the shortcut settings in the system preferences, but didn't find anything.

    any clues on how I can fix this phenomenon?!

    I'd appreciate any advice.

    many thanks in advance x

    PS: i've added a user, the same problem occurs with the new user/home/config settings.


    i think i've found what my problem was...the problem was located in the keymappings of the "Konsole" program. pretty weird, huh?!
    Last edited by rockprincess; January 15th, 2012 at 12:50 AM.

  5. #125
    Join Date
    Jan 2012

    Re: Ubuntu on Lenovo ThinkPad Edge

    Hi guys, it just for information. Before buying it, I have already performed many research but still get into several unbelieve situation.

    Lenovo Thinkpad Edge 11 E120 (3043AB)
    - Intel i3-2357M
    - 8G RAM
    - 120G SSD 2.5" 7.5mm (DIY)
    - Ubuntu 11.10 64bit Desktop using EFI boot

    Hardware Issue:
    1) Keyboard missing the "Insert" key and therefore cannot use the Midcommand in console.
    2) Can only access 6.7G RAM (where is the remaining 1.3G?).
    3) Wifi cannot be turned on after sleep, hibernate. Tried "rfkill" but failed. However, it only works upon restart reboot the entire machine. So, wherever cafe, outdoor meeting I went, I have to wait for the reboot.
    4) Quite hard to find 2.5" 7.5mm 7200RPM harddisk for replacement. The SATA slot design make one has no choice to insert a 9.5mm cos the SATA connector is upside down.
    5) Battery drained very fast. I means the full capacity. Newly bought is 67.5V in full and just for 2 months, it's now 55.5V in full and cannot find original replacement even from Lenovo.

    Hardware Solution:
    1) No solution. have tried to remap key in GNOME, X but failed. Any help, suggestion from u guys?
    2) Update BIOS to version "1.14" can access 7.7G RAM which acceptable now.
    3) Update BIOS to version "1.14" seems solved the problem but still in testing.
    4) Cos the reboot time of (3), bought a 9.5mm SSD and disassembly the casing to fit into the socket to shorten the reboot time.
    5) Trying to locate compatible battery one instead.

    So, seems the BIOS update is a must for fixing the machine problem. However, before you perform the BIOS update and you've already installed everything into the hardisk like me. Check whether you are using EFI to boot. If yes, please get a bootable CD or media in USB on hand, cos after the update the EFI boot information is also erased and need to recreate manually or else you cannot boot up.

    Delete the EFI boot info in the BIOS and boot Ubuntu 11.10 installation CD using usb, open a terminal and login as root, perform the following instructions
    > modprobe efivars
    > apt-get install efibootmgr
    > efibootmgr --create --gpt --disk /dev/sda --part 1 --wirte-signature --label "ubuntu" --loader "\\EFT\\ubuntu\\grubx64.efi"

    Be careful the last command cannot be re-issue. If anything wrong, go to the BIOS to delete the EFI boot info labeled - "ubuntu" and start it over again.

    Overall, after using so much time to re-search, test & check, the notebook now is ok. At least to me. Ubuntu running on it is quite stable, fast (cos SSD and resume just need 3 seconds).

    However, from consumer point of view, it's not a cheaper one and how come so many minor problems in their BIOS and their design, plus aftersales services.

    Conclusion, I don't recommend this notebook to anyone without sufficient technical knowledge but I am happy to have it.
    Last edited by rx78pilot; January 27th, 2012 at 08:20 AM.

Page 13 of 13 FirstFirst ... 3111213

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts