Quote Originally Posted by jmols View Post
I'm using a samsung R590 laptop (wich is quite similar to the R580) and I got my brightness controls to work on ubuntu 10.10 like this:

I first installed the samsung-tools these fixed all of my other fn buttons. This is just a tip and not necessary (i think) for the funcionality of the brightness buttons.
HTML Code:
Part 1: install drivers
1. Disable previous drivers (System/Additional drivers)
2. Download drivers from www.nvidia.com (use save as)
3. Reboot in a recovery shell
sudo sh ./<downloaded file>
5. Follow install instructions. (If previously installed the standard nvidia drivers, you should let the setup create a textfile wich will disable the previous drivers. After that, you should reboot and try again form step 3.)

Part 2: adjust grub
sudo gedit /etc/default/grub
2. Add acpi_backlight=vendor to the default command line, the line should then look like this:
HTML Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
sudo update-grub
Part 3: enable screen adjustments
sudo gedit /etc/X11/xorg.conf
2. Add the following line in the device section: Option "RegistryDwords" "EnableBrightnessControl=1"
My own section looked like this:
HTML Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "EnableBrightnessControl=1"
Part 4: reboot and everything should work

Have fun!
Thank you sooooooo much! Works for me!

My sys info:
NVIDIA 304.43 (Old 276* (*I'm not sure about version) didn't worked, so I made update and its working)
Samsung R780
Ubuntu 12.04