Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Banshee will only run with gksudo

  1. #1
    Join Date
    Feb 2008
    Location
    NSW Australia
    Beans
    91
    Distro
    Ubuntu 16.04 Xenial Xerus

    Banshee will only run with gksudo

    I love Banshee (1.5.3). A bit bleeding edge, but when I tried to reinstall it I find I can only run it with gksudo.
    Can anyone help here.

    My system:

    Karmic 32 bit
    AMD Athlon 64 X2 Processor 5200+
    Chipset Geforce 6100
    Drive 160G
    RAM 2G

  2. #2
    Join Date
    Oct 2009
    Location
    Amman, Jordan
    Beans
    93
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Banshee will only run with gksudo

    You might wanna try removing it and then install it all the way again.
    Jordan Open Source Association | E-mail
    Macbook (late 2008) - 2.4Ghz Core2Duo - 4GB RAM - nVidia 9400 - 250GB HDD

  3. #3
    Join Date
    Feb 2008
    Location
    NSW Australia
    Beans
    91
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: {solved}Banshee will only run with gksudo

    Ok Thanks for that. I had to go back a version, from 1.5.3 to 1.5.1 to get it to work, I work out why later.

  4. #4
    Join Date
    Feb 2008
    Location
    NSW Australia
    Beans
    91
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Banshee will only run with gksudo

    Oops it happened again. When I did I did the latest round of updates on "update manager" it broke again.

    Anyone?

  5. #5
    Join Date
    Feb 2008
    Location
    NSW Australia
    Beans
    91
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Banshee will only run with gksudo

    I have uninstalled Banshee 1.6 and reinstalled it and this is what I get when I run it from terminal:


    john@john-desktop:~$ banshee
    [Info 13:01:37.768] Running Banshee 1.6.0: [Ubuntu 9.10 51066b4 (linux-gnu, i486) @ 2010-04-02 16:10:03 UTC]

    (/usr/lib/banshee-1/Banshee.exe:2819): GLib-WARNING **: g_set_prgname() called multiple times
    [Info 13:01:41.362] All services are started 1.672092s
    [Info 13:01:44.742] nereid Client Started

    Unhandled Exception: System.ArgumentException: UNC pass should be of the form \\server\share.
    at System.IO.Path.InsecureGetFullPath (System.String path) [0x00000]
    at System.IO.Path.GetFullPath (System.String path) [0x00000]
    at Banshee.LibraryWatcher.IO.FileSystemWatcher.get_Fu llPath () [0x00000]
    at (wrapper remoting-invoke-with-check) Banshee.LibraryWatcher.IO.FileSystemWatcher:get_Fu llPath ()
    at Banshee.LibraryWatcher.IO.InotifyWatcher.StartDisp atching (Banshee.LibraryWatcher.IO.FileSystemWatcher fsw) [0x00000]
    at Banshee.LibraryWatcher.IO.FileSystemWatcher.Start () [0x00000]
    at Banshee.LibraryWatcher.IO.FileSystemWatcher.set_En ableRaisingEvents (Boolean value) [0x00000]
    at (wrapper remoting-invoke-with-check) Banshee.LibraryWatcher.IO.FileSystemWatcher:set_En ableRaisingEvents (bool)
    at Banshee.LibraryWatcher.FileSystemWatcherProxy.set_ EnableRaisingEvents (Boolean value) [0x00000]
    at Banshee.LibraryWatcher.SourceWatcher.Watch () [0x00000]
    john@john-desktop:~$

  6. #6
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,480
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Banshee will only run with gksudo

    I would remove Banshee's preferences files; they might be owned by root (which happens if you have ever used 'sudo banshee').

    Preferences files are stored in hidden folders in your home directory - that is, folders beginning with a fullstop.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  7. #7
    Join Date
    Oct 2005
    Location
    Linköping, Sweden
    Beans
    56
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Banshee will only run with gksudo

    Just to make sure: your home folder isn't full or nearly full is it? It happened to me onece (I had about 1.5Gb free) and that caused a few applications that stored preferences-files there to go haywire.
    Using Intel Core2Duo with 11.10 64-bit
    How many roads must a man walk down?
    - 42

  8. #8
    Join Date
    Feb 2008
    Location
    NSW Australia
    Beans
    91
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Banshee will only run with gksudo

    Thanks for getting back to me. No my home folder is not full, I only have 2 partitions on this drive. There is a bug report (450166) on Launchpad which is similar to my issue, but is yet unresolved.
    What is a little strange is that all the files in my Music have been made READ ONLY. For some reason I haven't been able to change the permission of the whole folder using gksudo nautilus. I am in the process of changing each individual file (over 600).

    Soon I am going to do a clean install on Lucid, that will fix it.

  9. #9
    Join Date
    Mar 2008
    Location
    The Burning Earth.
    Beans
    3,660

    Re: Banshee will only run with gksudo

    Try right clicking your Apps. Places, System Menu and selecting Edit menus. Find the Banshee entry and double click it for Properties. In that window, add gksudo to the beginning of the Command.

    Example:

    Code:
    gksudo banshee
    Note the space between the two words.
    God does not play dice with the universe - Albert Einstein
    Sure I do, I just use loaded dice. - warfacegod

    An open forum. Its a free for all. Check us out. https://openlinuxforums.org/

  10. #10
    Join Date
    Feb 2008
    Location
    NSW Australia
    Beans
    91
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Banshee will only run with gksudo

    No, this won't work for me, Banshee will not run from the panel. I even tried purging the program and configuration. What is odd is the the command file it is: "banshee-1 --redirect-log --device-activate-play=%u" Maybe this is incorrect?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •