Results 1 to 2 of 2

Thread: ATI driver did work and now it doesn't

  1. #1
    Join Date
    Oct 2007
    Ubuntu 10.04 Lucid Lynx

    Cool ATI driver did work and now it doesn't

    I just tried a fresh install of ubuntu 9.04 and a new attempt for 3D acceleration with my ATI Radeon Xpress 1150 - AND IT WORKED! thanx to this guide:

    glxinfo | grep "direct rendering"
    was giving a YES and playonlinux in the terminal didn't give the usual "you don't seem to have any 3D acceleration" message.

    For a few minutes, my happiness was greater then ever (ehum) I installed Jedi Knight II, Jedi Outcast, and it worked. Only I couldn't adjust the screen size or the gamma (and a few other minor video settings).

    After some install/reinstall of playonlinux and wine I found out something: 3D acceleration didn't work any longer. glxinfo | grep "direct rendering"
    is now giving

    direct rendering: No (LIBGL_ALWAYS_INDIRECT set)

    and I get the error in Playonlinux that i don't have any 3D acceleration.

    I want to know how this could happen? My xorg didn't change at all. But for completeness, here it is:

    [code]# xorg.conf (X.Org X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Device"
    Identifier "Configured Video Device"
    Driver "ati"
    BusID "PCI:1:5:0"
    Option "XAANoOffscreenPixmaps"

    Section "Monitor"
    Identifier "Configured Monitor"
    Option "DPMS"

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x800"

    Section "DRI"
    Mode 0666

    Section "Extensions"
    Option "Composite" "Enable"


    basic question: how do I make my laptop smile again with 3D acceleration?

  2. #2
    Join Date
    Oct 2007
    Ubuntu 10.04 Lucid Lynx

    Re: ATI driver did work and now it doesn't

    solved: I changed the visual effects to "Extra". after changing it back to "none", the 3D acceleration was activated again. Can't i learn ubuntu to use the same driver for its effects?

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts