Results 1 to 3 of 3

Thread: Edit grub.cfg to incorporate "noapic nolapic"

  1. #1
    Join Date
    Dec 2007
    Beans
    20

    Edit grub.cfg to incorporate "noapic nolapic"

    Can someone please explain to me how to edit the new grub.cfg file. For some reason when I start any version of linux none of my usb ports are powered unless I use these boot parameters (noapic nolapic). I have no idea why and I don't really care why, all I want to do is edit grub.cfg so it will incorporate these parameters automatically at startup. Links to others posts will be gladly appreciated. Thanks in advance and sorry for the negative tone.

    P.S. Why change from the old menu.list?

  2. #2
    Join Date
    Jul 2005
    Location
    Hughenden, Australia
    Beans
    5,096
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Edit grub.cfg to incorporate "noapic nolapic"

    You are not supposed to edit /boot/grub/grub.cfg directly.
    Instead, the file you should edit is called /etc/default/grub, and you may open it with the text editor gedit,
    Code:
    gksudo gedit /etc/default/grub
    It should look something like this,
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="10"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    You should add your boot options like so,
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="10"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX="noapic, nolapic"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    Save the file and close it and then run 'sudo grub-mkconfig -o /boot/grub/grub.cfg', to write the changes persistently to your grub.cfg.
    Code:
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    Ubuntu user since 2004 (Warty Warthog)

  3. #3
    Join Date
    Feb 2010
    Beans
    1

    Re: Edit grub.cfg to incorporate "noapic nolapic"

    Herman...Thank You!!

    I'm no longer getting a Kernal panic msg upon boot, thanks again.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •