Results 1 to 10 of 10

Thread: Wrong display monitor detected, wrong rate.

  1. #1
    Join Date
    Jan 2010
    Beans
    10

    Wrong display monitor detected, wrong rate.

    Hi.

    Got Ubuntu 9.10 for 2 days now.

    Got problem with my monitor. When I go to System > Preferences > Display it shows Eizo 19" (crt). I got Eizo 21".

    Second thing is I cant set refresh rate. I can choose between 75 and 85 only. I need to set it to 100Hz.

    How do I change my monitor as device? How do I force refresh rate?

    Thanks.

    /edit: Is there some advanced display settings application?

  2. #2
    Join Date
    Mar 2006
    Location
    Saint Petersburg, FL
    Beans
    1,123

    Re: Wrong display monitor detected, wrong rate.

    You monitor is giving the wrong EDID information. Which display drivers are you using, IE: Nvidia, ATI, or open source version?
    For those new to Ubuntu most of your answers can be found at help.ubuntu.com or ubuntuguide.org

  3. #3
    Join Date
    Jan 2010
    Beans
    10

    Re: Wrong display monitor detected, wrong rate.

    I got Radeon x800xl and I use open source coz ati drivers dont work for my card in 9.10.

  4. #4
    Join Date
    Mar 2006
    Location
    Saint Petersburg, FL
    Beans
    1,123

    Re: Wrong display monitor detected, wrong rate.

    Since you using the open source drivers you can use xrandr to test and change for non-detected resolutions and refresh rates:

    https://wiki.ubuntu.com/X/Config/Res...%20resolutions

    To keep the changes persistent I suggest that you use the .xprofile method since it's the easiest to set up. If you feel comfortable editing the xorg.conf file use that method instead replacing the example information with yours.

    Edit: There are some GUI packages such as gnome-randr-applet, arandr, or grandr but if you don't need to change the resolution frequently then an .xprofile file is most likely the way to go.
    Last edited by warp99; February 7th, 2010 at 09:22 AM.
    For those new to Ubuntu most of your answers can be found at help.ubuntu.com or ubuntuguide.org

  5. #5
    Join Date
    Jan 2010
    Beans
    10

    Re: Wrong display monitor detected, wrong rate.

    Thanks for reply.
    Code:
    :~$ xrandr --newmode "1280x1024_100.00"  189.50  1280 1376 1512 1744  1024 1027 1034 1087 -hsync +vsync
    X Error of failed request:  BadName (named color or font does not exist)
      Major opcode of failed request:  150 (RANDR)
      Minor opcode of failed request:  16 (RRCreateMode)
      Serial number of failed request:  23
      Current serial number in output stream:  23
    I used cvt to get info about 1280x1024 and put as it was shown on wiki u posted. First time i run command it just ran and nothing happened. I cant set to 100hz. This error message i got when i tried to run the command again.

    Thanks !

    /edit: I cant find .xprofile in my /Home/[me]/ folder
    Last edited by Locaj; February 7th, 2010 at 03:52 PM.

  6. #6
    Join Date
    Mar 2006
    Location
    Saint Petersburg, FL
    Beans
    1,123

    Re: Wrong display monitor detected, wrong rate.

    The first time you run it looks like nothing happened, but the screen will flicker and if you run the command "xrandr" by itself you'll see the modeline was added. You need to then associate the mode to the display and switch to that mode with some commands like this:

    Code:
    :~$xrandr --addmode VGA 1280x1024_100.00
    
    :~$xrandr --output VGA --mode 1280x1024_100.00
    Of course the addmode and output is whatever output your monitor is listed under xrandr. Also you need to create the .xprofile file in your home directory and make it executable. So something like this should work:

    First create the file:
    Code:
    :~$gedit ~/.xprofile
    Add your working commands to the file and save:
    Code:
    xrandr --newmode "1280x1024_100.00"  189.50  1280 1376 1512 1744  1024 1027 1034 1087 -hsync +vsync
    xrandr --addmode VGA 1280x1024_100.00
    xrandr --output VGA --mode 1280x1024_100.00
    Make the file executable:
    Code:
    chmod +x ~/.xprofile
    If you're still having problems you can download one of the GUI programs I mentioned and try those instead.
    Last edited by warp99; February 7th, 2010 at 10:01 PM. Reason: Corrected error in command string
    For those new to Ubuntu most of your answers can be found at help.ubuntu.com or ubuntuguide.org

  7. #7
    Join Date
    Jan 2010
    Beans
    10

    Re: Wrong display monitor detected, wrong rate.

    Thanks ! ! !

    Thank you so much. I got 100Hz now. Just need to make it to be forever =-D



    Last edited by Locaj; February 7th, 2010 at 09:55 PM.

  8. #8
    Join Date
    Mar 2006
    Location
    Saint Petersburg, FL
    Beans
    1,123

    Re: Wrong display monitor detected, wrong rate.

    That should be "xrandr --addmode VGA-0 1280x1024_100.00" and not "1280_1024_100.00". I checked my previous post and noticed I made this error. Sorry about that. I'll change it right away.

    Once you change this on your end everything should be OK.
    For those new to Ubuntu most of your answers can be found at help.ubuntu.com or ubuntuguide.org

  9. #9
    Join Date
    Mar 2006
    Location
    Saint Petersburg, FL
    Beans
    1,123

    Re: Wrong display monitor detected, wrong rate.

    Quote Originally Posted by Locaj View Post
    Thanks ! ! !

    Thank you so much. I got 100Hz now. Just need to make it to be forever =-D
    Glad I could help. If you could please mark the thread as "solved" by going into Thread Tools and clicking that option. Thanks!!
    For those new to Ubuntu most of your answers can be found at help.ubuntu.com or ubuntuguide.org

  10. #10
    Join Date
    Dec 2009
    Location
    Malibu, California
    Beans
    112
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Wrong display monitor detected, wrong rate.

    Quote Originally Posted by Locaj View Post
    Hi.
    . . .
    Second thing is I cant set refresh rate. I can choose between 75 and 85 only. I need to set it to 100Hz.

    . . . How do I force refresh rate?

    Is there some advanced display settings application?
    Although I am waiting for Xubuntu live iso to try lighter weight Xfce desktop . . .
    all I may need for gnome desktop is to reset refresh rate from the recovery mode root terminal -
    maybe
    more X config though too.

    Gnome desktop lasts about 1 minute before freezing up . . . the refresh rate can not be set by
    System > Preferences > Display (Refresh rate has even said 0 Hz with no other choices).

    Very good to know for my troubleshooting -
    Thanks for the thread and reply with a possibly valuable lead about forcing a refresh rate with xrandr.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •