Results 1 to 6 of 6

Thread: "The destination is read-only"

Hybrid View

  1. #1
    Join Date
    Feb 2010
    Beans
    2

    Angry "The destination is read-only"

    Anyone else run into this problem? I've booted from an Ubuntu Live CD and I've got all the files on my hard drive listed in a window using "gksu nautilus". The iMac I've connected to via Firewire is mounted, along with an external LaCie drive. However, when I try to move any of the files from the hard drive to these volumes, i get "The destination is read-only". These volumes certainly aren't read-only, as they are freely accessed in any direction from from OSX.

    Any suggestions?

  2. #2
    Join Date
    Jul 2006
    Location
    Los Angeles
    Beans
    1,310
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: "The destination is read-only"

    The destination drives are mounted, but for whatever reason, they've been mounted read-only. If you right-click on the mounted drive in nautilus (started as gksudo, like you did before), a dropdown menu appears. Go to Properties at the bottom, and then to the "Permissions" tab. Maybe it will let you change the permissions to "write" there and the problem will go away.

  3. #3
    Join Date
    Oct 2005
    Beans
    68
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: "The destination is read-only"

    Do you know what the format of that "destination" is? If it is HFS+ (the OSX format), there is afaik no write support in Linux. If it is FAT32, NTFS or ext2/3, you should be able to enable write support by changing the permissions.

  4. #4
    Join Date
    Jul 2006
    Location
    Los Angeles
    Beans
    1,310
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: "The destination is read-only"

    Good point, re the HFS format! Actually, there is a utility in synaptic, hfsutils and hfsplus, that's supposed to make it possible to write to HFS+. I saw it when I was fooling around with a hackintosh, but I haven't used it much.

  5. #5
    Join Date
    Oct 2009
    Beans
    141

    Re: "The destination is read-only"

    Quote Originally Posted by quixote View Post
    Good point, re the HFS format! Actually, there is a utility in synaptic, hfsutils and hfsplus, that's supposed to make it possible to write to HFS+. I saw it when I was fooling around with a hackintosh, but I haven't used it much.
    i dual boot OS X and #! linux on my HP desktop, and i could find no way for my linux to be able to write to my mac partition.

    OP whynot just back up all of your files to a NTFS external HD, that way both OS's can read from it.

    EDIT: actually this might help:

    http://ubuntuforums.org/archive/index.php/t-619909.html
    Last edited by Megafag; February 9th, 2010 at 01:07 AM.
    EeePC 1000HE Xubuntu 10.04
    Thinkpad R61 14" Gentoo
    iMac G5 Xubuntu 10.04

  6. #6
    Join Date
    Jul 2011
    Beans
    4

    Re: "The destination is read-only"

    Actually, use Ctrl+C and then Ctrl+V - works just fine.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •