Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Installing Catalyst 10.1 In Karmic?

  1. #1
    Join Date
    Apr 2008
    Beans
    38

    [SOLVED] Installing Catalyst 10.1 In Karmic?

    I'm trying to install the latest ATI Catalyst 10.1 Driver in Ubuntu Karmic for my Radeon HD 5850 graphics card.

    I hit problems with the package and found this solution to it:
    http://www.phoronix.com/forums/showp...5&postcount=67

    However when I try entering the first command, it returns:
    "No such file or directory"

    I placed the file on my desktop and my desktop directory is my current directory in the Terminal when I'm entering it.

    I'm really hoping to get this driver to work as the previous ATI drivers weren't working for me, nor is the open source driver working particularly well.

    Any help is greatly appreciated!

    *EDIT: [SOLVED] Steps to solve this problem provided in the replies below.
    Last edited by curtissthompson; March 29th, 2010 at 08:27 PM. Reason: Solution To Problem Discovered

  2. #2
    Join Date
    Jun 2007
    Beans
    12,689

    Re: Installing Catalyst 10.1 In Karmic?

    Maybe you need to make it executable with:
    Code:
    chmod +x file

  3. #3
    Join Date
    Apr 2008
    Beans
    38

    Re: Installing Catalyst 10.1 In Karmic?

    I tried that and got same message, here's the resulting terminal output:

    Code:
    curtissthompson@curtissthompson-desktop:~$ chmod +x ./ati-driver-installer-10-1-x86.x86_64.run
    chmod: cannot access `./ati-driver-installer-10-1-x86.x86_64.run': No such file or directory
    curtissthompson@curtissthompson-desktop:~$

  4. #4
    Join Date
    Jun 2007
    Beans
    12,689

    Re: Installing Catalyst 10.1 In Karmic?

    Heh, leave the ./ out of the chmod command
    Code:
    chmod +x ati-driver-installer-10-1-x86.x86_64.run

  5. #5
    Join Date
    Apr 2008
    Beans
    38

    Re: Installing Catalyst 10.1 In Karmic?

    Same result:
    Code:
    curtissthompson@curtissthompson-desktop:~$ chmod +x ati-driver-installer-10-1-x86.x86_64.run
    chmod: cannot access `ati-driver-installer-10-1-x86.x86_64.run': No such file or directory
    curtissthompson@curtissthompson-desktop:~$

  6. #6
    Join Date
    Apr 2008
    Beans
    38

    Re: Installing Catalyst 10.1 In Karmic?

    I was wondering, if maybe it isn't being seen due to permissions. So I right clicked and went to Properties, then clicked the Permissions tab. The settings are as follows:

    Owner: curtissthompson -- Curtiss Thompson
    Access: Read and Write

    Group: curtissthompson
    Access: Read-only

    Others
    Access: Read-only

    Execute: [Checkbox Unchecked] Allow executing file as program
    SELinux context: unknown

  7. #7
    Join Date
    Apr 2005
    Beans
    71

    Re: Installing Catalyst 10.1 In Karmic?

    Just to be sure, what is the output of
    Code:
    ls -l
    in the desktop folder?

  8. #8
    Join Date
    Jun 2007
    Beans
    12,689

    Re: Installing Catalyst 10.1 In Karmic?

    curtissthompson@curtissthompson-desktop:~$
    You're not in the Desktop folder. The name of your install has the word 'desktop' in it, which is confusing you.

    Code:
    cd ~/Desktop
    chmod +x ati-driver-installer-10-1-x86.x86_64.run
    sudo ./ati-driver-installer-10-1-x86.x86_64.run

  9. #9
    Join Date
    Apr 2008
    Beans
    38

    Re: Installing Catalyst 10.1 In Karmic?

    Yeah, I was suspicious about that myself, but I ended up doing the very thing you suggested, but by changing the settings under Permissions tab for the File Properties:

    Execute: [Checkbox Unchecked] Allow executing file as program

    By checking that box, then running it (by entering gksu nautilus and proceeding to open the installer), I was able to get through the end of the installer without problems.

    I followed the Custom Driver Installation Option (Page 7), and had success through Step 7 (on Page 9).

    I ran into trouble on Step 8, which I'm sure is due to me forgetting how to navigate the file system in Ubuntu via the Terminal, since I haven't used it in years. Could someone help me with this?

    I'm running X.Org 7.4 so I should use user/bin/aticonfig -initial according to the directions.

  10. #10
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Installing Catalyst 10.1 In Karmic?

    sudo aticonfig --initial

    should be all you need. It will ask for your pasword and then execute. It will give you a message like

    found .....
    and something about creating a new xorg.conf file
    PMs will be ignored.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •