Quote Originally Posted by verb3k View Post
Not reproducible. Clips compressed with AAC and H.264 in .mp4 are handled properly by youtube and stay at full length.
Im not sure if you actually tried to upload your clip to youtube but it's weird. the file does play fine in vlc and totem but it's only after it uploads to youtube that it's all screwed if I don't use the "-vsync 1" option to the encode line. Here's a sample if you don't believe me.


if i run a ffmpeg -i on the mp4 prior to uploading to youtube, the one without the -vsync 1, you can see this.
Stream #0.0(und): Video: h264, yuv420p, 1024x768 [PAR 1:1 DAR 4:3], 226 kb/s, 2.60 fps, 29.97 tbr, 30k tbn, 59.94 tbc

BUT when I use the -vsync 1 the fps and tbr match.
Stream #0.0(und): Video: h264, yuv420p, 1024x768 [PAR 1:1 DAR 4:3], 559 kb/s, 29.97 fps, 29.97 tbr, 2997 tbn, 59.94 tbc

as i stated someone on the ffmpeg irc chat pointed this out to me. whats more weird is that if you don't use the -vsync 1 and instead of using the mp4 container and you use a mkv container on the end of the file name the fps and tbr DO match. So this may be a bug with mp4 but I am not sure.

Next problem is the audio, I will try that although I remember trying to enter that in gtk-recordmydesktop and it returned that it couldn't configure the sound but that may be gtk-recordmydesktop problem. Thanks for trying to help. I'll post back sound result using hw:0,0 after work.