Page 4 of 11 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 107

Thread: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

  1. #31
    Join Date
    Jun 2010
    Beans
    1

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Hi,

    Thanks a lot, it worked for me, clear and easy to follow.

    Some info of my environment:

    Dell Studio 1537
    Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
    Newtwork Driver: Broadcom 802.11 Linux STA wireless

    Regards,
    Juan

  2. #32
    Join Date
    Jun 2010
    Beans
    1

    Smile Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Quote Originally Posted by owhno View Post
    Problem using Broadcom Wireless in Ubuntu 9.10/10.04 because it is not supported by b43 driver ?

    (...) But there is a small problem, as you would have noticed, the ‘ssb‘ driver cannot be blacklisted. It is included in the initrd as I remember from the ubuntuforums. To solve this issue modify the /etc/rc.local to include before the exit(0):

    Code:
    rmmod ssb
    modprobe wl
    Now on startup the ssb gets removed and after that the new wl gets inserted. Adding wl to the /etc/modules will not help because the removing needs to be done first.
    So with the /etc/rc.local modification everything happens in the correct order for perfect WiFi.
    Owhno,

    From your first post of this thread (http://ubuntuforums.org/showthread.php?t=1390979)

    I would propose the following update :

    If /etc/rc.local shabang has the option -e (e.g #!/bin/sh -e), the following code line :

    Code:
    rmmod ssb 
    modprobe wl
    shall be replaced by :

    Code:
    rmmod ssb || true  
    modprobe wl || true
    Most of the time, "rmmode ssb" would return an error because the module would not be necessarily present (because it has been fully de-installed or never installed yet). This means that the rc.local script would stop its execution (because of option -e in shabang) before it even executes "modprobe wl" so the new module would never be loaded at startup and the wi-fi card would remain disabled.

    Also it seems to be usually better to indicate full path to command in script, so the following would be even better :

    Code:
    /sbin/rmmod ssb || true
    /sbin/modprobe wl || true
    When script is executed with -e option, adding "|| true" after the command indicate to explicitly ignore the error return by the command and to continue execution of script anyway...

    Also rmmod et modprobe have an handy option -s which log error via syslog, useful for debugging (error messages are made available in /var/log/syslog file)

    I spend a lot of time believing that my /etc/rc.local was not executed at startup on Ubuntu 9.10 but it wasn't at all the case. It just this "amazing" -e option at the top of the script which caused me high pain

    Thank you for your post, it was a great source for resolving issues with my Broadcom wi-fi card on my Apple MacBook Pro 5,5 with Ubuntu 9.10 (64bits) by compiling and installing the driver from source following your instructions and the README.txt file available with the driver source.

    I may think it would be great to have this information in your original post updated (at the top of this thread) because my post would appears far deep (at the end of it, 5 pages down) so it might be unnoticed by other user trying to resolve similar issues...

    For other users encountering similar issue with their rc.local file, here is a functional /etc/rc.local file that I used to debug my issue and it works :

    -------------------------------------
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.

    logfile="/tmp/rc.local.log"
    /bin/sleep 10
    /bin/echo 'rc.local started' > $logfile
    /bin/echo `date` >> $logfile
    /sbin/rmmod -vs ssb || true
    /sbin/modprobe -vs wl || true
    /bin/echo 'rc.local ended normally' >> $logfile
    exit 0
    --------------------------------

    The "sleep 10" pause the script for 10 seconds before it continue to execute, allowing other element of the system to be fully initialised before it continue running.
    As for the driver loading purpose it may be optional, but in other situation, for other additional startup commands that may be used in the rc.local script, it might be useful.
    Others reported in other posts that a slight pause solves their issue with the rc.local script, so I thought it was worth mentioning as extra information.

    To help debuging rc.local script situation, it is also always good to test that it works fine when executed manually :

    $ sudo -i // Run console as root
    # cd /etc
    # ./rc.local // Manual execution of script

    Then check the log file /tmp/rc.local.log and verify availability of wi-fi card in Network Manager...

    Happy hacking everyone !

  3. #33
    Join Date
    Mar 2007
    Location
    Netherlands
    Beans
    12
    Distro
    Ubuntu Development Release

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Quote Originally Posted by miyune View Post
    Owhno,

    From your first post of this thread (http://ubuntuforums.org/showthread.php?t=1390979)

    I would propose the following update :

    If /etc/rc.local shabang has the option -e (e.g #!/bin/sh -e), the following code line :

    Code:
    rmmod ssb 
    modprobe wl
    shall be replaced by :

    Code:
    rmmod ssb || true  
    modprobe wl || true

    Yeah I found that out yesterday when it didn't work. Thanks for the comment. I'm currently testing the WL module for maverick, but it currently doesn't compile. Will post an update when it works so that when you all upgrade there is a how-to available.

    Update:
    For MAVERICK 10.10, or when you get this error:
    Code:
    KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
    make[1]: Entering directory `/usr/src/linux-headers-2.6.35-2-generic'
      LD      /home/osteenbergen/wl/built-in.o
      CC [M]  /home/osteenbergen/wl/src/shared/linux_osl.o
      CC [M]  /home/osteenbergen/wl/src/wl/sys/wl_linux.o
    /home/osteenbergen/wl/src/wl/sys/wl_linux.c: In function ‘_wl_set_multicast_list’:
    /home/osteenbergen/wl/src/wl/sys/wl_linux.c:1434: error: ‘struct net_device’ has no member named ‘mc_list’
    /home/osteenbergen/wl/src/wl/sys/wl_linux.c:1434: error: ‘struct net_device’ has no member named ‘mc_count’
    /home/osteenbergen/wl/src/wl/sys/wl_linux.c:1435: error: dereferencing pointer to incomplete type
    /home/osteenbergen/wl/src/wl/sys/wl_linux.c:1441: error: dereferencing pointer to incomplete type
    make[2]: *** [/home/osteenbergen/wl/src/wl/sys/wl_linux.o] Error 1
    make[1]: *** [_module_/home/osteenbergen/wl] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-2-generic'
    make: *** [all] Error 2
    That was easier than I thought thanks to some guys from Gentoo:
    On there bug system they have an patch which needs to be applied (http://bugs.gentoo.org/248450 > http://bugs.gentoo.org/attachment.cgi?id=232555)

    So go to the 'src/wl/sys' folder and execute 'patch < [location_of_the_diff_file]'
    in my case 'patch < ~/Downloads/wl_linux.c.diff'

    Then repeat the steps in post 1 and use the ' || true' as suggested in rc.local


    Update 2:
    For those who get this error:
    Code:
    KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
    make[1]: Entering directory `/usr/src/linux-headers-2.6.35-2-generic'
      CC [M]  /home/osteenbergen/wl/src/shared/linux_osl.o
    In file included from /home/osteenbergen/wl/src/shared/linux_osl.c:19:
    /home/osteenbergen/wl/src/include/linuxver.h:23:28: error: linux/autoconf.h: No such file or directory
    make[2]: *** [/home/osteenbergen/wl/src/shared/linux_osl.o] Error 1
    make[1]: *** [_module_/home/osteenbergen/wl] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-2-generic'
    make: *** [all] Error 2
    The autoconf.h is now under generated/ instead of linux/. So edit the line in the src/include/linuxver.h file.
    Last edited by owhno; June 12th, 2010 at 04:57 PM.

  4. #34
    Join Date
    May 2008
    Location
    Bucharest
    Beans
    12
    Distro
    Ubuntu

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    @earthpigg: Thanks!

  5. #35
    Join Date
    Jun 2010
    Beans
    3

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Code:
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up bcmwl-kernel-source (5.60.48.36+bdcom-0ubuntu3) ...
    dpkg (subprocess): unable to execute installed post-installation script: Exec format error
    dpkg: error processing bcmwl-kernel-source (--configure):
     subprocess installed post-installation script returned error exit status 2
    Errors were encountered while processing:
     bcmwl-kernel-source
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    This is killin me here. I have read google until my eyes bled. Everything I try is just telling me that something isnt right with bcmwl-kernel-source. I don't know what to do. I fear that trying all this different stuff has only made the matter worse.

    Please help

    ------------------------------------------------------------------------------------------------
    --My System--Alienware--M17x------------------------------------------------------------
    Processor(s)
    • Processor- 1
      • CPU_Name- Intel(R) Core(TM)2 Duo CPU T9600 @ 2.80GHz
      • CPU_Manufacturer- GenuineIntel
      • CPU_Caption- Intel64 Family 6 Model 23 Stepping 10
      • CPU_CurrentClockSpeed- 2801MHz
      • CPU_SocketDesignation- Socket 479

    System Memory
    • Memory Module- 1
      • Mem_Capacity- 2048MB
      • Mem_BankLabel- DIMM #1
      • Mem_Type- DDR3
      • Mem_Frequency- MHz
    • Memory Module- 2
      • Mem_Capacity- 2048MB
      • Mem_BankLabel- DIMM #2
      • Mem_Type- DDR3
      • Mem_Frequency- MHz

    BIOS Information
    • BIOS_Manufacturer- Alienware
    • BIOS_Name- Ver A02 1.00PARTTBLZ
    • BIOS_Version1- A02
    • BIOS_Version2- ALWARE - 6040000

    Motherboard Information
    • MB_Manufacturer- Alienware
    • MB_Product
    • MB_Version- A02

    Video Adapter
    • Video_Caption- ATI Mobility Radeon HD 4870
    • Video_AdapterRAM- 1024MB

  6. #36
    Join Date
    Sep 2009
    Beans
    8

    Cool Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    i had a failed install for broadcom sta wireless, i tried to activate but, failed.
    can you tell me why this would be.
    patiently waiting.
    Paul, 3 day old linux user

  7. #37
    Join Date
    Sep 2009
    Beans
    8

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    i should mention that i went to hardware drivers and tried the install, there were 2 listings, neither worked, i noticed the dependancy that was missing and updated, loaded it and there after i had a fail while loading.
    why would this happen
    cheers again

  8. #38
    Join Date
    Jan 2007
    Location
    Hermosillo, Sonora, Méxic
    Beans
    31
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    Well, I just thought I'd contribute here.

    I tried the original solution and it worked... until I rebooted again. Then I couldn't see the right driver in the Hardware Driver Manager and even if I repeat all the steps (and try the other solutions suggested in following comments by others) I just couldn't get it to work again.

    So my solution? Since I hadn't installed anything, I just reinstalled ubuntu from the start. In the liveCD session I can see the right driver in the Hardware Drivers thing, so I selected it. After it downloaded and installed, it asked me to reboot (doing so at this point undoes everything). I didn't reboot but instead finished the installation and then rebooted.

    The driver was working after reboot and after the next reboots. It even connected automatically.

  9. #39
    Join Date
    Nov 2004
    Beans
    226
    Distro
    Ubuntu

    Solved

    I solved this problem for a friend in a slighty different way. I hope this helps.


    1. Add the LiveCD as a repository and Uncheck ALL other repositories.
    System> Administration> Software Sources

    2. Update software sources. This can be done when you close the Software Sources window, or by using Synaptic.
    System> Administration> Synaptic Package Manager> Reload (button)

    3. Use Synaptic to Remove bad packages if they are installed.
    System> Administration> Synaptic Package Manager> Search (button)
    * bcmwl-kernel-source
    * b43-fwcutter
    * linux-image-2.6.32-22-generic (any linux-image 2.6.32-22 or greater)

    4. Use Synaptic to Lock the kernel package linux-image-2.6.32-21-generic, and lock the package linux-headers-generic to version 2.6.32-21.32. (This will prevent the problem from occurring again with future upgrades).
    System> Administration> Synaptic Package Manager> Package (menu)> Lock Version

    5. Reboot (restart)

    6. Install the wifi driver.
    System> Administration> Hardware Drivers

    7. Reboot (restart)

    8. Remove the LiveCD as a repository, and Recheck all the repositories that were unchecked in step #1.
    System> Administration> Software Sources
    Last edited by Sepero; June 18th, 2010 at 06:46 PM.

  10. #40
    Join Date
    Jun 2009
    Beans
    108

    Re: Broadcom Wireless STA driver (wl) Ubuntu 9.10/10.04

    I get this:

    Code:
    adrian@Alpha-60:~/Downloads/hybrid-portsrc-x86_64-v5.60.48.36$ make
    KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
    make: *** /lib/modules/2.6.32-22-preempt/build: No such file or directory.  Stop.
    make: *** [all] Error 2

Page 4 of 11 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •