Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Unknown encoder 'libmp3lame'

  1. #21
    Join Date
    May 2008
    USA New York
    Ubuntu 14.04 Trusty Tahr

    Re: Unknown encoder 'libmp3lame'

    Quote Originally Posted by tarahmarie View Post
    For Precise, install libavcodec-extra-53; looks like an update to the package, but this fix works perfectly.
    Tried doing that.
    Then ran ffmpeg and it didn't work for me.
    I got this output in terminal:

    rr@rr-Studio-XPS-8000:~$ ffmpeg -loop_input -i ~/Desktop/1.jpg -i ~/Desktop/E.mp3 -shortest -b 1000k -acodec copy video.mp4
    ffmpeg version 0.8.3-4:0.8.3-0ubuntu0.12.04.1, Copyright (c) 2000-2012 the Libav developers
    built on Jun 12 2012 16:52:09 with gcc 4.6.3
    This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
    -loop_input is deprecated, use -loop 1
    Input #0, image2, from '/home/rr/Desktop/1.jpg':
    Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0.0: Video: mjpeg, yuvj422p, 2048x1536, 25 tbr, 25 tbn, 25 tbc
    -loop_input is deprecated, use -loop 1
    [mp3 @ 0x2529660] max_analyze_duration reached
    Input #1, mp3, from '/home/rr/Desktop/E.mp3':
    artist : Eliane Elias
    album : Yule Struttin' - A Blue Note Christmas
    genre : Jazz
    track : 4
    title : I'll Be Home For Christmas / Sleigh Ride
    date : 1990
    Duration: 00:04:57.06, start: 0.000000, bitrate: 185 kb/s
    Stream #1.0: Audio: mp3, 44100 Hz, stereo, s16, 185 kb/s
    File 'video.mp4' already exists. Overwrite ? [y/N] y
    Incompatible pixel format 'yuvj422p' for codec 'mpeg4', auto-selecting format 'yuv420p'
    [buffer @ 0x2537100] w:2048 h:1536 pixfmt:yuvj422p
    [avsink @ 0x2551d20] auto-inserting filter 'auto-inserted scaler 0' between the filter 'src' and the filter 'out'
    [scale @ 0x2557a40] w:2048 h:1536 fmt:yuvj422p -> w:2048 h:1536 fmt:yuv420p flags:0x4
    Output #0, mp4, to 'video.mp4':
    encoder : Lavf53.21.0
    Stream #0.0: Video: mpeg4, yuv420p, 2048x1536, q=2-31, 1000 kb/s, 25 tbn, 25 tbc
    Stream #0.1: Audio: libmp3lame, 44100 Hz, stereo, 185 kb/s
    Stream mapping:
    Stream #0.0 -> #0.0
    Stream #1.0 -> #0.1
    Press ctrl-c to stop encoding
    frame= 1 fps= 0 q=9.4 Lsize= 176kB time=0.04 bitrate=35969.6kbits/s
    video:174kB audio:0kB global headers:0kB muxing overhead 0.685802%

    What went wrong?
    Ubuntu 14.04 64bit Ext4 on a Dell Studio XPS Desktop Intel® Core™ i7-860 2.8GHz, 8GB DDR3 ram and Dual booting: Ubuntu 14.04 64bit Ext4 & 32bit Vista Home Premium, on a Toshiba laptop dual core AMD Turion 64, 2.0 GHz, 4GB ram.

  2. #22
    Join Date
    Feb 2010

    Re: Unknown encoder 'libmp3lame'

    Have you tried in other files? I suppose that something is wrong with object. You should also check winff (your life will be simplier ;>).

  3. #23
    Join Date
    Dec 2012

    Re: Unknown encoder 'libmp3lame'

    Tks man! You save me!

  4. #24
    Join Date
    May 2007
    Ubuntu 15.10 Wily Werewolf

    Re: Unknown encoder 'libmp3lame'

    Quote Originally Posted by tarahmarie View Post
    For Precise, install libavcodec-extra-53; looks like an update to the package, but this fix works perfectly.
    Thanks for this. In Ubuntu 12.04 (Precise), I used Synaptic to install libavcodec-extra-53. The terminal output looked kinda scary, so I made a note of what was installed and removed, but then everything worked fine. From my /var/log/apt/history.log:

    Start-Date: 2013-10-14  21:53:47
    Commandline: /usr/sbin/synaptic
    Install: libopenjpeg2:i386 (1.3+dfsg-4+squeeze1build0.12.04.1, automatic), libavcodec-extra-53:i386 (0.8.6ubuntu0.12.04.1), libavutil-extra-51:i386 (0.8.6ubuntu0.12.04.1, automatic)
    Remove: libavutil51:i386 (0.8.6-0ubuntu0.12.04.1), libavcodec53:i386 (0.8.6-0ubuntu0.12.04.1)
    End-Date: 2013-10-14  21:54:08
    This post is probably gonna get nailed for necromancy, but I thought that Precise users who find this thread might appreciate seeing what got removed on my system.

  5. #25
    Join Date
    Oct 2013

    Re: Unknown encoder 'libmp3lame'

    Just a quick note to anyone else with this issue (for me, it came up at some point when trying to use youtube-dl --extract-audio --audio-format=mp3): the tip about libavcodec-extra-53 didn't seem to work for me (see also ubuntu-restricted-extras) apparently since, from which libavcodec-extra-53 gets downloaded, is no longer maintained. (I am using Linux Mint 13 at the moment but don't see how this would make a difference)

    I can't see what's in the thread mentioned in post #3 of this thread since I have less than 10 posts, but ultimately what worked was, as mentioned in that post, to build ffmpeg from source with libmp3lame enabled following the guide at (and after building it, remember to logout/login (or run ~/.profile in your terminal, as in the guide) to be sure that you're actually using it).

    Also, if you're confused about avconv and ffmpeg, be sure to read this: -- as well as the final link mentioned in that answer:
    Last edited by rziman; October 19th, 2013 at 05:39 AM.

Page 3 of 3 FirstFirst 123


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts