Results 1 to 4 of 4

Thread: mysql-admin won't schedule backup but will manual backup

  1. #1
    Join Date
    Feb 2008
    Location
    Swansea
    Beans
    144
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    mysql-admin won't schedule backup but will manual backup

    I have a scheduled backup to run on our server at work and since the 7/12/09 it has be making 592k files instead of 10Mb files, and I have no idea why!?!

    In mysql-admin (the GUI tool) I have a stored connection for the user 'backup', the user has select and lock rights on the databases being backed up. I have a backup profile called 'backup_regular' and in the third tab along its scheduled to backup at 2 in the morning every week day.

    If I look at one of the small backup files generated I see the following:

    Code:
    -- MySQL Administrator dump 1.4
    --
    -- ------------------------------------------------------
    -- Server version	`
    
    
    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;
    
    /*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
    /*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
    /*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
    If I run the backup profile manually I get the following:

    Code:
    -- MySQL Administrator dump 1.4
    --
    -- ------------------------------------------------------
    -- Server version	5.0.75-0ubuntu10.2
    
    
    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
    /*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
    /*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
    /*!40101 SET NAMES utf8 */;
    
    /*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
    /*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
    /*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
    
    
    --
    -- Create schema wordpress
    --
    
    CREATE DATABASE IF NOT EXISTS wordpress;
    USE wordpress;
    
    --
    -- Definition of table `wordpress`.`wp_comments`
    --
    
    DROP TABLE IF EXISTS `wordpress`.`wp_comments`;
    CREATE TABLE  `wordpress`.`wp_comments` (
      `comment_ID` bigint(20) unsigned NOT NULL auto_increment,
      `comment_post_ID` int(11) NOT NULL default '0',
      `comment_author` tinytext NOT NULL,
    ...
    ...
    As you can see the only difference between the files in the headers is the fact that the failed backup one does not list the server version:

    Code:
    -- Server version	`
    apposed to:

    Code:
    -- Server version	5.0.75-0ubuntu10.2
    In the manual version

    It seems that MySQL can open and write to the file fine, it just can't dump

    Does anyone have any ideas why this would happen or how I could find out whats going on?
    There is nothing common about sense - unknown

  2. #2
    Join Date
    Feb 2008
    Location
    Swansea
    Beans
    144
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: mysql-admin won't schedule backup but will manual backup

    anyone?
    There is nothing common about sense - unknown

  3. #3
    Join Date
    Feb 2008
    Location
    Swansea
    Beans
    144
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: mysql-admin won't schedule backup but will manual backup

    I have tried changing the stored connection to:

    127.0.0.1 - The IP under server information in mysql-admin
    127.0.1.1 - The IP under client information in mysql-admin
    192.168.2.5 - The IP of the machine on the network

    all to no avail
    There is nothing common about sense - unknown

  4. #4
    Join Date
    Feb 2008
    Location
    Swansea
    Beans
    144
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: mysql-admin won't schedule backup but will manual backup



    PROBLEM SOLVED!!!

    Hi,

    I solved this problem by activating the 'store connection password' option located in Tools - Preferences - General Options.

    Don't forget to re-enter the connection password in Tools - Manage Connections.

    Regards.

    Gwen
    There is nothing common about sense - unknown

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •