Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: How do I disable bluetooth on boot up?

  1. #11
    Join Date
    Sep 2009
    Location
    Missouri, USA
    Beans
    265
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How do I disable bluetooth on boot up?

    Here ya go:
    Code:
    user@ubuntu:~$rfkill list
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    Script will be very helpful. How did you learn about this useful little command?

    -- until I hear from you with the script, I tried
    Code:
    sudo rfkill block bluetooth
    and it turned off bluetooth, BUT when I rebooted, bluetooth was back on. Isn't this supposed to be remembered after a reboot?
    Last edited by shawnboy; January 15th, 2010 at 10:58 PM. Reason: add info
    I'd rather die fighting lions than being trampled by geese.

  2. #12
    Join Date
    May 2008
    Location
    Cluj, Romania
    Beans
    1,292

    Re: How do I disable bluetooth on boot up?

    Quote Originally Posted by shawnboy View Post
    Here ya go:
    Code:
    user@ubuntu:~$rfkill list
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    Script will be very helpful. How did you learn about this useful little command?
    Here you go. Remember, you MUST launch these scripts with administrator (root) privileges. If you plan to make a menu item for them the command is in the following format:

    Code:
    gksudo bash /path/scriptname
    Attached Files Attached Files

  3. #13
    Join Date
    May 2008
    Location
    Cluj, Romania
    Beans
    1,292

    Re: How do I disable bluetooth on boot up?

    Quote Originally Posted by shawnboy View Post
    Here ya go:
    Code:
    user@ubuntu:~$rfkill list
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    Script will be very helpful. How did you learn about this useful little command?

    -- until I hear from you with the script, I tried
    Code:
    sudo rfkill block bluetooth
    and it turned off bluetooth, BUT when I rebooted, bluetooth was back on. Isn't this supposed to be remembered after a reboot?
    It may not remember on reboot. Sorry, i wanted to say hibernate. I rarely reboot my laptop, i use hibernate/suspend. Also, my laptop (Dell D630) has 2 wireless/2 bluetooth (virtual) devices: dell-wifi/phy0 and del-bluetooth/hci0. I control the dell devices, but it works all the same on the others also.

    I kinda stumbled upon the command messing around.

  4. #14
    Join Date
    Sep 2009
    Location
    Missouri, USA
    Beans
    265
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How do I disable bluetooth on boot up?

    Thanks! Those scripts will come in handy.

    I took it one step further for my use. I added
    Code:
    rfkill block bluetooth
    to my /etc/rc.local file just before the last line (exit 0). Now my bluetooth is turned off at every boot, but the bluetooth applet and dimmed icon is still in the panel (like I wanted) so I can turn it back on anytime I want.

    Thanks for the help!
    I'd rather die fighting lions than being trampled by geese.

  5. #15
    Join Date
    Nov 2006
    Location
    Canada
    Beans
    71
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How do I disable bluetooth on boot up?

    Nice! An easy solution to turn off the bluetooth hardware using cli.

  6. #16
    Join Date
    Jan 2010
    Beans
    4

    Re: How do I disable bluetooth on boot up?

    run this:
    sudo echo "options rfkill master_switch_mode=0" > /etc/modprobe.d/rfkill.conf
    this will stop bluetooth being activated during boot.

    See: http://comments.gmane.org/gmane.linu...cpi.devel/1955

  7. #17
    Join Date
    Feb 2010
    Beans
    17

    Re: How do I disable bluetooth on boot up?

    Quote Originally Posted by aaron.lwe View Post
    run this:
    sudo echo "options rfkill master_switch_mode=0" > /etc/modprobe.d/rfkill.conf
    this returns a: bash: /etc/modprobe.d/rfkill.conf: Permission denied

    How to do it?

    Thanks,
    Lokesh

  8. #18
    Join Date
    Jan 2010
    Beans
    4

    Re: How do I disable bluetooth on boot up?

    Quote Originally Posted by Lokesh123 View Post
    this returns a: bash: /etc/modprobe.d/rfkill.conf: Permission denied

    How to do it?

    Thanks,
    Lokesh
    Make sure you are allowed to sudo, or you just run this command as root, as creating a new file named rfkill.conf under /etc/modprobe.d requires root privilege.

  9. #19
    Join Date
    Nov 2005
    Location
    Kerala,India
    Beans
    534
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Post Re: How do I disable bluetooth on boot up?

    I wanted bluetooth device(On the PC) disabled when booted.
    Code:
    sudo su -
    Code:
    hciconfig hci0 down
    ^ will make bluetooth device disabled.


    I don't remember how exactly..But ,I made a script with above syntax and put it in /etc/init.d/somefilename and some link made to /etc/rcS.d/filename .(I forgot all this ...will try to find the proper way to add a script to be ran on boot up.)
    UPDATE:
    Here is how:

    • Make a file inside /etc/init.d/ as "nobluetooth" with below content :

    Code:
    #!/bin/bash
    echo "Disabling hci0 bluetooth usb dongle"
    
    /usr/sbin/hciconfig hci0 down &
    and give it execution right(sudo chmod +x /etc/init.d/nobluetooth)


    • Run update-rc.d to wire all the symlinks needed for boot

    Code:
    update-rc.d nobluetooth start 26 2 3 4 5  .

    • On next boot ,open a terminal and check "hciconfig" output to confirm hci0 is "down"


    • later,if You want to enable bluetooth :

    Code:
    sudo hciconfig hci0 up
    OR Even a Launcher on Desktop/Panel with:
    Code:
    gksudo  hciconfig hci0 up
    --
    But ,Another Easy way is to blacklist kernel module bluetooth by adding into /etc/modprobe.d/blacklist.conf with a new line:
    Code:
    blacklist bluetooth
    ^^^ This way ,bluetooth is permanently disabled in the PC.
    ^/etc/modprobe.d/00.local file was used in earlier distros when blacklisting some modules never worked with blacklist.conf entry.

    Thanks
    Last edited by deepclutch; May 12th, 2010 at 02:45 PM.

  10. #20
    Join Date
    Jul 2007
    Location
    Upstate NY
    Beans
    17
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: How do I disable bluetooth on boot up?

    gradinaruvasile suggestion worked for me! Backed up rc.local when updates wipe out my tweaking.

    SIN

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •