Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: NTFS: unable to execute ---: Permission denied

  1. #1
    Join Date
    Dec 2005
    Beans
    166
    Distro
    Ubuntu 6.10 Edgy

    NTFS: unable to execute ---: Permission denied

    I have an NTFS partition mounted with
    Code:
    /dev/sdb1       /media/ntfs   ntfs    force,defaults,users,gid=1000,uid=1000,umask=000        0       0
    but I cannot execute executables on that partition. I simply get something like,
    Code:
    bash: ./t: Permission denied
    How do I fix these permissions?

  2. #2
    Join Date
    Jun 2009
    Location
    Open Linux Forums
    Beans
    2,710

    Re: NTFS: unable to execute ---: Permission denied

    remove that line from your fstab, add yourself to the fuse group:
    Code:
    sudo adduser <userid> fuse
    install ntfs-config:
    Code:
    sudo apt-get install ntfs-config
    set the partition to automount in ntfs-config (you'll find it in the menu under System>Administration>NTFS Configuration Tool)
    I'm not antisocial. I'm just not user friendly...
    Open Linux Forums

  3. #3
    Join Date
    Dec 2005
    Beans
    166
    Distro
    Ubuntu 6.10 Edgy

    Re: NTFS: unable to execute ---: Permission denied

    Can you please explain what the difference is? I'd rather just fix my fstab as it is. (I am also already in the fuse group).

  4. #4
    Join Date
    Mar 2008
    Location
    The Burning Earth.
    Beans
    3,660

    Re: NTFS: unable to execute ---: Permission denied

    Quote Originally Posted by Mazin View Post
    Can you please explain what the difference is? I'd rather just fix my fstab as it is. (I am also already in the fuse group).
    Installing ntfs-config will allow you to toggle on and off write support for internal and external drives formated as NTFS.
    God does not play dice with the universe - Albert Einstein
    Sure I do, I just use loaded dice. - warfacegod

    An open forum. Its a free for all. Check us out. https://openlinuxforums.org/

  5. #5
    Join Date
    Dec 2005
    Beans
    166
    Distro
    Ubuntu 6.10 Edgy

    Re: NTFS: unable to execute ---: Permission denied

    I already have read/write on the NTFS partition. I cannot, however, execute binaries. I would like to know what error is in my mount statement (if any).

  6. #6
    Join Date
    Jun 2009
    Location
    Open Linux Forums
    Beans
    2,710

    Re: NTFS: unable to execute ---: Permission denied

    Quote Originally Posted by Mazin View Post
    I already have read/write on the NTFS partition. I cannot, however, execute binaries. I would like to know what error is in my mount statement (if any).
    i'm not a fstab wiz, but i think that the gid and uid options pretty much annul the users option.
    I'm not antisocial. I'm just not user friendly...
    Open Linux Forums

  7. #7
    Join Date
    Nov 2007
    Beans
    2

    Re: NTFS: unable to execute ---: Permission denied

    Thank you Leppie.

    I had the same (non)execute permissions surprise as Mazin, having provided users,gid,uid and umask options in the fstab. After removing the superflous users option, the execute permissions started behaving as expected again.

  8. #8
    Join Date
    Jun 2009
    Location
    0000:0400
    Beans
    Hidden!

    Re: NTFS: unable to execute ---: Permission denied

    FYI: users and gid/uid options aren't related. One sets the owner/group permissions, the other specifies who's able to mount the drive. Inherent to the 'users' option, however, is the 'noexec' option which prevents execution of files on the partition.

  9. #9
    Join Date
    Oct 2011
    Beans
    4

    Re: NTFS: unable to execute ---: Permission denied

    Thank you for the information.
    I was going crazy for almost 1 hour, because I wasn't able to execute something on my 2nd partition.
    By purging the 'users' option it started to work as expected.

    Thx

  10. #10
    Join Date
    Sep 2009
    Location
    UK
    Beans
    435
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: NTFS: unable to execute ---: Permission denied

    rw,nosuid,nodev,allow_other,default_permissions options in fstab should work...
    My personal website with blog n apps
    http://www.mikejonesey.co.uk/

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •