Results 1 to 2 of 2

Thread: compile poppler

  1. #1
    Join Date
    Nov 2008
    Beans
    5

    compile poppler

    Does anyone has an idea why poppler 0.12 cannot be compiled on ubuntu 8.04 but it works on ubuntu 8.10 ?

    the configure parameters are:
    ./configure --disable-static --disable-cairo-output --enable-xpdf-headers --disable-poppler-qt --enable-poppler-qt4 --disable-splash-output --disable-gdk --disable-poppler-glib

    and the make error on ubuntu 8.04 is:
    poppler-page.cc: In static member function ‘static Poppler::Link* Poppler:ageData::convertLinkActionToLink(LinkAction*, Poppler:ocumentData*, const QRectF&)’:
    poppler-page.cc:79: warning: enumeration value ‘actionRendition’ not handled in switch
    poppler-page.cc: In member function ‘QImage Poppler:age::renderToImage(double, double, int, int, int, int, Poppler:age::Rotation) const’:
    poppler-page.cc:201: warning: unused variable ‘rotation’
    poppler-page.cc: In member function ‘QImage Poppler:age::thumbnail() const’:
    poppler-page.cc:293: error: ‘Format_RGB888’ is not a member of ‘QImage’
    make[3]: *** [poppler-page.lo] Error 1

    the code where is error apears is:

    QImage Page::thumbnail() const
    {
    unsigned char* data = 0;
    int w = 0;
    int h = 0;
    int rowstride = 0;
    GBool r = m_page->page->loadThumb(&data, &w, &h, &rowstride);
    QImage ret;
    if (r)
    {
    // first construct a temporary image with the data got,
    // then force a copy of it so we can free the raw thumbnail data
    ret = QImage(data, w, h, rowstride, QImage::Format_RGB888).copy();
    gfree(data);
    }
    return ret;
    }



    I've tried more versions and poppler-0.10.7 and below this version works on ubuntu 8.04

    Please don't tell me to install it from repository, I need to compile poppler.
    Last edited by mihaiadrian; January 4th, 2010 at 11:35 AM.

  2. #2
    Join Date
    Jun 2007
    Beans
    12,682

    Re: compile poppler

    This is same error, maybe solution will work for you: http://www.kdenlive.org/forum/qimage...-revision-1218

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •