Results 1 to 5 of 5

Thread: GNOME Commander - default application

Hybrid View

  1. #1
    Join Date
    Oct 2007
    Location
    Sydney
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    GNOME Commander - default application

    Trying to open a file in GNOME Commander (1.2.7 Ubuntu 9.04) produces the following (not very helpful) error message:-

    No default application found for the MIME type application/x-glade.
    Open the "File types and programs" page in the Control Center to add one.

    Trying to change the default application in Properties by clicking the Change button has no effect (it just changes colour).

    The default is set in Nautilus, and works there.

  2. #2
    Join Date
    Jan 2010
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: GNOME Commander - default application

    Apparently, this is currently broken in Gnome Commander.
    As it says on their documentation page, http://www.nongnu.org/gcmd/doc.html#mime :

    Since GNOME has changed to follow the freedesktop.org standard of handling mimetypes, the editing of preferred programs in GNOME Commander is currently broken (v 1.1.7). We do have this in our TODO file, but until GCMD can handle edititing of preferred programs, there are two other ways of managing this on user basis; use nautilus or manually edit the configuration files that controls mime types in your home directory.
    Well, using Nautilus didn't help me, I had a particular mime setting set up and working in Nautilus also, but not in Gnome Commander. Manually editing ~/.local/share/applications/defaults.list fixed this. Check that you have the line in that file that says:
    application/x-glade=NAME_OF_YOUR_PREFFERED_APPLICATION.desktop

    Look at http://www.nongnu.org/gcmd/doc.html#mime , and for manually editing files look at
    http://library.gnome.org/admin/syste...tering.html.en

  3. #3
    Join Date
    Oct 2007
    Location
    Sydney
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: GNOME Commander - default application

    Quote Originally Posted by bneven View Post
    Apparently, this is currently broken in Gnome Commander.
    As it says on their documentation page, http://www.nongnu.org/gcmd/doc.html#mime :



    Well, using Nautilus didn't help me, I had a particular mime setting set up and working in Nautilus also, but not in Gnome Commander. Manually editing ~/.local/share/applications/defaults.list fixed this. Check that you have the line in that file that says:
    application/x-glade=NAME_OF_YOUR_PREFFERED_APPLICATION.desktop

    Look at http://www.nongnu.org/gcmd/doc.html#mime , and for manually editing files look at
    http://library.gnome.org/admin/syste...tering.html.en
    Thanks.

    There was no defaults.list, so I created one with the following:-
    Code:
    [Default Applications]
    application/x-glade=glade-3.desktop

  4. #4
    Join Date
    Jun 2012
    Beans
    1

    Re: GNOME Commander - default application

    Quote Originally Posted by Milliways View Post
    Thanks.

    There was no defaults.list, so I created one with the following:-
    Code:
    [Default Applications]
    application/x-glade=glade-3.desktop
    This discussion was extremely helpful.

    Putting defaults.list in ~/.local/share/applications as instructed by

    http://library.gnome.org/admin/syste...tering.html.en

    did not work for me.
    I spent quite a while looking for an answer and finally located defaults.list in

    /usr/local/share/applications

    Editing that file did the trick.

  5. #5
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: GNOME Commander - default application

    Old thread closed.
    Ubuntu 16.04 Desktop Guide - Ubuntu 17.10 Desktop Guide - Forum Guide to BBCode - Using BBCode code tags - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •