Page 3 of 12 FirstFirst 12345 ... LastLast
Results 21 to 30 of 117

Thread: Speakers AND headphones playing sound simultaneously.

  1. #21
    Join Date
    Jun 2007
    Beans
    13,730

    Re: Speakers AND headphones playing sound simultaneously.

    Quote Originally Posted by slooksterpsv View Post
    I have a Gateway NV53
    http://www.backports.ubuntuforums.or....php?p=9318502

  2. #22
    Join Date
    Sep 2008
    Beans
    16

    Re: Speakers AND headphones playing sound simultaneously.

    With regards to eternal243's post, I would also like to offer an option for filling in the "model=" parameter. I was browsing an ArchLinux forum and one user recommended using

    options snd-hda-intel model=auto

    for /etc/modprobe.d/alsa-base.conf

    I mention this only because my Lenovo Y510 running 10.04, using model=lenovo nb0763 was giving me subwoofer support but not headphones and with it disabled giving me the opposite and only giving me internal mic support with it disabled, but by using model=auto I have everything at the same time!!!

    Just something to try...

  3. #23
    Join Date
    Aug 2007
    Location
    Kaiserslautern, Germany
    Beans
    89
    Distro
    Ubuntu Development Release

    Re: Speakers AND headphones playing sound simultaneously.

    Someone please help me fix this problem! I have an Alienware M9750, and ever since Karmic, pulseaudio has screwed up headphone detection (it doesn't, even though the way the speakers sound changes on the laptop) and plays through both the speakers and the headphones all the time. The only solution I've had is to kill pulseaudio and use alsamixer to turn off the speakers. Also of note is the fact that the optical (digital) out and the surround pugs aren't working correctly either.

    Here's the obligatory information:

    Code:
    phyrewall@zangetsu:~$ uname -a
    Linux zangetsu 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
    Code:
    phyrewall@zangetsu:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC889A Analog [ALC889A Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC889A Digital [ALC889A Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    phyrewall@zangetsu:~$ cat /proc/asound/card0/codec#* | grep CodecCodec: Realtek ALC889A
    Codec: LSI ID 1040
    Code:
    phyrewall@zangetsu:~$ lspci | grep Audio
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    Thanks in advance, this is really bugging me!!
    Ubuntu Missionary in Germany. Converting M$ Drones one at a time.
    OIF Veteran, Disabled American Vet, Veteran of Foreign Wars, American Legionnaire, Father of two Future Ubuntu Users.

  4. #24
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: Speakers AND headphones playing sound simultaneously.

    Quote Originally Posted by phyrewall View Post
    Someone please help me fix this problem! I have an Alienware M9750, and ever since Karmic, pulseaudio has screwed up headphone detection (it doesn't, even though the way the speakers sound changes on the laptop) and plays through both the speakers and the headphones all the time. The only solution I've had is to kill pulseaudio and use alsamixer to turn off the speakers. Also of note is the fact that the optical (digital) out and the surround pugs aren't working correctly either.

    Here's the obligatory information:

    Code:
    phyrewall@zangetsu:~$ uname -a
    Linux zangetsu 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
    Code:
    phyrewall@zangetsu:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC889A Analog [ALC889A Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC889A Digital [ALC889A Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    phyrewall@zangetsu:~$ cat /proc/asound/card0/codec#* | grep CodecCodec: Realtek ALC889A
    Codec: LSI ID 1040
    Code:
    phyrewall@zangetsu:~$ lspci | grep Audio
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    Thanks in advance, this is really bugging me!!

    Using a Terminal="Applications->Accessories->Terminal"
    Open this file for editing:
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Insert this line at the bottom:
    Code:
     options snd-hda-intel model=6stack-dig
    Save. Close. Reboot. Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default.

  5. #25
    Join Date
    Nov 2005
    Location
    Jackson, TN USA
    Beans
    462
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Speakers AND headphones playing sound simultaneously.

    figure I'll try my laptop too, why not...

    Its an Asus K50IJ.

    Here's the info on the sound card:



    Code:
    myk@mobileOne:/etc/modprobe.d$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: VT1708S Analog [VT1708S Analog]
      Subdevices: 2/2
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
    myk@mobileOne:/etc/modprobe.d$ cat /proc/asound/card0/codec#* | grep Codec
    Codec: VIA VT1708S
    myk@mobileOne:/etc/modprobe.d$
    I have the same problem, the speaker still plays when my headphones are plugged in.
    Need assistance with the correct model setting for alsa, please.

    Thanks in advance.
    -myk
    "Despite millions of dollars of research, Death continues to be Americas number one killer."

    Kingdom Computer Solutions

  6. #26
    Join Date
    Nov 2005
    Location
    Jackson, TN USA
    Beans
    462
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Speakers AND headphones playing sound simultaneously.

    bump
    "Despite millions of dollars of research, Death continues to be Americas number one killer."

    Kingdom Computer Solutions

  7. #27
    Join Date
    Sep 2007
    Beans
    50

    Re: Speakers AND headphones playing sound simultaneously.

    I have the same issue. I manually direct output to my headphones to resolve the issue.

    Firstly, it's worth pointing out I did not even get a headphone option until I added the correct model to the alsa-base.conf file.

    To switch to headphones I go to:
    1. system->preferences->sound
    2. Then switch to output tab
    3. You should see a drop down (connector). Switch it to headphones or analog headphones.
    4. When done switch back.

    If you don't see a connector drop down you need to correct your model in alsa-base.conf

    Hope this helps, George

  8. #28
    Join Date
    Nov 2005
    Location
    Jackson, TN USA
    Beans
    462
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Speakers AND headphones playing sound simultaneously.

    I get the headphone connector option all the time, it just still continues to play through both. In the process of trial and error now. Tried the obvious "asus-laptop" for mine, but no dice...
    "Despite millions of dollars of research, Death continues to be Americas number one killer."

    Kingdom Computer Solutions

  9. #29
    Join Date
    Sep 2007
    Beans
    50

    Re: Speakers AND headphones playing sound simultaneously.

    I would try a few other models. I tried a bunch until one finally worked.

  10. #30
    Join Date
    May 2010
    Location
    Hyderabad
    Beans
    18
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Speakers AND headphones playing sound simultaneously.

    Quote Originally Posted by lidex View Post
    I haven't seen it. Do this for me. Can you post the output of these terminal commands for me please:
    Code:
    uname -a
    aplay -l
    cat /proc/asound/version
    Terminal="Applications->Accessories->Terminal"
    Please also include the make/model of your PC/Laptop.
    Please post text output using code tags (the # in toolbar)
    hi,
    sorry for replying late, didn't check this forum in days .

    Anyway, heres the output I get:
    Code:
    $uname -a
    
    Linux user@laptop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux
    Code:
    $ aplay -l
    
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    $cat /proc/asound/version
    
    Advanced Linux Sound Architecture Driver Version 1.0.21.
    Laptop Model: Lenovo G560
    Thanks!
    Last edited by saiganeshb; June 4th, 2010 at 04:52 AM.

Page 3 of 12 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •