Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: I can't use ststic ip with wireless internet connection

  1. #1
    Join Date
    Nov 2009
    Location
    Damascus
    Beans
    225
    Distro
    Kubuntu

    I can't use ststic ip with wireless internet connection

    When I change the connection settings from DHCP to manual ip configuration i lose the ability to browse internet but instead i can see the current network.


    DHCP= internet connection
    Manual= local connection

    Can I have both at the same time using the same wireless ?

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: I can't use ststic ip with wireless internet connection

    When I change my wireless network manager settings from DHCP to manual (in Karmic) I can still browse the internet just fine. So, the question is, what did you do when you set up a manual IP address? Did you use network manager? Most importantly, did you assign DNS server addresses?

    You say:

    Quote Originally Posted by ibrahim.k View Post
    DHCP= internet connection
    Manual= local connection

    Can I have both at the same time using the same wireless ?
    I'm not quite sure what you mean by this. Your local network address will be in the range 192.168.x.y or 10.0.x.y depending on the make of router, whether or not you have set up the address manually, or whether you are using DHCP.

    Your external IP address (the outward-facing address on your router) will be assigned by your ISP. There's nothing you can do about that.

    What version of Ubuntu are you using? I presume you are using a wireless modem-router. Correct? Do you have any other computers on your local network? Do you assign manual addresses with them or do you use DHCP?
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Aug 2008
    Beans
    488

    Re: I can't use ststic ip with wireless internet connection

    yes with an interface alias (eth0:1), but you will have to let go of the network manager gui and configure your network in /etc/network/interfaces

    Code:
    auto lo eth0 eth0:1
    iface eth0 inet dhcp
    
    iface eth0:1 inet static
            address 192.168.10.1
            netmask 255.255.255.0
    and restart networking
    Code:
    sudo service network restart
    Last edited by puppywhacker; December 28th, 2009 at 07:09 PM.

  4. #4
    Join Date
    Nov 2009
    Location
    Damascus
    Beans
    225
    Distro
    Kubuntu

    Re: I can't use ststic ip with wireless internet connection

    I tried it on ubuntu 9.10 and it didn't work


    Quote Originally Posted by puppywhacker View Post
    yes with an interface alias (eth0:1), but you will have to let go of the network manager gui and configure your network in /etc/network/interfaces

    Code:
    auto lo eth0 eth0:1
    iface eth1 inet dhcp
    
    iface eth0:1 inet static
            address 192.168.1.1
            netmask 255.255.255.0

  5. #5
    Join Date
    Nov 2009
    Location
    Damascus
    Beans
    225
    Distro
    Kubuntu

    Re: I can't use ststic ip with wireless internet connection

    i am using ubuntu 9.10 when i changed it into the manual ip adress using the network manager it was like this
    192.168.10.1
    255.255.255.0
    192.168.10.1
    I didn't use DNS settings the field is empty
    i am using my laptop wireless
    yes i have other computers on the local network I don't use dhcp mode with them
    thnx coffeecat

    Quote Originally Posted by coffeecat View Post
    When I change my wireless network manager settings from DHCP to manual (in Karmic) I can still browse the internet just fine. So, the question is, what did you do when you set up a manual IP address? Did you use network manager? Most importantly, did you assign DNS server addresses?

    You say:



    I'm not quite sure what you mean by this. Your local network address will be in the range 192.168.x.y or 10.0.x.y depending on the make of router, whether or not you have set up the address manually, or whether you are using DHCP.

    Your external IP address (the outward-facing address on your router) will be assigned by your ISP. There's nothing you can do about that.

    What version of Ubuntu are you using? I presume you are using a wireless modem-router. Correct? Do you have any other computers on your local network? Do you assign manual addresses with them or do you use DHCP?

  6. #6
    Join Date
    May 2008
    Location
    Cluj, Romania
    Beans
    1,292

    Re: I can't use ststic ip with wireless internet connection

    Quote Originally Posted by ibrahim.k View Post
    When I change the connection settings from DHCP to manual ip configuration i lose the ability to browse internet but instead i can see the current network.


    DHCP= internet connection
    Manual= local connection

    Can I have both at the same time using the same wireless ?
    You can have 1 ip assigned to 1 device... Why do you need both?
    I use manual IP on wireless and works, no problem.

    Try this:
    Set to dhcp, connect to it, right-click on the network manager icon, select connection information.
    Copy all data from there.

    Then set up your manual connection, make sure you give an IP from the same class, use the same netmask, and the most important, use the same gateway/dns servers as from the dhcp connection. That way it will work.

  7. #7
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: I can't use ststic ip with wireless internet connection

    Quote Originally Posted by ibrahim.k View Post
    192.168.10.1
    255.255.255.0
    192.168.10.1
    I didn't use DNS settings the field is empty
    i am using my laptop wireless

    That's your problem - empty DNS settings. When using some (most? all?) routers you need to specify DNS server addresses in network manager if you are setting up your local IP address manually. That's why you can't browse the internet - no DNS resolution.

    Use the DNS addresses supplied by your ISP or use OpenDNS.
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  8. #8
    Join Date
    Nov 2006
    Beans
    67

    Re: I can't use ststic ip with wireless internet connection

    Quote Originally Posted by coffeecat View Post
    That's your problem - empty DNS settings. When using some (most? all?) routers you need to specify DNS server addresses in network manager if you are setting up your local IP address manually. That's why you can't browse the internet - no DNS resolution.

    Use the DNS addresses supplied by your ISP or use OpenDNS.
    Also Your router ip might work for dns.

  9. #9
    Join Date
    Dec 2009
    Beans
    42

    Re: I can't use ststic ip with wireless internet connection

    [QUOTE=ibrahim.k;8565526]i am using ubuntu 9.10 when i changed it into the manual ip adress using the network manager it was like this
    192.168.10.1
    255.255.255.0
    192.168.10.1
    I didn't use DNS settings the field is empty
    i am using my laptop wireless
    yes i have other computers on the local network I don't use dhcp mode with them
    thnx

    See the attached file for manual settings with explanations...
    Attached Files Attached Files

  10. #10
    Join Date
    Nov 2009
    Location
    Damascus
    Beans
    225
    Distro
    Kubuntu

    Re: I can't use ststic ip with wireless internet connection

    I have used this settings with my wireless but still not working
    192.168.10.1 (available)
    255.255.255.0
    192.168.0.1 (gateway wireless router)
    isp dns (82.137.200.86, 82.137.200.83)
    and didn't work anymore suggestions ?
    also i tried to use the gateway ip instead of the dns didn' work !
    Last edited by ibrahim.k; December 28th, 2009 at 09:01 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •