Results 1 to 7 of 7

Thread: picasa photo viewer

  1. #1
    Join Date
    Jan 2009
    Beans
    46

    picasa photo viewer

    i'm trying to install picasa and it's photo viewer that someone ported into linux. it's found here.

    i installed the latest linux picasa from google.com, which installed and worked fine. then i downloaded and installed the above link's deb file (Picasa Photo Viewer (Updated to 1.0.2 Requires Picasa 3). when i attempt to open a picture via the photo viewer, nothing happens. otherwise, picasa works fine. please help.
    Last edited by excbuntu; February 27th, 2009 at 10:54 PM.

  2. #2
    Join Date
    Feb 2008
    Location
    Decatur, GA
    Beans
    1,157
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: picasa photo viewer

    Can you start the photoviewer in the command line interface? Sometimes that will generate error messages you may not see in the GUI, especially if it's a custom program like this one.
    yeats - Ubuntu 13.04

  3. #3
    Join Date
    Mar 2009
    Beans
    2

    Re: picasa photo viewer

    Hi,
    I found this post while looking for solutions for the same problem described by chrissharp123.

    I tried to launch PicasaPhotoViewer from the terminal, even before I read your advice. The error is the following:

    run-detectors: unable to find an interpreter for
    /opt/google/picasa/3.0/wine/drive_c/Program
    Files/Google/Picasa3/PicasaPhotoViewer.exe

    I am not an expert, but it seems that it cannot launch the picasa-flavoured wine instance properly. This is strange, as the script (correctly?) calls the wine wrapper available in the Picasa folder.

    starlex.

  4. #4
    Join Date
    Mar 2009
    Beans
    2

    Red face Re: picasa photo viewer

    Update: I was almost ready to hit the bed, when I had a suspect. I installed WineHQ onto my system and tried again with the picasa photo viewer.
    Now the program opens fine, so I think that the previous problem was due to some missing dlls in the vanilla-wine provided with Picasa. Nevertheless, now it doesn't seem to recognise the path for my pictures (it always show some sample pictures from the picasa installation folder).

    When run from the terminal, the error now is:


    "errle:apartment_getclassobject DllGetClassObject returned error 0x80040111
    errle:create_server class {9ba05972-f6a8-11cf-a442-00a0c90a8f39} not registered
    fixmele:CoGetClassObject CLSCTX_REMOTE_SERVER not supported
    errle:CoGetClassObject no class object {9ba05972-f6a8-11cf-a442-00a0c90a8f39} could be created for context 0x17" ...

  5. #5
    Join Date
    Jul 2007
    Beans
    2

    Re: picasa photo viewer

    Hi starlex et al,

    no additional wine installation is needed! Please find a debian package of Picasa Photo Viewer at
    http://www.caiacoa.de/wiki/index.php...rt)_for_Ubuntu

    Cheers

    -caiacoa
    Last edited by caiacoa; June 19th, 2009 at 09:32 AM.

  6. #6
    Join Date
    Jun 2008
    Beans
    21

    Re: picasa photo viewer

    Quote Originally Posted by caiacoa View Post
    [...]Please find a debian package of Picasa Photo Viewer at
    http://www.caiacoa.de/wiki/index.php...rt)_for_Ubuntu
    Cheers
    -caiacoa
    Is there any solution to make it start faster? It takes a while to start the viewer after clicking on image.

  7. #7
    Join Date
    Feb 2010
    Beans
    1

    Lightbulb Re: picasa photo viewer

    For the many of us who dual boot (like myself), if Picasa is already installed in windows, you can associate image files in Ubuntu with PicasaPhotoViewer.exe and it will run natively (with wine installed).

    Prereqs: Install wine

    1. Right Click an image file (.png, .jpg, ...)
    2. Open With > Other Application
    3. > Use Other Command
    4. Enter one of the following:

    '/media/[nameOfWindowsPartion]/Program Files (x86)/Google/Picasa3/PicasaPhotoViewer.exe' (64bit Windows)
    - or -
    '/media/[nameOfWindowsPartion]/Program Files/Google/Picasa3/PicasaPhotoViewer.exe' (32bit Windows)

    In my case, I run 64-bit windows, my partition is labeled 'Win7'

    '/media/Win7/Program Files (x86)/Google/Picasa3/PicasaPhotoViewer.exe'

    If you do not mount your windows partition automagically after logging into Linux/Ubuntu, you will have to mount the partition before you can view image files.

    Point in case, this solution is for those who:
    a.) dual boot,
    b.) always mount his/her partition at system start,
    c.) really love picasa-photo-viewer.

    Hope this helps! And BTW, thanks @caiacoa for the linux port!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •