Page 4 of 4 FirstFirst ... 234
Results 31 to 33 of 33

Thread: Karmic: x200 tablet problem switching between tablet mode and back kills stylus

  1. #31
    Join Date
    Oct 2008
    Austin, TX
    Ubuntu 10.04 Lucid Lynx

    Re: Karmic: x200 tablet problem switching between tablet mode and back kills stylus

    Sorry to be dense but I'm missing something on the pages we're discussing.

    Am I supposed to create the FDI file then restart X11 -- what used to be CTRL-ALT-BACKSPACE?

    If that does not work, how do I back out? Where will I find the error logs to fix what does not work?

    ~~~ 8d;-/ Dan
    "All government spending, regardless of the motives, uses YOUR money."

  2. #32
    Join Date
    Nov 2008
    Ubuntu 12.04 Precise Pangolin

    Re: Karmic: x200 tablet problem switching between tablet mode and back kills stylus

    Not a problem. The instructions are in Section 2 b). You back up your current default 10-linuxwacom.fdi file and replace it with one of the modified ones so wacomcpl works for you. If you don't like it you can restore from back up. Or you can use one of the other options like rec's script.

    You have to enable ctrl-alt-backspace in Karmic. It was disabled on purpose upstream (not by Ubuntu) to prevent you from accidentally restarting X. So just reboot after you change the .fdi.

    Xorg.0.log in /var/log is usually a good place to start.

  3. #33
    Join Date
    Dec 2009

    Re: Karmic: x200 tablet problem switching between tablet mode and back kills stylus

    Hi Favux,

    Sorry for not responding for a long time; it's been a crazy term.

    I finally tried the linuxwacom-0.8.5-10, here's my experience with it so far:
    - i can only get everything (stylus, eraser, and touch) using the .fdi you provided in this thread (it's in page 1). I tried the .fdi from the HOWTO page to no avail.

    - multitouch works, with some catch. i like the second-touch-as-right-click feature. however, scrolling pages with two-finger touch is hit-and-miss; most of the time it'll just go and select (highlight) texts on the page and won't scroll. i might say it's worse than the previous one - but i have to double-check that ;p

    - typing (i'm typing this on Cellwriter) seems to work well even in rotated (portrait) mode. that said, single and double clicks works well for the most part. The catch is, the cursor still jumps around after you lift your finger off the screen. Unlike last time where it's somewhat related to the screen orientation, this time it seems rather random. It's still related to the screen orientation:
    - when rotated to the right (top of desktop on the right side): tapping on the screen's top side, when the finger is lifted the cursor is on the right side of the screen (although, only near the center of the screen, slightly over to the right), bottom --> left (edge), left --> top, right --> bottom.
    - when rotated upside-down (landscape), everything's the opposite: top-->bottom, bottom-->top, left-->right, right-->left.
    - when rotated to the left: top-->left, left-->bottom, bottom-->right, right-->top
    There's also seem to be some offset issues when rotated to the right/left... the area where the cursor lands after release is smaller than the screen. However, the touch basic functions like tap (click) and double-tap (double-click) works.

    so i guess i pretty much agree with your experience: it's hasn't quite addressed some of the issues in the 0.8.5-8 version ... i think.

    - Bungjamu

    UPDATE: I forgot to mention. I tried to configure Touch using wacomcpl. After tapping at the two calibration boxes, a message box appears saying: "There's something wrong with the configuration. But if you think it's working fine, ignore this message, otherwise try again." - or something on that note (I forgot the exact message). Well, after that, the Touch input goes wonky: the cursor doesn't appear where i tap on the screen, but somewhere else. Logging out and back in seemed to fix this.
    Last edited by bungjamu; March 15th, 2010 at 07:21 PM.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts