Results 1 to 2 of 2

Thread: force fsck not working

  1. #1
    Join Date
    Sep 2009
    Beans
    90

    force fsck not working

    When I run "sudo fsck -n" on my laptop with lucid installed, I get messages saying that there are errors on my file system.

    When I "sudo touch /forcefsck" and reboot, I get a message during boot-up that the disk is being checked for errors, as expected. However, when I run "sudo fsck -n" once it's booted-up, I can see that they are not resolved.

    When I run fsck from a 9.10 live cd, it says that the system is clean...

    What I would really like to do is boot-up without mounting the filesystem (like you can do on os x in single user mode) and then run "fsck -y" or something and see the output.

    Is there a way to do this, or some other way to fix my file system? Or is there something that I'm misunderstanding?

    Thanks for any help.

  2. #2
    Join Date
    Sep 2009
    Beans
    90

    Re: force fsck not working

    Well I tried setting FSCKFIX=yes in /etc/default/rcS as well as touching /forcefsck and I think that may have reduced the number of errors I'm getting, but I'm afraid my newish hard drive might be dying.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •