Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

  1. #1
    Join Date
    Apr 2008
    Beans
    48

    Unhappy Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Hey all,

    So I was re-ripping my cd library yesterday in Rhythmbox (I accidentally wiped my external drive a few weeks ago), and it worked fine for about 15 cd's, but then I ran an update and it seems it forgot how to encode flac. The option was completely missing from the "Preferred Formats" menu under Preferences -> Music.

    The weird part was that neither rhythmbox nor any gstreamer packages were updated:

    Code:
    The following packages will be upgraded:
      app-install-data-partner apport apport-gtk chromium-browser 
      chromium-browser-inspector chromium-codecs-ffmpeg libpython2.6 
      python-apport python-problem-report python2.6 python2.6-minimal
    I looked around and ended up reinstalling gstreamer0.10-plugins-good, but that didn't change anything either.

    Lastly, I tried adding the "flac" profile manually, copying over from another ubuntu machine; but it still didn't appear in the menu, so I couldn't test it.

    Is there a package I need to downgrade? A new package I need to install? How can I get rhythmbox to rip my cds in flac again?
    Attached Images Attached Images

  2. #2
    Join Date
    Oct 2006
    Location
    Ayrshire.
    Beans
    54,707
    Distro
    Ubuntu Development Release

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Check you have flac installed. Fire up synaptic and search for it.

  3. #3
    Join Date
    Apr 2008
    Beans
    48

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Ah, yes, I forgot to mention. I did install flac after this happened (sudo aptitude install flac), and it didn't change anything.

    Thanks for the reply, though!

  4. #4
    Join Date
    Apr 2008
    Beans
    48

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    ...I also tried opening Sound Juicer, and it says "The current audio profile is not available on your installation", with no hints as to how to make it so! erg!

  5. #5
    Join Date
    Jun 2007
    Beans
    13,143

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Hmm, maybe try this command and see if it lists flac:
    Code:
    $ gst-inspect-0.10 | grep flac
    Output on my box looks like:
    Code:
    ffmpeg:  ffdec_flac: FFmpeg FLAC (Free Lossless Audio Codec) decoder
    ffmpeg:  ffmux_flac: FFmpeg raw FLAC muxer
    typefindfunctions: application/x-id3v2: mp3, mp2, mp1, mpga, ogg, flac, tta
    typefindfunctions: application/x-id3v1: mp3, mp2, mp1, mpga, ogg, flac, tta
    typefindfunctions: audio/x-flac: flac
    flac:  flacenc: FLAC audio encoder
    flac:  flacdec: FLAC audio decoder
    flac:  flactag: FLAC tagger

  6. #6
    Join Date
    Apr 2008
    Beans
    48

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Looks pretty normal:

    Code:
    typefindfunctions: audio/x-flac: flac
    typefindfunctions: application/x-id3v1: tta, flac, ogg, mpga, mp1, mp2, mp3
    typefindfunctions: application/x-id3v2: tta, flac, ogg, mpga, mp1, mp2, mp3
    ffmpeg:  ffmux_flac: FFmpeg raw FLAC muxer
    ffmpeg:  ffdec_flac: FFmpeg FLAC (Free Lossless Audio Codec) decoder
    flac:  flactag: FLAC tagger
    flac:  flacdec: FLAC audio decoder
    flac:  flacenc: FLAC audio encoder
    Peace,
    --Jay

  7. #7
    Join Date
    Jun 2007
    Beans
    16,569

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Take a look here and see if it's active and if the pipeline command is correct
    Code:
    gconf-editor
    Attached Images Attached Images

  8. #8
    Join Date
    Dec 2006
    Location
    Earth
    Beans
    217
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    If all else fails, create a new profile:
    Edit > Preferemces > Music (tab)

    Click on the "Edit" button.

    When the menu opens, click on the "New" button.

    Name the new profile "CD Quality, Lossless"

    Highlight the new profile and click on the "Edit" button.

    In the box that says GStreamer pipeline:
    Code:
    audio/x-raw-int,rate=44100,channels=2 ! flacenc name=enc
    In the box that says File extension:
    Code:
    flac
    Tick the button that says "Active?"

    Click on the "Close" button.

    You should now have an option in the menu for CD Quality Lossless. Choose it. Close Rhythmbox, and re-open.

    You're done.
    I asked the Lord for patience and He led me to Linux
    Linux User #470874 | Ubuntu User #22063

  9. #9
    Join Date
    Apr 2008
    Beans
    48

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Ah, maybe I didn't make it clear. What I meant by "can't add" is that if I add a profile and click the "Active" checkbox, it still doesn't appear in the dropdown list of available formats in Rhythmbox. I would take a screenshot, but whatever screenshot thing I have doesn't work when a menu is open.

    ...so yes, I have a flac profile, and it looks just like that, and I have flac installed, but Rhythmbox seems not to know it. ...?

    Thanks for all your helpful responses so far though, I really appreciate you guys taking the time to help me.
    Last edited by Jayferd; December 17th, 2009 at 06:03 AM.

  10. #10
    Join Date
    Apr 2008
    Beans
    48

    Re: Rhythmbox/gstreamer: FLAC option not appearing in "Preferred Formats", can't add

    Here's my gconf-editor, too.
    Attached Images Attached Images

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •