Results 1 to 6 of 6

Thread: Synaptic won't let me force version

  1. #1
    Join Date
    Jul 2009
    Location
    Genève
    Beans
    24
    Distro
    Xubuntu 10.04 Lucid Lynx

    [SOLVED] Synaptic won't let me force version

    I followed the instructions available (in various places) to force a package version (Xvidcap ... I want the one I downloaded from Sourceforge, not the one in the repo, which won't record audio). But it won't do it. I select "Force version" from the "Package" menu in Synaptic, choose the version I want, and click "Force". The program works on something - but nothing happens. No changes are available to apply ... is there a manual way to do this? Update Manager keeps pestering me ...
    Last edited by jovean; December 15th, 2009 at 10:39 AM. Reason: solved

  2. #2
    Join Date
    Jun 2005
    Location
    South Dakota, US
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Synaptic won't let me force version

    It sounds to me like you probably shouldn't be doing this in the first place....

    If you want to isntall something from a different source, then you need to remove it from your system, before installing the other version.

    It's highly not recommended to install from a different source though.

    Your other option is to simply file a bug about it in launchpad.net.

  3. #3
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Wink Re: Synaptic won't let me force version

    Quote Originally Posted by jovean View Post
    I followed the instructions available (in various places) to force a package version (Xvidcap ... I want the one I downloaded from Sourceforge, not the one in the repo, which won't record audio). But it won't do it. I select "Force version" from the "Package" menu in Synaptic, choose the version I want, and click "Force". The program works on something - but nothing happens. No changes are available to apply ... is there a manual way to do this? Update Manager keeps pestering me ...
    As mtecknology states, uninstall previous version. Then, if it's a deb package, you can install using dpkg or gdebi gui.

  4. #4
    Join Date
    Jul 2009
    Location
    Genève
    Beans
    24
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: Synaptic won't let me force version

    I need the non-repo version because the version of Xvidcap in the repository doesn't support audio recording by default whereas the one on sourceforge does. Also, I did uninstall the repository version first, then install using gdebi ...

    And not to be thankless and annoying, but my question wasn't "should I be doing this?", but "how can I do this?" The real problem is not that I can't install the non-repo version, but that I can't convince Synaptic/Update Manager that I REALLY do not want the repository version.
    Last edited by jovean; December 14th, 2009 at 09:24 AM.

  5. #5
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Arrow Re: Synaptic won't let me force version

    If I understand what you're saying then you need to lock the current version so synaptic doesn't override??? Is that correct because that's not what one would infer from your initial question?

    Select the package in right pane of synaptic and go to the "Package" menu. Select "Lock Version" - put a check in box - and synaptic will ignore updates.

  6. #6
    Join Date
    Jul 2009
    Location
    Genève
    Beans
    24
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: Synaptic won't let me force version

    Thank you lidex - I was confused about terminology and didn't even know it. MarkingSolved.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •