Results 1 to 7 of 7

Thread: ubuntu 9.10 i386 livecd uses harddisk swap partition

  1. #1
    Join Date
    Dec 2007
    Beans
    48

    ubuntu 9.10 i386 livecd uses harddisk swap partition

    When using the livecd it automatically mounts the swap partition on my local harddisk. Typing the command 'free' in the terminal shows that the system uses allot of swap space including the local partition. Also typing 'sudo swapon -a" show the local hard-disk partition as being used for swap.

    This might be enabled for better performance on the livecd, but I think its bad because it alters the pc on which the livecd is running on.

    My final goal is creating a customized livecd without this swap behaviour.

    How do I disable this swapping and let it only use the swap in the compressed fs on the cd?
    http://ubuntuforums.org/showthread.php?t=518496

  2. #2
    Join Date
    Aug 2007
    Location
    Manchester, UK
    Beans
    10,285
    Distro
    Ubuntu

    Re: ubuntu 9.10 i386 livecd uses harddisk swap partition

    Using the swap area wouldn't alter the PC which the LiveCD is running on at all. And it will only use that swap partition if one exists - it wouldn't create one.

  3. #3
    Join Date
    Dec 2007
    Beans
    48

    Re: ubuntu 9.10 i386 livecd uses harddisk swap partition

    Quote Originally Posted by Joeb454 View Post
    Using the swap area wouldn't alter the PC which the LiveCD is running on at all. And it will only use that swap partition if one exists - it wouldn't create one.
    I'm not saying it creates one, it uses a existing swap area and therefore can leave marks like passwords or keys unencrypted on the local harddisk swap area.

    Is there a other way than typing after the livecd has booted "sudo swapoff -a" to turn this off by default?

  4. #4
    Join Date
    Dec 2007
    Beans
    48

    Re: ubuntu 9.10 i386 livecd uses harddisk swap partition

    Quote Originally Posted by walterav View Post
    I'm not saying it creates one, it uses a existing swap area and therefore can leave marks like passwords or keys unencrypted on the local harddisk swap area.

    Is there a other way than typing after the livecd has booted "sudo swapoff -a" to turn this off by default?
    Anyone?

  5. #5

    Re: ubuntu 9.10 i386 livecd uses harddisk swap partition

    on the one hand livecd OS should ask for permission from user to change hard disk content, on the other hand may be it will not show how will look real installed OS truly if asks about swap space on start. 2009-12-28 10:55 utc+3 : not, there is nothing bad if such option, live cd is already not like installed system, it asks for language and where too boot.
    Last edited by q.dinar; December 28th, 2009 at 08:57 AM.

  6. #6
    Join Date
    Mar 2009
    Beans
    166

    Re: ubuntu 9.10 i386 livecd uses harddisk swap partition

    I think that it is a bad idea to do ANYTHING with the HD from a Live CD, without explicit user permission. Swapping can only hurt a dying drive you are trying to get important files off of.

  7. #7
    Join Date
    Dec 2009
    Location
    Panama City, FL, USA
    Beans
    543
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: ubuntu 9.10 i386 livecd uses harddisk swap partition

    So you're wanting to make a LiveCD for your own personal use to make absolutely certain none of your passwords or encryption keys end up in an unencrypted swap partition anywhere you might take it?

    It seems like there should be an option for it. In Knoppix you can add noswap as a "cheat code."

    Either way if the first thing you do is run swapoff after boot the only password that might be recoverable would be the liveuser password for the CD, which is probably not that useful.

    If you're doing it in the context of rescuing a system you might try one of the more forensically-inclined LiveCDs like Backtrack, Helix, or Trinity Rescue Disk.

    P.S. swapon -a turns on all available swap, it's swapon -s that shows which swap files/partitions are in use.
    Last edited by adam814; December 28th, 2009 at 08:59 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •