Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Karmic--can't set static ip config

  1. #11
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Karmic--can't set static ip config

    Quote Originally Posted by shawnisalk View Post
    I don't understand why the wireless card isn't working, though.
    Your machine uses eth1 for wireless? My laptop does, as well, but wlan0 is another common alias. I presume you've checked lshw -C network to verify interface status.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  2. #12
    Join Date
    Aug 2009
    Beans
    14

    Red face Re: Karmic--can't set static ip config

    Hi, It is rather bad on the part of ubuntu that my internet connection changed for me after upgrading from 9.04 to 9.10. Earlier I had a static IP on the laptop and the new network manager refused to take a static IP. On doing networking restart, I would get the static IP. My solution: 1 sudo apt-get remove network-manager network-manager-gnome 2 Restarted system on dialog asking for same. 3 sudo apt-get install gnome-network-admin 4 Added 192.168.1.1 in DNS servers using network-admin Regards, KCN

  3. #13
    Join Date
    Aug 2009
    Location
    San Francisco
    Beans
    46
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Karmic--can't set static ip config

    I actually discovered a solution. I had previously uninstalled Network Manager.

    I re-installed it and of course, it wiped out any static settings I'd made.
    Then, instead of trying to edit Eth0 in Network Manager (which it would never let me do),
    I created a new network connection, defined it the way I wanted (statically) and then I deleted Eth0.

    So now I have what I wanted: wireless nic config'd via dhcp and ethernet nic config'd statically

    I just wish I had thought of that earlier.

    *shrug*

  4. #14
    Join Date
    Sep 2008
    Location
    Salt Lake City
    Beans
    207
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Karmic--can't set static ip config

    Quote Originally Posted by shawnisalk View Post
    I actually discovered a solution. I had previously uninstalled Network Manager.

    I re-installed it and of course, it wiped out any static settings I'd made.
    Then, instead of trying to edit Eth0 in Network Manager (which it would never let me do),
    I created a new network connection, defined it the way I wanted (statically) and then I deleted Eth0.

    So now I have what I wanted: wireless nic config'd via dhcp and ethernet nic config'd statically

    I just wish I had thought of that earlier.

    *shrug*
    I had the exact same problem as you did. Apply button was not available when attempting to set Manual config. However you can change the default ethO to manual. After clicking the IPV4 tab to edit select Manual(which you did) then click the add button in Addresses field and add your static IP hit Enter then click on Netmask(did you do this?)and you will be able to enter it, then
    click on Gateway and enter it.Either after clicking on Netmask
    or Gateway (I don't remember which) I noticed Apply was available.
    I couldn't figure out how to enter my Netmask/Gateway values when
    I just clicked on Netmask and the enter field appeared. Anyways this worked for me.

  5. #15
    Join Date
    Apr 2005
    Location
    Sintra, Portugal
    Beans
    835

    Re: Karmic--can't set static ip config

    Quote Originally Posted by ManyBeers View Post
    I had the exact same problem as you did. Apply button was not available when attempting to set Manual config. However you can change the default ethO to manual. After clicking the IPV4 tab to edit select Manual(which you did) then click the add button in Addresses field and add your static IP hit Enter then click on Netmask(did you do this?)and you will be able to enter it, then
    click on Gateway and enter it.Either after clicking on Netmask
    or Gateway (I don't remember which) I noticed Apply was available.
    I couldn't figure out how to enter my Netmask/Gateway values when
    I just clicked on Netmask and the enter field appeared. Anyways this worked for me.
    You're right, this works. I was kind of stuck and willing to try some more unconventional approaches, but fortunately I read your post. When I entered the Netmask info, the apply button appeared. Thanks.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •