Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Karmic--can't set static ip config

  1. #1
    Join Date
    Aug 2009
    Location
    San Francisco
    Beans
    46
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Cool Karmic--can't set static ip config

    Hello,

    I'm running Karmic on a Dell Inspiron and having problems I didn't have with Jaunty.

    One of those issues is this:
    I am unable to set eth0 with a static ip config.

    Through the Gnome interface in Network Connections, if I edit eth0, when I switch from DHCP, the "apply" button disappears. If set the configuration I want, anyway, and then close out that window, the changes are lost.

    I tried editing /etc/network/interfaces, and though I did it properly, this disabled the interfaces, altogether.

    I successfully set the IP of eth0 with ifconfig, but this brought down the connection (possibly because I couldn't find a way to set a DNS server through ifconfig).

    I have also tried all of these steps while logged in as root with the same results.

    Anyone have any ideas? I'm starting to curse the name Ubuntu...

    Thanks for help,
    Shawn

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Karmic--can't set static ip config

    What's the current state of things?
    Does /etc/network/interfaces have more than the two lines defining "lo"?
    Were you editing from the Network Manager applet, or from the pulldown menu?
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    Dec 2007
    Location
    The last place I look
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Karmic--can't set static ip config

    for dns servers, put them in /etc/resolv.conf
    Code:
    nameserver ###.###.###.###

  4. #4
    Join Date
    Aug 2009
    Location
    San Francisco
    Beans
    46
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Karmic--can't set static ip config

    Iowan--
    There are only two lines defining lo in /etc/network/interfaces

    I was editing from the pull-down menu: System--Preferences--Network Connections


    doas777--
    Thanks. I'll see if that gets me what I want.

  5. #5
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Karmic--can't set static ip config

    On at least one occasion, my Jaunty box would let me edit via the NM applet where the pull down would not (although they looked identical...)

    I've seen people put a nameserver line in /etc/network/interfaces, but the preferred way is (as mentioned) /etc/resolv.conf.
    Last edited by Iowan; December 10th, 2009 at 11:41 PM. Reason: Jaunty - not Jaumty
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  6. #6
    Join Date
    Oct 2007
    Beans
    77
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Karmic--can't set static ip config

    Quote Originally Posted by shawnisalk View Post
    I am unable to set eth0 with a static ip config.
    ...
    I tried editing /etc/network/interfaces, and though I did it properly, this disabled the interfaces, altogether.
    Here's what i had to do between 9.04 and 9.10 to fix the same problem.

    In /etc/network/interfaces, keep the lo lines as is, but replace the ethx lines with
    Code:
    auto eth0
    or equivalent. This enables DHCP, so your router better be handing out ip addresses.

    In /etc/NetworkManager/nm-*
    Keep the managed=false.

    Restart the computer and login.

    Add a new connection entry to the NetworkManager and adjust it to your requirements.

    Cheers.

  7. #7
    Join Date
    Dec 2007
    Location
    The last place I look
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Karmic--can't set static ip config

    Quote Originally Posted by imtheguru View Post
    Here's what i had to do between 9.04 and 9.10 to fix the same problem.

    In /etc/network/interfaces, keep the lo lines as is, but replace the ethx lines with
    Code:
    auto eth0
    or equivalent. This enables DHCP, so your router better be handing out ip addresses.

    In /etc/NetworkManager/nm-*
    Keep the managed=false.

    Restart the computer and login.

    Add a new connection entry to the NetworkManager and adjust it to your requirements.

    Cheers.

    I've always been under the impression that to enable DHCP, you still have to add an iface line:

    Code:
    auto eth0
    iface eth0 inet dhcp
    Things are rarely just crazy enough to work, but they're frequently just crazy enough to fail hilariously.

  8. #8
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Karmic--can't set static ip config

    Quote Originally Posted by doas777 View Post
    I've always been under the impression that to enable DHCP, you still have to add an iface line:
    I've always done it that way, too - otherwise, it seems like NM won't touch it, but the system doesn't know what to do with it either.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  9. #9
    Join Date
    Aug 2009
    Location
    San Francisco
    Beans
    46
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Karmic--can't set static ip config

    Welp. I've got an ethernet connection, now.

    I uninstalled Network Manager and config'd /etc/network/interfaces and /etc/resolv.conf
    (the lack of automation feels surprisingly Clean and Safe)

    I don't understand why the wireless card isn't working, though.
    I added

    "auto eth1
    iface eth1 inet dhcp"


    to interfaces but no luck. I think I could get it working by assigning it static IP, but I don't want to do that because of potential conflicts with other networks.

    Any other thoughts?

  10. #10
    Join Date
    Aug 2009
    Location
    San Francisco
    Beans
    46
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Smile Re: Karmic--can't set static ip config

    Thanks so much for your intelligent and helpful feedback, by the way (everyone).
    I really appreciate the support.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •