Page 5 of 5 FirstFirst ... 345
Results 41 to 49 of 49

Thread: Griffin Powermate (package for volume control and shutdown)

  1. #41
    Join Date
    Jan 2007
    Location
    USA, Tennessee
    Beans
    29

    Re: Griffin Powermate (package for volume control and shutdown)

    Thanks!

    Some questions and concerns:
    -Generating a group manually with an arbitrary group ID, instead of using the groupadd command, which will make sure that the ID created is the correct number and there are no clashes with existing groups. Why did you go with manually generating the group ID?

    -Allowing write access for the device to all with the dreaded 0666. This is asking for trouble on many levels. Can the permissions be reduced to 0640, with what you have assembled?


    Kindly,
    SHD

  2. #42
    Join Date
    Mar 2008
    Location
    KC
    Beans
    22
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: Griffin Powermate (package for volume control and shutdown)

    I tried, but it didn't work. Funny. And also the group ID keeps changing on every restart.
    --
    The Wickerman
    Ubuntu = sudo apt-get install freedom

  3. #43
    Join Date
    Jan 2007
    Location
    USA, Tennessee
    Beans
    29

    Re: Griffin Powermate (package for volume control and shutdown)

    OK, well then the groups will need to be manual with an arbitrary ID.

    How about the permissions? Did you try changing those?

    -S

  4. #44
    Join Date
    Feb 2014
    Beans
    30

    Re: Griffin Powermate (package for volume control and shutdown)

    I have been searching the internet trying to get my Griffin Powermate to work as a volume up/ down, mute on/off. I have tried various solutions that have been posted and I have searched this forum and tried most of the solutions in this thread. I am using ubuntu 12.04 with the LXDE desktop on this machine.


    Tried this: http://screamingroot.org/node/5
    Have created '/etc/evrouterrc' but the reference to this '(or $HOME/.evrouterrc)' confuses me a little.The final line 'Setup your session to auto-run powermate on login (or just be lazy like me and run it when you need it).' is something I don't understand - I don't even get how to run powermate manually. Also, I'm not sure if the commands here refer to volume control or some other functions.


    My group name is 'powermate' not 'video'. I am a member of the group, the evrouter daemon is running and seeing the powermate. The Power Mate is event 5, when I run 'sudo evrouter -d /dev/input/event5' I see '"Griffin PowerMate" "/dev/input/event5" none key/256 "fill this in!"
    ' (or rel/7/ + or - 1 when I turn the knob)


    Then I attempted the hesus-powermate package which I installed thru GDebi but when I went to look at the installed files (etc/hesus/ for example) they aren't there. If I click on the 'treminal' tab in GDebi it looks like some sort of error but the terminal window doesn't persist long enough for me to read it. In any event, it doesn't seem to install.


    The last things I attempted were to change the 'evrouterrc' file to:


    Window ""
    "Griffin PowerMate" "" any key/256 "XKey/XF86AudioMute"
    "Griffin PowerMate" "" any rel/7/1 "XKey/XF86AudioRaiseVolume"
    "Griffin PowerMate" "" any rel/7/-1 "XKey/XF86AudioLowerVolume"


    and change the ' /usr/local/bin/powermate ' to include the line :
    evrouter -c /etc/evrouterrc /dev/input/event5


    I also created '/etc/udev/rules.d/40-permissions.rules' with the code line 'ATTRS{product}=="Griffin PowerMate" GROUP="powermate", MODE="0666" '


    and then finally put this line in rc.local '/usr/local/bin/powermate'.




    Any help would be appreciated.


    mark springer
    industrial arts

  5. #45
    Join Date
    Jan 2007
    Location
    USA, Tennessee
    Beans
    29

    Re: Griffin Powermate (package for volume control and shutdown)

    I think you have pieces of different options going, but they are not going to work together.

    http://ubuntuforums.org/showthread.p...4#post12202644

    I recommend uninstalling everything you have tried and trying this option. If it works, and it probably will, then we can tweak from there. Otherwise, you have a system issue that needs further diagnosis.

    FWIT, evrouter-0.4 helped a lot to get it going for me.

    -SHD

  6. #46
    Join Date
    Feb 2014
    Beans
    30

    Re: Griffin Powermate (package for volume control and shutdown)

    Thanks, I was thinking that as well. I 'll go back and re-trace my steps and remove what I have installed. I may just re-install Ubuntu since this had been a side by side install with Windows and I will not be running that OS on this machine any longer.

    I do have evrouter 0.4 installed on the machine, so after I clean things up I may have an easier go of it.

    Thanks again, I will post again with my success - or more questions

  7. #47
    Join Date
    Aug 2007
    Location
    From the land down under
    Beans
    1,245
    Distro
    Ubuntu Development Release

    Re: Griffin Powermate (package for volume control and shutdown)

    Anyone have any ideas on getting the script to run on login?

    I've tried rc.local, a cronjob, the ubuntu startup applications program, none of them work.

    rc.local just doesn't appear to run, when I put in something to test it, i get output from the test but nothing from the script.

    cronjobs complain of no X display to output to, running the script as root in the current session appears to be the hard part.

    Anyone got it working? (Ubuntu 14.04)

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.

    /usr/local/bin/powermate.sh

    exit 0
    and my powermate.sh:

    #!/bin/sh
    /usr/bin/evrouter -c /etc/evrouterrc /dev/input/event12
    With 755 file permissions.
    Last edited by ikt; March 16th, 2014 at 03:06 PM.
    // Blog

  8. #48
    Join Date
    Feb 2014
    Beans
    30

    Re: Griffin Powermate (package for volume control and shutdown)

    Still having problems with getting this to work




    Did a new install of Fubuntu, installed evrouter and then installed 'PowerMate & Linx Mint.deb'. Went to check the files under etc/hesus and there weren't any. Tried a reboot and received an error (something about 'major systems error - sorry didn't make a note of it)


    Tried to create the /etc/apt/sources.list.d/bedroomlan.list file but couldn't figure how to with the new install. I had learned previouly to create new files using gksudo nautilus so I tried that and received no response. Figured I needed to install Nautilus an when I went to Synaptic I got this error:


    Software index is broken
    This is a major failure of your software management system. Please check for broken packages with synaptic, check the file permissions and correctness of the file '/etc/apt/sources.list' and reload the software information with: 'sudo apt-get update' and 'sudo apt-get install -f'.


    So I figured I needed to remove the hesus package but went I went to GDebi to remove I got this:
    E: The package hesus-powermate needs to be reinstalled, but I can't find an archive for it.
    E: Internal error opening cache (1). Please report.


    Added these lines to /etc/apt/sources.list file thinking that might be the problem. Not it (I didn't think so but a shot in the dark)
    deb http://debian.bedroomlan.org/debian/ unstable main non-free contrib
    deb-src http://debian.bedroomlan.org/debian/ unstable non-free contrib


    Searched for solution and tried sudo apt-get update and then sudo apt-get install -f. Got the hesus powermate error message in terminal. Finally tried sudo dpkg --remove --force-remove-reinstreq hesus-powermate


    and back to normal.


    But what is the problem and how do install the hesus powermate package? Is that what I am trying to do? I asssume this from the link you posted.


    Thanks
    mark springer
    industrial arts

  9. #49
    Join Date
    Feb 2014
    Beans
    30

    Re: Griffin Powermate (package for volume control and shutdown)

    Finally got it working -


    Followed the directions here : http://screamingroot.org/node/5


    but changed the group name in /etc/udev/rules.d/powermate.rules to powermate and made sure I was part of the powermate group.


    SUBSYSTEM=="input", ATTRS{idVendor}=="077d", ATTRS{idProduct}=="0410", SYMLINK+="powermate", MODE="660", GROUP="powermate"


    And then changed the content of /etc/evrouterrc from this:
    Window ""
    "Griffin PowerMate" "" any key/256 "XButton/2"
    "Griffin PowerMate" "" any rel/7/1 "XButton/5"
    "Griffin PowerMate" "" any rel/7/-1 "XButton/4"


    to this:
    Window ""
    "Griffin PowerMate" "" any key/256 "XKey/XF86AudioMute"
    "Griffin PowerMate" "" any rel/7/1 "XKey/XF86AudioRaiseVolume"
    "Griffin PowerMate" "" any rel/7/-1 "XKey/XF86AudioLowerVolume"
    from this site: http://www.mp3car.com/input-devices/...-in-linux.html


    and finally got the volume to work by running this command:


    'sudo evrouter -c /etc/evrouterrc /dev/powermate'
    from this link: http://www.linuxquestions.org/questi...se-4175490996/
    (see bottom of post)


    My questions now are:


    Why do I have to run it as sudo? I placed evrouterrc in the home folder but it wouldn't run using 'evrouter -c /etc/evrouterrc /dev/powermate'. I renamed the file .evrouterrc (which I learned makes it hidden) but still not running as regular user. Also, how would I get it to run on log in?






    Thanks


    Mark Springer
    industrial arts

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •