Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: no libcupsys2 at karmic ubuntu 9.10??

  1. #1
    Join Date
    Nov 2009
    Beans
    8

    no libcupsys2 at karmic ubuntu 9.10??

    Okay, here is the problem:

    I have 2 printers wanted to be run at the office. One of them is epson LQ1170, and another is Canon ir2016.
    Ubuntu 9.10 detects this printer, while ubuntu have drivers for Canon ir2016, it doesnt has the drivers for LQ1170.(If any of you know where to get a driver for epson LQ1170 linux version, please do tell me)
    Ubuntu drivers for Canon ir2016 doesnt seems to be compatible with the Canon ir2016~the printer is detected, but it doesnt want to print test page (the ubuntu realizes the job and considers it done, but nothing is printed).

    So I go to canon-asia.com, downloaded the driver for Canon ir2016/2020 for linux, installed it, and there goes my problem: No libcupsys2!

    The dependencies needed is libcupsys2-gnutls10 something like that~but I just cant install it through update package, the package doesnt even have libcupsys2 to begin with.

    Please help. ~~ office needed linux badly.

  2. #2
    Join Date
    Nov 2009
    Beans
    8

    Re: no libcupsys2 at karmic ubuntu 9.10??

    sudo aptitude update
    sudo aptitude install -f libcupsys2-gnutls10

    yields results saying that there is no package with the name: libcupsys2-gnutls10~~

    sudo aptitude install -f libcucpsys2-dev is successful.

    but I still cant get that libcupsys2-gnutls10 package

    installing libcupsys2-dev cant solve the problem
    when I double click on the Canon ir2016 linux installer (.deb), it tells me that there is dependencies required which is libcupsys2-gnutls10(>=1.1.23-1)
    Last edited by j3fk4; December 4th, 2009 at 07:27 AM.

  3. #3
    Join Date
    Dec 2009
    Beans
    2

    Re: no libcupsys2 at karmic ubuntu 9.10??

    didn't u try to make a symbolic????

  4. #4
    Join Date
    Nov 2009
    Beans
    8

    Re: no libcupsys2 at karmic ubuntu 9.10??

    Quote Originally Posted by wibinem View Post
    didn't u try to make a symbolic????
    symbolic?
    what is it?
    I am pretty noob in ubuntu 9.10 so please elaborate.
    what is it for?
    and how do I make one?

  5. #5
    Join Date
    Dec 2009
    Beans
    3

    Re: no libcupsys2 at karmic ubuntu 9.10??

    Quote Originally Posted by j3fk4 View Post
    symbolic?
    what is it?
    I am pretty noob in ubuntu 9.10 so please elaborate.
    what is it for?
    and how do I make one?
    I am also pretty new to ubuntu and currently trying to get a Canon Pixma MP810 to work on 9.10 ... In my attempts I installed -

    http://security.ubuntu.com/ubuntu/po...ntu3.4_all.deb

    which is a dummy to help the smooth transition from the package name libcupsys2 to the new name of libcups2

  6. #6
    Join Date
    Nov 2009
    Beans
    8

    Re: no libcupsys2 at karmic ubuntu 9.10??

    Quote Originally Posted by LilJohn!! View Post
    I am also pretty new to ubuntu and currently trying to get a Canon Pixma MP810 to work on 9.10 ... In my attempts I installed -

    http://security.ubuntu.com/ubuntu/po...ntu3.4_all.deb

    which is a dummy to help the smooth transition from the package name libcupsys2 to the new name of libcups2

    THIS ANSWER HITS THE SPOT!
    Thanks
    I can install the libcupsys2-gnutls now!
    But that doesnt mean I can install my printer yet, since now they need libglib2>.<
    but anyway, it is solved for now.

  7. #7
    Join Date
    Nov 2008
    Beans
    17

    Re: no libcupsys2 at karmic ubuntu 9.10??

    Thank you! This is the Holy Grail answer to this problem. So, here it is folks. If you're using karmic and originally had trouble with the default ubuntu driver having dark muddy colors like I did (someone may or may not get around to fixing it in the future, who knows..) , and you can't install the Canon official drivers, then get the newest libcupsys2 to libcups2 transitional package and install it first. I got mine at:
    http://altruistic.lbl.gov/mirrors/ub...ntu3.7_all.deb
    Install it, then get the canon driver deb tar. I got mine at:
    http://software.canon-europe.com/sof...811.asp?model=
    Extract the debs, install them, the "common" one first and the actual printer model deb second.
    I spent days trying to figure this out. But all is working now. And now I understand better what a transitional package is.

    On a side-note, it seems there should be some way of avoiding this. Something maybe in the package manager, maybe a comments section for each package. I mean, we have servers out there that tell us what Cds and track names we're listening to or about to convert. Can't we have a server that detects what package we're looking at installing and give us comments from the Ubuntu community for that particular package? I have more imagination than know-how, so I don't know how doable this is. Also, it is a different topic.
    I buntu. U?

  8. #8
    Join Date
    Aug 2008
    Location
    Wien (Vienna) Austria Eur
    Beans
    8
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: no libcupsys2 at karmic ubuntu 9.10??

    Thank you! After hours and hours of searching and trying to get my Canon iP3500 printing correctly with the original Canon drivers I found your link http://altruistic.lbl.gov/mirrors/ub...ntu3.7_all.deb
    which supported the final help. Now everything works fine also in Karmic Koala as it did resp. does in Hardy Heron. The libcupsys2-problem is solved. And I learned a lot by the way.

  9. #9
    Join Date
    Jul 2010
    Beans
    4

    Re: no libcupsys2 at karmic ubuntu 9.10??

    I the links to those .debs are broken, how can I find them?

  10. #10
    Join Date
    Apr 2006
    Beans
    13

    Re: no libcupsys2 at karmic ubuntu 9.10??

    Late reply here, but those debs can be found by hunting around the mirrors, for example.

    http://mirror.linux.org.mt/ubuntu/pool/universe/c/cups/

    Alas, there is further dependency hell after that one. Good luck.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •