Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

  1. #1
    Join Date
    Sep 2009
    Beans
    11

    D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    My D-Link DWL-G520+ card is not detected by Ubuntu 9.10, despite being detected automatically on Ubuntu 7.04, which I have been using previously until now.

    I have not tested with 9.04 or prior.

    ifconfig does not show the interface...

    user@ubuntuserver:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:13:46:99:eb:dd
    inet6 addr: fe80::213:46ff:fe99:ebdd/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10 errors:0 dropped:0 overruns:0 carrier:10
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:1836 (1.8 KB)
    Interrupt:10 Base address:0x1080

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)


    lspci shows the card. It's the last-but-one line. Incidentally the D-Link DFE-550TX Ethernet is detected and works on installation.

    user@ubuntuserver:~$ lspci
    00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
    00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
    00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
    00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
    00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
    00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
    00:0f.0 Ethernet controller: D-Link System Inc DL10050 Sundance Ethernet (rev 15)
    00:10.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface
    01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC AGP (rev 3a)


    There is nothing about the Wireless card in 'dmesg'. It shows the Ethernet card only.

    uname -mr
    2.6.31-14 Generic i386

    sudo /etc/init.d/networking restart

    * Reconfiguring network interfaces
    Ignoring unkown interface eth0=eth0.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,582
    Distro
    Ubuntu Development Release

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    Please see here: http://ubuntuforums.org/showthread.php?t=1321303

    I tested this by compiling the driver and patch without errors but I do not have the device to test it with.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Sep 2009
    Beans
    11

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    It didn't work for me, unfortunately. Results were unchanged and nothing listed in ifconfig. Thanks anyway.

    Does this mean that at some time in the past, the driver (which previously was included) has been dropped form Ubuntu?

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,582
    Distro
    Ubuntu Development Release

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    Results were unchanged and nothing listed in ifconfig.
    Did acx.ko get insmodded successfully? If so, please run:
    Code:
    dmesg | grep acx
    Please post the result.
    Does this mean that at some time in the past, the driver (which previously was included) has been dropped form Ubuntu?
    Not from Ubuntu, but from the 2.6.30-x, or so kernels, yes.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  5. #5
    Join Date
    Apr 2008
    Location
    Bulgaria
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    I have the same issue. Does anyone know how can this be enabled in Ubuntu 9 so that i can connect to internet?

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,582
    Distro
    Ubuntu Development Release

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    See post #1 here: http://ubuntuforums.org/showthread.php?t=1321303
    Follow the 'make' step with this:
    Code:
    sudo make -C /lib/modules/`uname -r`/build M=`pwd` modules_install
    There are a few other steps. First:
    Code:
    sudo cp /lib/firmware/acx/1.9.8.b/tiacx100 /lib/firmware
    sudo cp /lib/firmware/acx/1.9.8.b/tiacx100r0D /lib/firmware
    Next, let's load the module permanently:
    Code:
    sudo gedit /etc/rc.local
    Add a new line, just above 'exit 0.'
    Code:
    cd ~/acx/acx-20080210 && insmod acx.ko
    Use kate or nano or vim, if you don't have gedit. Upon reboot, you should have a new wireless interface, wlan0.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  7. #7
    Join Date
    Apr 2008
    Location
    Bulgaria
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    Hi. Thank you for that. I did it and upon reboot i still do not have wireless. It only shows wired.

    I had some problems getting "patch" but i downloaded it on windows and installed it manually

    So still does not detect the wireless card...

  8. #8
    Join Date
    Dec 2009
    Beans
    110
    Distro
    Ubuntu

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    I managed to get the Ax revision of this card operating with ndiswrapper in Karmic last night. Apologies if this is old ground, but I just grabbed the driver here :

    http://www.dlink.co.uk/cs/Satellite?...GB%2FDLWrapper

    Extracted it to a folder, pointed ndiswrapper at <folder>/driver/WinXP/GPLUS.inf and I was away.

    My network is running WEP, I've not tested with WPA.
    Last edited by changingstate; December 18th, 2009 at 02:15 PM. Reason: Remove stuff mentioned elsewhere

  9. #9
    Join Date
    Apr 2008
    Location
    Bulgaria
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    Erm i am running ubuntu. This is for windows...

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,582
    Distro
    Ubuntu Development Release

    Re: D-Link DWL-G520+ no longer detected on Ubuntu 9.10

    Quote Originally Posted by DaveBG View Post
    Erm i am running ubuntu. This is for windows...
    He is suggesting you use the Windows driver with ndiswrapper. https://help.ubuntu.com/community/Wi...er/Ndiswrapper
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •