Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: How do I disable Avahi??

  1. #1
    Join Date
    Mar 2006
    Beans
    38

    How do I disable Avahi??

    I have U 9.10 as well as U studio 9,10. Both display a message on startup that says something to the effect of 'localhost... network discovery service is disabled'
    How do I disable it permanently?
    TIA

    A

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: How do I disable Avahi??

    I thought I'd seen it under the System>Preferences>Startup Applications... but it's not there on this Jaunty laptop.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: How do I disable Avahi??

    Quote Originally Posted by aeh View Post
    I have U 9.10 as well as U studio 9,10. Both display a message on startup that says something to the effect of 'localhost... network discovery service is disabled'
    How do I disable it permanently?
    TIA

    A
    Edit the /etc/init/avahi-daemon.conf file to something like this:
    Code:
    # avahi-daemon - mDNS/DNS-SD daemon
    #
    # The Avahi daemon provides mDNS/DNS-SD discovery support (Bonjour/Zeroconf)
    # allowing applications to discover services on the network.
    
    description	"mDNS/DNS-SD daemon"
    
    start on (never
              and filesystem
    	  and started dbus)
    stop on stopping dbus
    ...

  4. #4
    Join Date
    Mar 2009
    Location
    Riniken, Switzerland
    Beans
    2
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How do I disable Avahi??

    I tried editing /etc/init/avahi-daemon.conf as suggested, but still get that irritating "network discovery service is disabled" pop-up every time that I login.

    The avahi-daemon would appear to be really stubborn! I have even tried deleting /usr/sbin/avahi-daemon, and still get the pop-up.

  5. #5
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: How do I disable Avahi??

    Check ps -ef | avahi to see if avahi is still running.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  6. #6
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,628

    Re: How do I disable Avahi??

    Disable:

    Code:
    sudo update-rc.d -f avahi-daemon remove
    Enable:

    Code:
    sudo update-rc.d avahi-daemon defaults

  7. #7
    Join Date
    Mar 2006
    Beans
    38

    Re: How do I disable Avahi??

    Thanx but the problem is still unsolved....

  8. #8
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,628

    Re: How do I disable Avahi??

    Since there is no System > Administration > Services, you could download Boot-up Manager and see if you can stop it through there.

  9. #9
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: How do I disable Avahi??

    Quote Originally Posted by wojox View Post
    Disable:

    Code:
    sudo update-rc.d -f avahi-daemon remove
    Enable:

    Code:
    sudo update-rc.d avahi-daemon defaults
    Quote Originally Posted by wojox View Post
    Since there is no System > Administration > Services, you could download Boot-up Manager and see if you can stop it through there.
    update-rc.d and bum installs/removes System-V style init scripts. In karmic, avahi-daemon is started/stopped by an Upstart job. So you cannot use update-rc.d and bum to disable the daemon.

    __________________________________________________ _____________

    It looks like avahi-daemon is also started when the network connection is established (/etc/network/if-up.d/avahi-daemon).

    To disable it, you must edit the file /etc/default/avahi-daemon as root:

    Code:
    gksu gedit /etc/default/avahi-daemon
    and add this line:
    Code:
    AVAHI_DAEMON_DETECT_LOCAL=0

  10. #10
    Join Date
    Mar 2009
    Location
    Riniken, Switzerland
    Beans
    2
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How do I disable Avahi??

    Thanx. Changing AVAHI_DAEMON_DETECT_LOCAL=1 to AVAHI_DAEMON_DETECT_LOCAL=0 in /etc/default/avahi-daemon has got rid of the irritating pop-up.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •