Results 1 to 5 of 5

Thread: digikam cr2 question

  1. #1
    Join Date
    Nov 2009
    Beans
    3

    digikam cr2 question

    Hi All,
    Pretty much a complete newbie here. Trying to get away from Windows. I am trying to set up a photo workflow in ubuntu 9.10. I use a Canon 500D T1i camera , shooting RAW. Since it is a new model, I've had to do some hacking because it is not supported in the stable releases of most of the photo editing software. I have gotten gimp,ufraw,dcraw all importing the raw files 'correctly' (what I mean by 'correctly' is that the colors are not all pink/purple - they look correct) and where applicable they will convert to jpeg,tiff or whatever correctly.
    For digital asset management,sorting and taging though I like the look of digiKam. Here is where I run into trouble. When I add an album in digiKam all looks well, I can 'correctly' view the raw files in the image browser. However, when I click the edit button (lets say I want to do a simple crop - not worth opening gimp for) the image looks all pink/purple in the image editor.

    I am pretty sure that this has to do with the version of either libkdcraw or libraw digiKam is using. It seems that it may have an embedded local version of these libraries that it uses. I have tried to install from tarballs updated versions of these libraries but to no avail, when I click list of supported cameras, I cannot seem to affect the versions of KDcraw or LibRaw that digikam reports.

    I've attached a screen shot showing the editor on the left and the viewer on the right. center is the version info for digikam.

    I may be in over my head here but I feel like I'm very close. Any help would be greatly appreciated.

    Regards,

    Barry
    Attached Images Attached Images

  2. #2
    Join Date
    Nov 2009
    Beans
    3

    Re: digikam cr2 question

    Anybody? Did I post this on the wrong forum?

  3. #3
    Join Date
    Nov 2009
    Beans
    3

    Re: digikam cr2 question

    Monday morning bump! Anybody?

  4. #4
    Join Date
    Jun 2005
    Location
    Framingham, MA
    Beans
    190
    Distro
    Kubuntu Development Release

    Re: digikam cr2 question

    Same problem here with Digikam 1.0.0.
    (Intel Core i7 860, 2x2GB, Gigabyte GA-P55-UD3L, Radeon HD 4550, Audigy2 ZS Platinum, Sonata) + Asus V6J + Lenovo IdeaPad U330
    YOU can make Kubuntu Lucid a solid distro | My Blog

  5. #5
    Join Date
    Jun 2005
    Location
    Framingham, MA
    Beans
    190
    Distro
    Kubuntu Development Release

    Re: digikam cr2 question

    A newer version of libkdcraw is in kdegraphics in KDE SC 4.4, so I solved this problem by upgrading to 4.4: http://www.kubuntu.org/news/kde-sc-4.4-rc-1

    The upgrade was a bit problematic, but it works now. Maybe you can grab just the newer dcraw libraries.
    (Intel Core i7 860, 2x2GB, Gigabyte GA-P55-UD3L, Radeon HD 4550, Audigy2 ZS Platinum, Sonata) + Asus V6J + Lenovo IdeaPad U330
    YOU can make Kubuntu Lucid a solid distro | My Blog

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •