Results 1 to 10 of 10

Thread: Kino not working on Karmic

  1. #1
    Join Date
    Aug 2009
    Beans
    6

    Question Kino not working on Karmic

    Hello,

    Kino used to work well on Ubuntu.

    However, when I updated to Ubuntu 9.10 it started to act really strange.

    Everything goes ahead like I am fast forwarding the video.

    Does anybody know how to fix this?

  2. #2
    Join Date
    Nov 2009
    Beans
    8

    Unhappy Re: Kino not working on Karmic

    Same problem here.
    I'm going to try building from source.

    I suspect it has something to do with pulse audio - I get lots of messages on the console:
    Code:
    Could not open ALSA device "/dev/dsp": No such file or directory
    ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM /dev/dsp

  3. #3
    Join Date
    Aug 2009
    Beans
    6

    Re: Kino not working on Karmic

    I get that audio error message too, but it is also fast forwarding the video.

  4. #4
    Join Date
    Nov 2009
    Beans
    8

    Angry Re: Kino not working on Karmic

    I built and installed kino-1.3.4 from source - same problem. There are lots of libfoo-dev packages required to do that. I noticed if I close Banshee Media Player, a wait a while (30 seconds perhaps) kino will play normally. But if I press stop/play it will go back to playing quickly and silently again.

    I'm not quite willing to nuke pulse-audio from this machine, but it might be worth a try if you don't mind the risk.

    - Nigel

  5. #5
    Join Date
    Nov 2009
    Beans
    8

    Re: Kino not working on Karmic

    There are some suggested workaround mentioned on the Kino site: http://www.kinodv.org/article/view/173/1/13/

    The first of these doesn't work for me: "try setting the Audio Device to plughw:0,0"

    The second works, but the audio is choppy: run Kino using the "padsp kino" command.

    So is pulse audio here to stay, or has it been declared some big terrible disaster already?

    - Nigel

  6. #6
    Join Date
    Aug 2009
    Beans
    6

    Re: Kino not working on Karmic

    Thanks! I will try these...

  7. #7
    Join Date
    Nov 2009
    Beans
    8

    Smile Re: Kino not working on Karmic

    Here is a workaround that works well for me.

    At the command line:
    Code:
    pasuspender kino
    Which suspends pulse audio and provides direct audio hardware access to kino.

    Rejoice and be happy.

    - Nigel

  8. #8
    Join Date
    Aug 2009
    Beans
    6

    Re: Kino not working on Karmic

    Thanks! That did it! Now both video and audio are ok!

  9. #9
    Join Date
    Feb 2007
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Kino not working on Karmic

    Quote Originally Posted by ukuli View Post
    Thanks! That did it! Now both video and audio are ok!
    Please remember to mark the thread as solved. Select "Thread Tools" and then Solved. Thanks.

  10. #10
    Join Date
    Aug 2006
    Location
    S.F. Bay Area
    Beans
    260
    Distro
    Ubuntu

    Re: Kino not working on Karmic

    Sweet! I'm having this issue right now so I'll give the above a try.

    Thanks!

    EDIT: Using "padsp kino" works beautifully! Thanks again!

    Peace...
    Last edited by tomdkat; December 2nd, 2009 at 11:08 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •