On my laptop wireless networking worked perfectly (8.04 — 9.04) until I upgraded to Ubuntu 9.10. Wireless was disabled and trying to bring it up resulted in "SIOCSIFFLAGS: Unknown error 132". After looking at dmesg I decided to look at rfkill and it appeared hard-blocked. I must tell you that my laptop does have a wireless switch (not exactly a switch but a push-button with LED) but I never used it and I'm not even sure it actually ever worked. Regardless, pressing it now doesn't put anything to dmesg, doesn't change rfkill state and doesn't do anything else except toggling the LED. After trying to google for a while I decided to backup my /home and do a fresh install. After installation finished, the first thing I did was to check rfkill, and it was not blocked! However, WiFi was still down because driver was not installed. So i did
apt-get install b43-fwcutter
and found that rfkill got hard-blocked again! And even after uninstalling b43-fwcutter it still remained the same. So I can guess that b43-fwcutter breaks rfkill upon installation, and this issue seems to be only for 9.10 because I never had any Wi-Fi problems before.

Now could you please advice what should I do in order to get my wireless up again?

Below is various information according to the guide:

Laptop model: Fujitsu-Siemens Amilo D 1840W
root@lyuda-laptop:/home/lyuda# lspci -nn | grep "Broadcom"
00:0b.0 Network controller [0280]: Broadcom Corporation BCM4303 802.11b Wireless LAN Controller [14e4:4301] (rev 02)
root@lyuda-laptop:/home/lyuda# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:03:0d:10:8b:3b  
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:19 Base address:0xe800 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@lyuda-laptop:/home/lyuda# iwconfig wlan0
wlan0     IEEE 802.11b  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@lyuda-laptop:/home/lyuda# lsmod | grep b43
b43                   122136  0 
b43legacy             117752  0 
mac80211              181236  2 b43,b43legacy
cfg80211               93052  3 b43,b43legacy,mac80211
led_class               4096  2 b43,b43legacy
ssb                    35300  3 b43,b43legacy,b44
root@lyuda-laptop:/home/lyuda# dmesg | grep b43
[    2.922723] b43-pci-bridge 0000:00:0b.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   18.979699] b43legacy-phy0: Broadcom 4301 WLAN found
[   19.004018] b43legacy-phy0 debug: Found PHY: Analog 0, Type 1, Revision 4
[   19.004044] b43legacy-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2053, Revision 2
[   19.024023] b43legacy-phy0 debug: Radio initialized
[   19.201052] b43legacy ssb0:0: firmware: requesting b43legacy/ucode2.fw
[   19.663797] b43legacy ssb0:0: firmware: requesting b43legacy/pcm4.fw
[   19.694143] b43legacy ssb0:0: firmware: requesting b43legacy/b0g0initvals2.fw
[   19.837407] b43legacy-phy0: Loading firmware version 0x127, patch level 14 (2005-04-18 02:36:27)
[   19.895253] b43legacy-phy0 debug: Chip initialized
[   19.895576] b43legacy-phy0 debug: 30-bit DMA initialized
[   19.895759] b43legacy-phy0 warning: LEDs: Unknown behaviour 0x44
[   19.895770] b43legacy-phy0 warning: LEDs: Unknown behaviour 0x46
[   19.895782] b43legacy-phy0 warning: LEDs: Unknown behaviour 0x12
[   19.895798] b43legacy-phy0 warning: LEDs: Unknown behaviour 0x4D
[   19.895844] b43legacy-phy0 debug: Wireless interface started
[   19.895882] b43legacy-phy0 debug: Adding Interface type 2
[   24.805043] b43legacy-phy0: Radio hardware status changed to DISABLED
[   24.805055] b43legacy-phy0 debug: Radio initialized
[   24.849022] b43legacy-phy0 debug: Removing Interface type 2
[   24.861143] b43legacy-phy0 debug: Wireless interface stopped
[   24.861282] b43legacy-phy0 debug: DMA-30 0x0260 (RX) max used slots: 1/64
[   24.861343] b43legacy-phy0 debug: DMA-30 0x0200 (RX) max used slots: 1/64
[   24.861405] b43legacy-phy0 debug: DMA-30 0x02A0 (TX) max used slots: 0/128
[   24.869034] b43legacy-phy0 debug: DMA-30 0x0280 (TX) max used slots: 0/128
[   24.877025] b43legacy-phy0 debug: DMA-30 0x0260 (TX) max used slots: 0/128
[   24.885647] b43legacy-phy0 debug: DMA-30 0x0240 (TX) max used slots: 0/128
[   24.893047] b43legacy-phy0 debug: DMA-30 0x0220 (TX) max used slots: 2/128
[   24.901032] b43legacy-phy0 debug: DMA-30 0x0200 (TX) max used slots: 0/128
[   24.909023] b43legacy-phy0 debug: Radio initialized
[   24.909039] b43legacy-phy0 debug: Radio initialized
root@lyuda-laptop:/home/lyuda# sudo lshw -C network
       description: Ethernet interface
       product: SiS900 PCI Fast Ethernet
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 91
       serial: 00:03:0d:10:8b:3b
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis900 driverversion=v1.08.10 Apr. 2 2006 duplex=half latency=64 link=no maxlatency=11 mingnt=52 multicast=yes port=MII speed=10MB/s
       resources: irq:19 ioport:e800(size=256) memory:dfffc000-dfffcfff memory:dffc0000-dffdffff(prefetchable)
       description: Network controller
       product: BCM4303 802.11b Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: b
       bus info: pci@0000:00:0b.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=b43-pci-bridge latency=64
       resources: irq:18 memory:dfffe000-dfffffff
  *-network DISABLED
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:90:4b:1d:20:be
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11b
root@lyuda-laptop:/home/lyuda# iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down

root@lyuda-laptop:/home/lyuda# lsb_release -d
Description:    Ubuntu 9.10
root@lyuda-laptop:/home/lyuda# uname -mr
2.6.31-14-generic i686
root@lyuda-laptop:/home/lyuda# sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...                                                                                                                [ OK ] 
root@lyuda-laptop:/home/lyuda# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes