Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: how to set bluetooth radio default off (afrer booting)?

  1. #1
    Join Date
    Nov 2009
    Location
    Estonia
    Beans
    2
    Distro
    Ubuntu 9.10 Karmic Koala

    how to set bluetooth radio default off (afrer booting)?

    Currently, the bluetooth radio is by default allways on after booting. How to set bluetooth radio default off?

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,506
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: how to set bluetooth radio default off (afrer booting)?

    You may have to look around in /proc/acpi to find where this is in your system. I suggest:
    Code:
    sudo gedit /etc/rc.local
    Add a line above 'exit 0' as follows:
    Code:
    echo "disabled" > /proc/acpi/ibm/bluetooth
    This may or may not be located in /proc/acpi/ibm in your system, please look around and customize to suit. On boot, the bluetooth LED blinks off in the last few seconds for me.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: how to set bluetooth radio default off (afrer booting)?

    I've found this to work better:

    Still edit the /etc/rc.local file, but instead add this line:
    Code:
    rfkill block bluetooth
    This will keep bluetooth turned off when you boot/login but you can still turn it on at will with the bluetooth applet in the panel.

  4. #4
    Join Date
    Dec 2009
    Location
    Bangalore, India
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: how to set bluetooth radio default off (afrer booting)?

    Quote Originally Posted by Wollombi View Post
    I've found this to work better:

    Still edit the /etc/rc.local file, but instead add this line:
    Code:
    rfkill block bluetooth
    This will keep bluetooth turned off when you boot/login but you can still turn it on at will with the bluetooth applet in the panel.
    Brilliant! it worked like a charm ... thanks!

  5. #5
    Join Date
    Mar 2007
    Beans
    9
    Distro
    Ubuntu 6.10 Edgy

    Re: how to set bluetooth radio default off (afrer booting)?

    I know this is a very old thread and all, but I had to chime in to say this worked great on my CR-48! Thanks!

  6. #6
    Join Date
    Feb 2011
    Beans
    1

    Re: how to set bluetooth radio default off (afrer booting)?

    Quote Originally Posted by Wollombi View Post
    I've found this to work better:

    Still edit the /etc/rc.local file, but instead add this line:
    Code:
    rfkill block bluetooth
    This will keep bluetooth turned off when you boot/login but you can still turn it on at will with the bluetooth applet in the panel.

    Worked perfectly, bluetooth applet is still running and can turn it back on, but radio is off after boot!

    *edit: This turns off the bluetooth LED on my ThinkPad as well, so it actually turns it off, in case others wanted to know...
    the only problem is, when I turn bluetooth on, then off again, for some reason the bluetooth-applet icon goes away, but can still use it through System -> Preferences -> Bluetooth
    (didn't do this before, but not a real issue)

    Thanks for the post!
    Last edited by mattsloper; February 25th, 2011 at 04:23 PM.

  7. #7
    Join Date
    May 2005
    Location
    Oslo, Norway
    Beans
    467
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: how to set bluetooth radio default off (afrer booting)?

    This worked for me on Natty, but I have since upgraded to Oneiric. /etc/rc.local still contains the line, but bluetooth is still on by default. Any advice?
    || My blog ||

  8. #8
    Join Date
    Feb 2006
    Beans
    15

    Re: how to set bluetooth radio default off (afrer booting)?

    Quote Originally Posted by kwaanens View Post
    This worked for me on Natty, but I have since upgraded to Oneiric. /etc/rc.local still contains the line, but bluetooth is still on by default. Any advice?
    For me, I noticed that at least on Ubuntu 11.10 (Oneiric), you can run rfkill without any other special permissions, so I just added
    Code:
    rfkill block bluetooth
    to gnome's "Startup Applications..." configuration menu.

    If it still doesn't work for you, try running the command in the terminal and see if you get some error back.

  9. #9
    Join Date
    May 2005
    Location
    Oslo, Norway
    Beans
    467
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: how to set bluetooth radio default off (afrer booting)?

    Thanks [Knuckles], that worked like a charm.
    Funnily enough, bluetooth is reenabled after the computer is back from suspend, so if you or anyone know how to deal with that as well, I'd much appreciate it!
    || My blog ||

  10. #10
    Join Date
    Feb 2006
    Beans
    15

    Re: how to set bluetooth radio default off (afrer booting)?

    Quote Originally Posted by kwaanens View Post
    Thanks [Knuckles], that worked like a charm.
    Funnily enough, bluetooth is reenabled after the computer is back from suspend, so if you or anyone know how to deal with that as well, I'd much appreciate it!
    I haven't tried this, but it should work.

    Create a file in /etc/pm/sleep.d/ called 70_disablebluetooth with the following contents.

    Code:
    #!/bin/bash
    case $1 in
        thaw|resume)
            rfkill block bluetooth
            ;;
        *)
            ;;
    esac
    
    exit $?
    Don't forget to mark it as executable:
    sudo chmod +x /etc/pm/sleep.d/70_disablebluetooth

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •