Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Ubuntu 9.10: Downgrade GDM to previous version

  1. #1
    Join Date
    May 2006
    Location
    Switzerland
    Beans
    2,541
    Distro
    Ubuntu 12.04 Precise Pangolin

    Ubuntu 9.10: Downgrade GDM to previous version

    As you may be aware the current version of GDM included with Ubuntu 9.10 leaves a lot to be desired ...

    Many people have complained about this. Me too. I even went so far and replaced the current GDM with KDM:
    http://ubuntuforums.org/showthread.p...23#post8337723

    Simply downgrading to the previous GDM did not seem to work ... Until now. I just ran across this posting:

    http://www.ubuntugeek.com/how-to-dow...10-karmic.html

    As the author clearly states in that posting: following those steps may break your system! Please: only proceed if you know what you do!

    Best thing probably would be you try that procedure on a virtual machine (e.g. inside VirtualBox or VMware) first before doing it for real on your real Ubuntu OS installation.

    I post this in the hope it might be useful to others who are disappointed with the new GDM just as myself ...

  2. #2
    Join Date
    May 2006
    Location
    Switzerland
    Beans
    2,541
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    OK, I just tried it and it works. The steps:

    • log out of your GNOME session


    • when at the GNOME login screen, hit Ctrl+Alt+F2 ... this should take you to the text console (you have several of those and you can switch between them using Ctrl+Alt+F1, Ctrl+Alt+F2, Ctrl+Alt+F3, and so on. It's like having multiple screens on the same computer. Your graphical desktop should usually be sitting and waiting for you on Ctrl+Alt+F7 ...)


    • We have to stop GNOME now:
      Code:
      sudo /etc/init.d/gdm stop
      (the system might complain slightly about those "init" commands being outdated, that Ubuntu uses new-style "upstart" commands and what not .... oh well, I'm oldschool ... )


    • Now we install the new old GDM 2.20:
      Code:
      sudo apt-get install gdm-2.20
      The packet manager will add a few extra packages as dependencies and ask for your confirmation. It will also warn you that a few other packages will be removed as consequence. Hit "Y" if you agree with what it wants to do ...


    • Once the new old GDM 2.20 has been installed a dialogue should appear on your screen, asking you which login manager you want to use: "gdm" or "gdm-2.20" ... Use the cursor keys to highlight "gdm-2.20" and then use the Tab key to highlight the "OK" button. Hit enter ....


    New old GDM 2.20 unfortunately has a slight bug in its config file and there are two methods to correct it.

    Method #1

    This means we have to edit the config file. This is the method that was suggested on "UbuntuGeek":
    http://www.ubuntugeek.com/how-to-dow...10-karmic.html

    Background info:

    There is a line in /etc/gdm/gdm.conf that says ... :
    Code:
    ...
    StandardXServer=/usr/X11R6/bin/X
    ...
    The highlighted part above is wrong ... On Ubuntu 9.10 there is no "/usr/X11R6" directory. If you rebooted your system now you'd now run into trouble and the GUI environment would not be able to start.

    Hence why that line needs to be corrected. Either manaually with whatever editor you see fit (vi, vim, nano, pico ...) or automated with "sed" as demonstrated on the web site above.

    I personally don't like that idea. What if there is an update? Chances are the config file would be overwritten and those changes might then be lost ... which means that after an update there might be unexpected troubles.

    Method #2 -- way easier:

    So instead I chose to give that config file what it wants ... I created the sub-directory it wants so its paths are correct now. The commands I used for this:

    Code:
    cd /usr
    sudo mkdir X11R6
    cd X11R6
    sudo ln -s /usr/bin bin
    The commands above create an empty directory with the name "X11R6", we go into that directory and then create a symbolic link between /usr/bin (where all the programs really are) and the "X11R6" directory, so that the programs underneath /usr/bin can now also be found as /usr/X11R6/bin but without wasting any extra space.

    Time to restart GDM:
    Code:
    sudo /etc/init.d/gdm start
    Or simply reboot:
    Code:
    sudo reboot

    In both cases the old GDM should start now and it should look exactly like the login screen in Jaunty. Best of all: it's themable again and all the GDM login themes that you may have used in the past should work tip top again.
    Last edited by scorp123; November 19th, 2009 at 10:48 PM.

  3. #3
    Join Date
    May 2006
    Location
    Switzerland
    Beans
    2,541
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    Oh ... sorry for my redundant post. Someone already posted instructions one week ago:

    http://ubuntuforums.org/showpost.php...39&postcount=1

    OK ... I suck at Google

  4. #4
    Join Date
    Jul 2007
    Beans
    18

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    well it helped me at any rate.

    thanks for the info

  5. #5
    Join Date
    Jul 2009
    Location
    hyperdimensional space
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    holy **** it worked lmao im typing from my lapop becuse my desktops ubuntu didint start XD but i found your kde thing and boom it ran although still kinda slow lol thanks

  6. #6
    Join Date
    Apr 2009
    Beans
    228

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    Quote Originally Posted by scorp123 View Post
    Oh ... sorry for my redundant post. Someone already posted instructions one week ago:

    http://ubuntuforums.org/showpost.php...39&postcount=1

    OK ... I suck at Google
    Not at all! Your post is valuable, because your Method#2 is so much safer. I'll give it a try.

    I had all but given up. THANKS

  7. #7
    Join Date
    Jul 2009
    Location
    Dayton Ohio USA
    Beans
    1,069
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    You may have missed this but a tool has been made to configure GDM2 http://ubuntuforums.org/showthread.p...highlight=GDM2

    You may be able to use gdm to your satisfaction.
    It's okay, I'm a limo driver

  8. #8
    Join Date
    Jan 2010
    Beans
    1

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    Both the methods of solving the /X11R6/ issue caused problems for me. The first method (removing the entry) caused Ubuntu to boot in low graphics mode and no GDM displayed. The second one made a lot of fuss about failing graphics and double displays until finally booting into GDM 2.20 (and thereafter working fine, mind you).

    For some reason it also switched out my grub background to a Debian logo.

    Strange.

  9. #9
    Join Date
    May 2009
    Location
    Bangalore, India
    Beans
    20
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Angry Re: Ubuntu 9.10: Downgrade GDM to previous version

    Hey,
    I tried downgrading. When i hit ctrl+alt+f2.. i get the black screen... but thr is nothing written there... it's an empty screen with a cursor and i can't enter any text. Pls help !

  10. #10
    Join Date
    Apr 2006
    Beans
    16

    Re: Ubuntu 9.10: Downgrade GDM to previous version

    To start, I suppose everyone has a different experience based on there hardware & preferences. One thing I can agree with, like a lot of people I'm finding, is that the new GDM sucks.

    I followed the steps provided to downgrade from 2.28 to 2.20 using method 2. Every time I turn on or restart my computer, I have a Xserver conflict error of 2 Xservers on the same display :0 that I have to choose 'yes' to get through. From what I can see, by choosing 'yes', it take the Xserver you want to display :1

    I find it annoying & wish I knew more on how to resolve the issue. Instead I've found a method that helps to a degree. Unfortunately, you'll still get that error the 1st time after downgrading, every time you update your kernel & video driver. If this process helps you too, then you gotta admit it's less annoying.

    What I did was:
    a) I created the directory for X11R6
    cd /usr
    sudo mkdir X11R6
    cd X11R6
    sudo ln -s /usr/bin bin

    b) Then I jumped down to the text console ctrl-alt-f1 to stop the gdm
    sudo /etc/init.d/gdm stop *as stated before, there is that issue that comes up but it still stops

    c) Then I removed the new gdm 2.28
    sudo apt-get remove gdm

    d) Then I installed the older gdm 2.20
    sudo apt-get install gdm-2.20

    e) Finally I rebooted
    sudo reboot

    Choose 'yes' when the Xserver error comes up so it can use display :1. Also, if you jump between different consoles, typically it's f7 for the default. Now with this change your using f9. As it did for me, I hope it makes your downgrading less painful.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •