Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: black screen on ubuntu 9.10 lenovo install.

  1. #11
    Join Date
    Nov 2009
    Location
    Dayton Oh,
    Beans
    6
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: black screen on ubuntu 9.10 lenovo install.

    not sure why I haven't thought of this before but has any one tried to write zeros to to your drive? that way its virtually a fresh drive....may give it a try. will update later.

  2. #12
    Join Date
    Jan 2008
    Location
    London, UK
    Beans
    14
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: black screen on ubuntu 9.10 lenovo install.

    I am also experiencing this problem, if any of you find a solution PLEASE let us know how you did it!
    good luck to ya' all and thanks ^__^

    EDIT: If you go over |"Install UBUNTU", press F4 and "run in safe graphics" mode ( or something along those lines), it should work.
    Worked for me, hope it works for you too ^_________^
    Last edited by devix91; January 10th, 2010 at 03:08 PM.

  3. #13
    Join Date
    Jan 2010
    Beans
    1

    Re: black screen on ubuntu 9.10 lenovo install.

    Hey,

    I had the same problem with a Toshiba Satellite a110. I tried the installation with a live CD of 9.04 Jaunty Jackalope and it worked without problems. I will try to upgrade to 9.10 afterwards.

  4. #14
    Join Date
    Feb 2010
    Location
    Chicago, IL
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: black screen on ubuntu 9.10 lenovo install.

    I have the Lenovo y550 too (the one with the t6500 Centrino). I initially installed 9.04 on the system (not dual-booting or anything) and everything worked great. Ran all of the updates, everything worked great. Upgraded to to 9.10 and black screen on boot. I could hear the chime when Ubuntu logged in, but nothing but black. The only thing I could do was hit escape while the GRUB was loading, and boot from the old kernel (I dont' remember the version numbers). The only problem when booting this way was that the trackpad wouldn't work. So I plugged in a usb mouse and everything else worked fine. Though, I didn't really want to carry a usb mouse around with me everywhere I took the laptop, so I reinstalled 9.04; ran all updates except the upgrade to 9.10; and now everything works great! I tried several things when I was getting the black screen, but nothing panned out.

    The re-install of 9.04 is the only non-irritating way to go, me thinks. Run all the updates, but don't upgrade to 9.10.

  5. #15
    Join Date
    Feb 2010
    Location
    Chicago, IL
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: black screen on ubuntu 9.10 lenovo install.

    So, I ended up following the instructions here and everything works great now!

    Here's what I did in a nutshell:

    1. Upgrade to Karmic (the same steps may work from a fresh install, but I haven't done it)

    2. After upgrading, you'll need to restart the computer. When the boot process hits the Grub screen (you may have to hit ESC to get to it), choose "Ubuntu 9.10, kernel 2.6.28-18-generic"... Upon booting, you may need to have a usb mouse handy, as the trackpad may not respond

    3. Ubuntu should have loaded. If it did, add 'deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu karmic main' and 'deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu karmic main' (without the quotes) to your repository list (System->Administration->Software Sources)

    4. Run update manager, you should have a whole bunch of packages that can be installed from the aforementioned sources

    5. From a terminal type: sudo cp /etc/X11/xorg.conf /etc/X11/xorg.confBAK, then run: sudo gedit /etc/X11/xorg.conf, and make the settings look like so:
    Code:
              Section "Device"
                  Identifier    "Configured Video Device"
                  Driver        "intel"
              EndSection
    
              Section "Screen"
                  Identifier     "Default Screen"
                  Monitor       "Configured Monitor"
                  Device        "Configured Video Device"
              EndSection
    5. Edit /etc/xdg/compiz/compiz-manager, and add 'INDIRECT="yes"' after the last line, like so:
    Code:
              COMPIZ_BIN_PATH="/usr/bin/"
              PLUGIN_PATH="/usr/lib/compiz/"
              COMPIZ_NAME="compiz.real"
              INDIRECT="yes"
    7. Reboot your computer, and everything should work okay.


    ** - 'Driver "intel"' is of course assuming that you have an Intel video card as opposed to NVidia. I've only done this with a Intel card.

    Please let me know if this works for you!
    Last edited by spyrule; March 17th, 2010 at 03:47 PM. Reason: dyslexia - Don't laugh, it's a real pblorem.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •