Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Gnome-do won't start in Karmic

  1. #1
    Join Date
    May 2006
    Location
    Boston, Mass. USA
    Beans
    35

    Gnome-do won't start in Karmic

    Please help with Gnome-Do! Since upgrading to Karmic I can't get it to start at all. Every time I run it I get the following error.

    Code:
    [Error 22:43:33.717] Missing login credentials. Please set login information in plugin configuration.
    
    (Do:9227): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
    
    Could not locate Tomboy on D-Bus. Perhaps it's not running?
    Microblogging.FriendSource "Microblog friends" encountered an error in Items: Object reference not set to an instance of an object.
    Microblogging.FriendSource "Microblog friends" encountered an error in Items: Object reference not set to an instance of an object.
    [Debug 22:43:35.600] Acquiring org.freedesktop.DBus session instance
    [Debug 22:43:35.603] Starting org.bansheeproject.CollectionIndexer
    
    Unhandled Exception: System.Exception: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bansheeproject.CollectionIndexer was not provided by any .service files
      at org.freedesktop.DBus.IBusProxy.StartServiceByName (System.String flags, UInt32 ) [0x00000] 
      at NDesk.DBus.Bus.StartServiceByName (System.String name, UInt32 flags) [0x00000] 
      at NDesk.DBus.Bus.StartServiceByName (System.String name) [0x00000] 
      at Banshee.Collection.Indexer.RemoteHelper.IndexerClient.Start () [0x00000] 
      at Banshee.Collection.Indexer.RemoteHelper.SimpleIndexerClient.Start () [0x00000]
    I've tried uninstalling and reinstalling it several times to no avail. Any help would be much appreciated.

    Cheers!

  2. #2
    Join Date
    Apr 2009
    Location
    Ellensburg, WA
    Beans
    1,441
    Distro
    Ubuntu

    Re: Gnome-do won't start in Karmic

    Did you remove wnck, tomboy and banshee recently? If not, did you upgrade recently?

  3. #3
    Join Date
    Mar 2009
    Location
    Earth
    Beans
    128

    Re: Gnome-do won't start in Karmic

    I get a similar error.

    I have a fresh install of Ubuntu 9.10.

    I don't think I removed any of the packages you mentioned.
    Code:
    (Do:3498): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
    
    Could not locate Tomboy on D-Bus. Perhaps it's not running?
    Firefox.PlacesItemSource "Firefox Places" encountered an error in UpdateItems: Object reference not set to an instance of an object.

  4. #4
    Join Date
    Nov 2009
    Location
    Dilapidated Apartment
    Beans
    3
    Distro
    Ubuntu

    Re: Gnome-do won't start in Karmic

    I can't remeber the error message I got, but I did get something similar when I attempted to install Gnome-Do.

    A friend told me to purge Mono and all it's related apps, and then reinstall Gnome-Do and related stuff again.... it worked.

    That is all I know. I'm new to Ubuntu, unfortunately.

  5. #5
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Gnome-do won't start in Karmic

    Quote Originally Posted by carleton View Post
    Please help with Gnome-Do! Since upgrading to Karmic I can't get it to start at all. Every time I run it I get the following error.

    Code:
    (Do:9227): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
    I wouldn't worry about this error.I get this on a fresh karmic install and gnome-do runs fine.
    With all the problems people are having with upgrading, I would do a backup and fresh install.
    I've had no major problems with karmic.

  6. #6
    Join Date
    Mar 2009
    Location
    Earth
    Beans
    128

    Re: Gnome-do won't start in Karmic

    stinkeye can you get Gnome Do to auto run?

    The reason I need to be able to run it from the terminal is so I can set it to run automatically when ubuntu starts.

    Mine works if I click the icon in the Gui. But I want it to load automatically.

    Kuro-Chinko are you using ubuntu 9.10? Have you got Gnome Do working on so that it auto starts?

    Also I don't have mono installed so purging it won't work.

    I have filed a bug on launchpad.

  7. #7
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Gnome-do won't start in Karmic

    Quote Originally Posted by Captain_Glen View Post
    stinkeye can you get Gnome Do to auto run?

    The reason I need to be able to run it from the terminal is so I can set it to run automatically when ubuntu starts.

    Mine works if I click the icon in the Gui. But I want it to load automatically.

    Kuro-Chinko are you using ubuntu 9.10? Have you got Gnome Do working on so that it auto starts?

    Also I don't have mono installed so purging it won't work.

    I have filed a bug on launchpad.
    Yes. Just select start gnome-do at login in preferences.
    I think you might find that gnome-do is built on mono.
    What window manager are you using?
    Last edited by stinkeye; November 20th, 2009 at 05:20 AM.

  8. #8
    Join Date
    Mar 2009
    Location
    Earth
    Beans
    128

    Re: Gnome-do won't start in Karmic

    I am using Compiz.

    But I found gnome-do works if I use metacity.

    Is there a solution to get it working with compiz?

  9. #9
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Gnome-do won't start in Karmic

    Quote Originally Posted by Captain_Glen View Post
    I am using Compiz.

    But I found gnome-do works if I use metacity.

    Is there a solution to get it working with compiz?
    Firstly I would make sure you are running compiz at startup by installing wmctrl
    Code:
    sudo apt-get install wmctrl
    Then after you restart run in terminal
    Code:
    wmctrl -m
    and it will tell you what window manager is running
    eg. I get
    Code:
    glen@karmic:~$ wmctrl -m
    Name: compiz
    Class: N/A
    PID: N/A
    Window manager's "showing the desktop" mode: OFF
    Although I don't have to on my machine you might want to try delaying the
    starting of gnome do until after compiz has loaded.
    This is a script I use for delaying the start of conky that I tested and will do the same for gnome-do.
    Code:
    #! /bin/bash
    until [ "$done" = "true" ]
    do
    	if [ $(dbus-send --print-reply --type=method_call --dest=org.freedesktop.compiz /org/freedesktop/compiz/dbus/screen0 org.freedesktop.compiz.list | wc -l) != 0 ]
    	then
    		DISPLAY=:0.0 gnome-do >/dev/null 2>&1 &
                    
                    
    		done="true";
    	else
    		echo "GNOME-DO IS WAITING"
    		done="false"
    		sleep 5;
    	fi
    done
    exit 0
    Save this in your home folder as start_do
    Right click on start_do properties > permissions and tick the execute box.
    Go to your gnome do preferences and untick start gnome-do at login.
    Open startup applications and add start_do to the startup programs
    by adding
    Code:
    /home/your-username/start_do
    in the command box.
    screenshot_033.png
    For this script to work you must have the Dbus plugin enabled.
    It is under utilities in CCSM.
    Restart and see if gnome-do loads.

  10. #10
    Join Date
    Mar 2009
    Location
    Earth
    Beans
    128

    Re: Gnome-do won't start in Karmic

    Thanks stinkeye that fixed it!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •