Results 1 to 7 of 7

Thread: Installing 9.10 on raid array installs grub-legacy, not grub2

  1. #1
    Join Date
    Oct 2009
    Location
    Los Angeles, CA
    Beans
    380
    Distro
    Ubuntu 10.04 Lucid Lynx

    Installing 9.10 on raid array installs grub-legacy, not grub2

    I've been trying to install Karmic on my RAID0 array (2 x WD 74 GB Raptors on Intel ICH7R SATA RAID on motherboard), and every time the installer installs grub-legacy, not grub2. Does anyone know a workaround to get grub2 installed? I tried upgrading the grub-legacy to grub2 per this site (http://www.unixnewbie.org/how-to-easily-upgrade-grub-2/), but that didn't work. I don't understand why Karmic installs grub-legacy on RAID but grub2 on single drives. Is this normal?

    Thank you in advance.
    Main: Intel Core i7 920 D0 @ 4.0GHz | Asus P6X58D Premium | 6 x 2GB Mushkin Redline 1600 7-8-7-24 | EVGA GeForce GTX 560 Ti | 6 x 1TB WD Caviar Black | Mint 15 Cinnamon / OS X 10.7.3
    Portable: Dell Mini 9 | OS X 10.6.7

  2. #2
    Join Date
    Jun 2007
    Beans
    17

    Re: Installing 9.10 on raid array installs grub-legacy, not grub2

    This might be some help though not exactly the same, see comments #14,#15,#16 here:
    https://bugs.launchpad.net/ubuntu/+s...ta/+bug/436340

  3. #3
    Join Date
    Oct 2009
    Location
    Los Angeles, CA
    Beans
    380
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Installing 9.10 on raid array installs grub-legacy, not grub2

    Thanks for the post. I'd pretty much come to the same conclusion as the last poster on that thread and just decided to stick with grub-legacy. Now I am able to triple-boot Karmic off my RAID array, Jaunty off one of my WD Caviar Blacks, and Win XP Pro off the other WD Caviar Black. It's just that when I posted this, I thought something was wrong because grub 2 was supposed to be the default bootloader for Karmic.
    Main: Intel Core i7 920 D0 @ 4.0GHz | Asus P6X58D Premium | 6 x 2GB Mushkin Redline 1600 7-8-7-24 | EVGA GeForce GTX 560 Ti | 6 x 1TB WD Caviar Black | Mint 15 Cinnamon / OS X 10.7.3
    Portable: Dell Mini 9 | OS X 10.6.7

  4. #4
    Join Date
    Dec 2008
    Location
    Scotland
    Beans
    17

    Re: Installing 9.10 on raid array installs grub-legacy, not grub2

    It appears as though I'm suffering from the same issue (in my thread here). Could you please tell me how you fixed your issue? "Decided to stick with grub-legacy"...how do you do that during installation? Thanks for any help.

  5. #5
    Join Date
    Oct 2009
    Location
    Los Angeles, CA
    Beans
    380
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Installing 9.10 on raid array installs grub-legacy, not grub2

    I read through your original thread and it seems to me that you want to set up your system slightly differently than what I've got. I have all my OSes on different drives (Karmic on the RAID array, Jaunty on one 1 TB drive, Windows on the other 1 TB drive) and I have set the boot order in BIOS to start up the RAID array first. This ensures that grub comes up first, which I have set up to chainload the other two. I prefer this setup because I don't have to worry about grub erasing NTLDR and vice versa. Each drive's MBR remains intact and I just choose which to boot first in BIOS.

    You, however, want to have both Karmic and Windows on two partitions on the same RAID array. To make this work (as I understand it), you would install Windows in the first partition and put Karmic in the second (Windows likes to be first). If you want Windows to have 110 GB, then you would have to reformat the RAID array so that the first partition is 110 GB and the second partition is 30 GB. Then, when you install Karmic in the second partition, you would install grub in (hd0) and have it chainload Windows.

    As far as sticking with grub-legacy is concerned, I just found that once I installed Karmic onto my RAID array, it had grub-legacy, not grub2, as its bootloader. Initially, I thought something was wrong because when I installed Karmic on a single drive, it (as it should) installed grub2 by default. But on my RAID array, I had grub-legacy by default. I tried upgrading my grub-legacy to grub 2 after the fact, but found that this didn't work. So I decided to just stick with grub-legacy.
    Last edited by Ginsu543; November 19th, 2009 at 12:28 PM.
    Main: Intel Core i7 920 D0 @ 4.0GHz | Asus P6X58D Premium | 6 x 2GB Mushkin Redline 1600 7-8-7-24 | EVGA GeForce GTX 560 Ti | 6 x 1TB WD Caviar Black | Mint 15 Cinnamon / OS X 10.7.3
    Portable: Dell Mini 9 | OS X 10.6.7

  6. #6
    Join Date
    Dec 2008
    Location
    Scotland
    Beans
    17

    Re: Installing 9.10 on raid array installs grub-legacy, not grub2

    Ok, thanks for the reply. For the moment I've just installed 9.1 on a portion of the 1TB drive again, leaving the RAID alone.

  7. #7
    Join Date
    Oct 2009
    Location
    Los Angeles, CA
    Beans
    380
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Installing 9.10 on raid array installs grub-legacy, not grub2

    Are you using grub-legacy or grub2?
    Main: Intel Core i7 920 D0 @ 4.0GHz | Asus P6X58D Premium | 6 x 2GB Mushkin Redline 1600 7-8-7-24 | EVGA GeForce GTX 560 Ti | 6 x 1TB WD Caviar Black | Mint 15 Cinnamon / OS X 10.7.3
    Portable: Dell Mini 9 | OS X 10.6.7

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •