Results 1 to 9 of 9

Thread: Kubuntu 9.10: Get iBus working

  1. #1
    Join Date
    Aug 2008
    Beans
    26
    Distro
    Ubuntu Development Release

    Lightbulb Kubuntu 9.10: Get iBus working

    After a while trying to figure out what was wrong with my installation, I finally get it to work properly, and would like to share with others that might be in the same situation (I could not see any post that gave me the answers I needed).

    First of all, iBus works great in Ubuntu 9.10, although you still need to do some tweak to get it working (already posted here). For KDE (4.3.1) on Kubuntu 9.10, however, the story is completely different.

    Most common errors are:
    - not installed by default
    - default repository does not work (starts but can not display the IM options)

    The solution was: recompile latest version, plus tweaks (I don't know if just the tweaks would work - someone try this first before getting the source).

    1) Get sources


    Go to:

    Code:
    http://code.google.com/p/ibus/downloads/list
    and download the latest (and stable) versions available (get ibus, ibus-table and the others you need).

    2) Install dependencies


    It took me a while to get through all the missing packages:

    Code:
    sudo apt-get install -y libglib2.0-dev libgtk2.0-dev libdbus-1-dev libgconf2-dev libanthy-dev swig python-dev

    3) Compile


    Go to each of the sources (ibus > ibus-table > etc) and type:

    Code:
    sudo ./configure
    sudo make
    sudo make install
    If you are not lucky to pass through this stage, you may need additional packages (that my machine already has, for instance build-essentials, etc). I am assuming the machine has a minimum of compiling tools (see other threads on this subject for details, i you need)


    4) Tweak 1: ~/.bashrc

    Append the following to your ~/.bashrc file:

    Code:
    export GTK_IM_MODULE=ibus
    export XMODIFIERS=@im=ibus
    export QT_IM_MODULE=ibus

    5) Tweak 2: im-switch


    From the command line, type:

    Code:
    im-switch -s ibus

    6) Start iBus


    Here you still need to setup the input methods in the list. Go to the try icon:

    Code:
    Right Click > Preferences > Input Method > Select Input Method > Add

    7) Logout/Login


    I actually rebooted just in case, but the im-switch turns valid after logging out.

    8) Done!


    And here (attachment) is how it should look like...
    Attached Images Attached Images

  2. #2
    Join Date
    Aug 2008
    Beans
    26
    Distro
    Ubuntu Development Release

    Talking Re: Kubuntu 9.10: Get iBus working

    Just forgot. To start the ibus (already posted here), just type:
    Code:
    ibus-daemon -d
    If you still have problems, one way I could toubleshoot the isues was through:

    Code:
    ibus-daemon -xrv
    which will log (verbosely or debug) on screen what's going wrong.

    If you did the bashrc tweak, it will be started automatically when you login next time.

  3. #3
    Join Date
    Oct 2006
    Beans
    Hidden!

    Re: Kubuntu 9.10: Get iBus working

    Thank you for providing this information.

    I could install ibus through the repository, so I didn't need to compile it.

    However, to make ibus work, instead of .bashrc I had to edit the .profile file.

    To make the ibus daemon start at boot, I had to go to System Settings, Advanced tab, Autostart, and add the ibus-daemon program. The command entry in the application tab needs to be changed to: "ibus-daemon -d".

  4. #4
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Kubuntu 9.10: Get iBus working

    Nice guide.

    If you use im-switch and point it to ibus, it should start the daemon upon boot, though unfortunately the panel applet will start *before* the GTK resource file is loaded. (That's the "theme file" that makes GTK apps look decent in KDE. So the panel will be grey and have weird fonts.)

    Using im-switch it should set the correct environment variables to make ibus available in all GTK, Qt and XIM apps.

    There's also an ibus-dev launchpad user with Intrepid, Karmic, Jaunty and Lucid ppas, with ibus packages updated regularly-ish, if you don't want to compile your own.

    ppa:ibus-dev/ibus-1.2-karmic
    ppa:japanese-testers/ppa
    ppa:japaneseteam/ppa
    ...

  5. #5
    Join Date
    Mar 2005
    Location
    Oslo, Norway.
    Beans
    205
    Distro
    Kubuntu 15.04 Vivid Vervet

    Re: Kubuntu 9.10: Get iBus working

    This guide doesn't seem to work for me
    I downloaded the source ibus, ibus-table and ibus-anthy (I need the japanese support).
    I compiled them apparently without problem.

    But:
    1) with the command
    im-switch -s ibus

    it says:
    Error: no configuration file "ibus" exists.
    Error: No action taken.
    even after a reboot.

    If i try to start the daemon, it says:
    ibus-daemon -d
    ibus-daemon: error while loading shared libraries: libibus.so.1: cannot open shared object file: No such file or directory

    Now I'll uninstall the sources and try again with the official packages from the repos. I see that they are updated to the last version. Why they should not work?

    I tried every possible guide and it still doesn't work what a mess. I use kubuntu 9.10 64bit.
    All over the place, from the popular culture to the propaganda system, there is constant pressure to make people feel that they are helpless, that the only role they can have is to ratify decisions and to consume.
    (Noam Chomsky)

  6. #6
    Join Date
    Oct 2009
    Location
    UK
    Beans
    4
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Kubuntu 9.10: Get iBus working

    I've got as far as downloading the ibus-source and ibus table, and they are sitting here on my desktop. What do I do with them now? That step seems to be missing from the guide above.

    I'm new to Linux, so I apologize for not knowing this.

    Cheers!

  7. #7
    Join Date
    Aug 2008
    Beans
    26
    Distro
    Ubuntu Development Release

    Talking Re: Kubuntu 9.10: Get iBus working

    Thanks everyone for the feedback. This solution posted here was what worked for me, and in deed I was already expecting different approaches (I got to realize this happens fairly often).

    KageTora, the step you are talking about is the (3), where you will need to compile the source code. Since this is probably your first time, you will also need to install:
    Code:
    sudo aptitude install build-essential
    Once you have that, you open your terminal and go to the directory where the source code is, and type the commands as described in the first post.

    Cheers,

  8. #8
    Join Date
    Apr 2008
    Beans
    10

    Re: Kubuntu 9.10: Get iBus working

    Thanks a million!
    Got ibus working on my system with your instructions.

  9. #9
    Join Date
    Jan 2010
    Beans
    1

    Re: Kubuntu 9.10: Get iBus working

    I had the same problem also, however after I reinstalled the system last night (the previous one was directly upgraded from 9.04) the installation for iBus appeared to be quite easy.

    Here is a detailed instruction link: http://www.pinyinjoe.com/linux/ubunt...nese-setup.htm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •