I bought a logitech wireless keyboard and mouse. I plugged in the usb receiver and followed the directions. Nothing happened. I left it plugged in and continued to use the PS2 keyboard while trying to resolve the issue. During this time I decided to upgrade to ubuntu 9.10. When my machine began to configure for the upgrade, prior to the actual download I happened to jostle the wireless mouse and noticed that the cursor moved. I tried the keyboard and it also worked. I continued the upgrade and all worked perfectly. Sadly I was using my windows partition to view a streaming netflix film (pretty much the only reason I have windows!) and left the machine on over night. Windows did some kind of automated system upgrade(hate them!!!) and in the morning the keyboard and mouse no longer worked.I tried to undo the windows upgrade but it did not change anything. I have searched and experimented but to no avail.

I have an HP Pavillion ADM 64 Dual Core
S 520 wirele3ss keyboard and mouse.
Ubuntu 9.10

Any idea exactly what gets disabled prior to an upgrade that might effect change in the behavior? Would the answer be in Xorg The device is being detected. I ran dmesg on the advice from another forum the receiver keyboard and mouse are there. I am not that familiar with editing the configuration files so I would appreciate some direction.

Thank you.