Page 12 of 114 FirstFirst ... 210111213142262112 ... LastLast
Results 111 to 120 of 1132

Thread: Wacom Bamboo Pen and Touch Series Development

  1. #111
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by kgingeri View Post
    Ah, ok - I figured likely. EDIT: I did try reinstating your _pt_ function but I get no response either.



    Code:
    # ls -l `locate hal-setup-wacom`
    -rwxr-xr-x 1 root root  9632 Oct 14 19:05 /usr/lib/hal/hal-setup-wacom
    -rwxr-xr-x 1 root root 16782 Nov 12 23:25 /usr/libexec/hal-setup-wacom
    -rwxr-xr-x 1 root root 16782 Nov  7 00:27 /usr/local/libexec/hal-setup-wacom
    Should I delete some - sym-link?
    I am thinking that the /usr/libexec/hal-setup-wacom is supposed to be in /usr/lib/hal. You might want to make a backup of the one in /usr/lib/hal and symlink it to the one in /usr/libexec. As for the one in /usr/local/libexec, I would either move it out or remove it. I am thinking that might have come from an install where the --prefix was not used.

    I am hoping that it will help it work, but I am thinking that there is something that we are missing in the 2.6.28 directory that is causing the kernel module to not stay bound.

  2. #112
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    I was looking at this link and I see that there was a similar problem like this a while back and people had to reload the kernel module. Have you tried this?

    EDIT: I think this bug explains the issue. From what I can tell, the /lib/udev/check-driver is not installed (EDIT2: I guess the file is there on my system--forgot to update the locate database). From Jaunty, I am finding this in that file:
    Code:
    #!/bin/sh
    #
    
    #logger check_driver called with: $1 - $2 - $3 -
    
    wanted=$1
    devpath=$2
    bustype=$3
    
    device=$(readlink /sys/$devpath/device)
    device=${device##*/}
    driver=$(readlink /sys/$devpath/device/driver)
    driver=${driver##*/}
    
    logger device $device is bound to the $driver driver
    
    if [ "$driver" != "$wanted" ]; then
        logger must rebind
        echo -n "$device" > /sys/$devpath/device/driver/unbind
        echo -n "$device" > /sys/bus/$bustype/drivers/$wanted/bind
    else
        logger no need to rebind
    fi
    Last edited by Ayuthia; November 13th, 2009 at 06:41 AM.

  3. #113
    Join Date
    Nov 2008
    Location
    Southern Ontario, Canada
    Beans
    296
    Distro
    Ubuntu UNR

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by Ayuthia View Post
    I was looking at this link and I see that there was a similar problem like this a while back and people had to reload the kernel module. Have you tried this?
    Ok, not getting any joy here at all Ayuthia. I have tried reloading wacom - to no avail.

    BTW This is what I did with hal-setup-wacom and then rebooted...
    Code:
    # ls -l `locate hal-setup-wacom `
    lrwxrwxrwx 1 root root    28 Nov 13 00:17 /usr/lib/hal/hal-setup-wacom -> /usr/libexec/hal-setup-wacom
    -rwxr-xr-x 1 root root 16782 Nov 13 00:24 /usr/libexec/hal-setup-wacom
    EDIT: I think this bug explains the issue. From what I can tell, the /lib/udev/check-driver is not installed (EDIT2: I guess the file is there on my system--forgot to update the locate database). From Jaunty, I am finding this in that file:
    ...
    I do not have stylus or any action from the tablet, at all. I'll check out the above. Funny, I went looking for xorg.conf in /etc/X11 and I don't have one - not even with updated locate!! I can't restart X as UNR comes with Option DontZap enabled. I'll check out how to put it into the fdi file maybe. I will also try rebooting and plugging in after - I've always left the tablet connected.

    I'll keep trying what I can but even the old 0.8.5-1 wacom.ko doesn't work now? I may have forgotten to do a 'make install' - I'll try that again too.

    EDIT: Oh, and I do have /lib/udev/check_driver - and it's the same as yours in Jaunty.
    EDIT: Think I'm turning in for the night - I'll catch up tomorrow again
    Last edited by kgingeri; November 13th, 2009 at 07:27 AM.

  4. #114
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by kgingeri View Post
    I do not have stylus or any action from the tablet, at all. I'll check out the above. Funny, I went looking for xorg.conf in /etc/X11 and I don't have one - not even with updated locate!! I can't restart X as UNR comes with Option DontZap enabled. I'll check out how to put it into the fdi file maybe. I will also try rebooting and plugging in after - I've always left the tablet connected.
    You will need to modify /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi and update the "input.keys" section to look like:
    Code:
        <match key="info.capabilities" contains="input.keys">
          <!-- If we're using Linux, we use evdev by default (falling back to
               keyboard otherwise). -->
          <merge key="input.x11_driver" type="string">keyboard</merge>
          <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
                 string="Linux">
            <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
            <merge key="input.x11_driver" type="string">evdev</merge>
          </match>
        </match>
    I am debating about going back to 0.8.4-3 where we know that it is stable. If we are not able to get this going in 0.8.5-3, I will start creating patches for both until we are able to get some progress with the 0.8.5-X version.

    Please let me know your thoughts on this.
    Last edited by Ayuthia; November 13th, 2009 at 07:45 AM.

  5. #115
    Join Date
    Nov 2008
    Location
    Southern Ontario, Canada
    Beans
    296
    Distro
    Ubuntu UNR

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by Ayuthia View Post
    You will need to modify /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi and update the "input.keys" section to look like:
    Code:
        <match key="info.capabilities" contains="input.keys">
          <!-- If we're using Linux, we use evdev by default (falling back to
               keyboard otherwise). -->
          <merge key="input.x11_driver" type="string">keyboard</merge>
          <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
                 string="Linux">
            <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
            <merge key="input.x11_driver" type="string">evdev</merge>
          </match>
        </match>
    Well I think the key binding is ok, it's a matter of something like:
    Code:
    <deviceinfo version="0.2">
      <device>
        <match key="input.originating_device" contains="if0">
          <match key="info.product" contains="Wacom">
            <merge key="input.x11_driver" type="string">wacom</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
            <merge key="info.product" type="string">stylus</merge>
            <merge key="input.x11_options.DebugLevel" type="string">12</merge>
            <merge key="input.x11_options.CommonDBG" type="string">12</merge>
            <merge key="input.x11_options.DontZap" type="boolean">off</merge>
              <append key="info.callouts.add" type="strlist">hal-setup-wacom</append>
              <append key="wacom.types" type="strlist">eraser</append>
              <append key="wacom.types" type="strlist">pad</append>
              <append key="wacom.types" type="strlist">touch</append>
          </match>
        </match>
      </device>
     ...
    - not sure tho.

    I am debating about going back to 0.8.4-3 where we know that it is stable. If we are not able to get this going in 0.8.5-3, I will start creating patches for both until we are able to get some progress with the 0.8.5-X version.
    Yeah, it seems very strange we can't get anything. I rebuilt for 0.8.5-1 and I have a stylus (evdev) which means no selection, stylus buttons etc.

    Now that I have a working touch pad, I can be of more assistance.

    ALso, I noticed in one the links to a thread you gave, some xsetwacom command that might be useful for setting the tablet buttons - once we get that far... sample is...
    Code:
    # Button <  set to + (Zoom in)
    xsetwacom set pad Button1 "core key +"
    # Button FN1  set to - (Zoom out)
    xsetwacom set pad Button2 "core key -"
    # Button > to Ctrl Z (undo)
    xsetwacom set pad Button3 "core key ctrl y"
    # Button FN2 to Ctrl Y (redo)
    xsetwacom set pad Button4 "core key ctrl z"
    Ok, I'm done for the day... or yesterday now, I guess

    EDIT: Oops, forgot to mention - no touch data seen in dmesg with version 0.8.5-1. I'll try 0.8.4-3 later today (after some sleep) and see if I see any.
    Last edited by kgingeri; November 13th, 2009 at 07:55 AM.

  6. #116
    Join Date
    Aug 2007
    Beans
    113

    Thumbs up Re: Wacom Bamboo Pen and Touch Series Development

    Good Morning Ayuthia,
    I went through all posts i missed last night and tried all. Also reinstalling kernel but nothing except for many:
    Code:
    (II) config/hal: Adding input device Wacom Bamboo Craft cursor
    (EE) PreInit returned NULL for "Wacom Bamboo Craft cursor"
    (EE) config/hal: NewInputDeviceRequest failed (8)
    in xorg.log that were not there in 0.8.5-3 first patches.

    Quote Originally Posted by Ayuthia View Post
    I am debating about going back to 0.8.4-3 where we know that it is stable. If we are not able to get this going in 0.8.5-3, I will start creating patches for both until we are able to get some progress with the 0.8.5-X version.

    Please let me know your thoughts on this.
    0.8.5-1 was only missing eraser functionality rest seemed to be fine why not continue from there?? Why do you think of going back to 0.8.4-3??

    I reinstalled 0.8.5-1 and if done correctly + reboot:

    0.8.5-1 in MyPaint:
    Stylus: OK
    Stylus Buttons: OK
    Tilting: OK
    Eraser: NONE
    Touch: NONE
    Touch Buttons: NONE

    0.8.4-3 in MyPaint:
    Stylus: OK
    Stylus Buttons: OK
    Tilting: OK
    Eraser: OK
    Touch: NONE
    Touch Buttons: NONE

    Other issue is to check the auto-created fdi that does give issues like no pressure in gimp and others. Pasting the test fdi pressure is back.

    Thanks for your great work,
    cheers....
    Last edited by dnprossi; November 13th, 2009 at 10:03 AM.

  7. #117
    Join Date
    Nov 2009
    Beans
    73

    Re: Wacom Bamboo Pen and Touch Series Development

    0.8.5-1 was only missing eraser functionality rest seemed to be fine why not continue from there?? Why do you think of going back to 0.8.4-3??
    I agree, except for the eraser I had all pen functionality with 0.8.5-1.

    Tilting: OK
    This might be a stupid question, but what do you mean by that?

  8. #118
    Join Date
    Aug 2007
    Beans
    113

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by rebecca2525 View Post
    This might be a stupid question, but what do you mean by that?
    Hi Rebecca2525,
    Some applications like git-downloaded MyPaint have stylus tilt input to which different paint functions are assigned. Eg. select a solid brush start painting with pen up-right then tilt and pen will start smudging..

    Nifty!!!

  9. #119
    Join Date
    Nov 2009
    Beans
    73

    Re: Wacom Bamboo Pen and Touch Series Development

    Quote Originally Posted by dnprossi View Post
    Hi Rebecca2525,
    Some applications like git-downloaded MyPaint have stylus tilt input to which different paint functions are assigned. Eg. select a solid brush start painting with pen up-right then tilt and pen will start smudging..
    Wow, I will have to look out for that.

  10. #120
    Join Date
    Apr 2007
    Location
    Mount Horeb, WI
    Beans
    4,312
    Distro
    Kubuntu Development Release

    Re: Wacom Bamboo Pen and Touch Series Development

    We can try going from 0.8.5-1. I have no problem with that. One concern is that 0.8.5-X is shifting enough that we lose stability at times so we might not have a good patch to submit. However, I am sure that it is easier to patch to the newer 0.8.5-X version once ours is ready.

    I will update the first post later today to reflect the change back to 0.8.5-1 for now. Since 0.8.5-1 is no longer available, I will keep a copy of it at linuxfans.keryxproject.org.

    So the next release today will be reverting back to 0.8.5.-1 and I will add the eraser back to the code also.

Page 12 of 114 FirstFirst ... 210111213142262112 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •